The Swift Package Index logo.Swift Package Index

Build Information

Failed to build ResearchKit with Swift 5.8 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-14.3.1.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.34.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/StanfordBDHG/ResearchKit.git
Reference: 2.2.30
Initialized empty Git repository in /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/StanfordBDHG/ResearchKit
 * tag               2.2.30     -> FETCH_HEAD
HEAD is now at 3f70adf Create XCFramework for release 2.2.30
Cloned https://github.com/StanfordBDHG/ResearchKit.git
Revision (git rev-parse @):
3f70adf898b5985ba15e25d5074d86a9c657d305
SPI manifest file found: $workDir/.spi.yml
SUCCESS checkout https://github.com/StanfordBDHG/ResearchKit.git at 2.2.30
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.8
Building package at path:  $workDir
https://github.com/StanfordBDHG/ResearchKit.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-14.3.1.app xcrun swift build --arch arm64
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.1
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.1
BUILD FAILURE 5.8 macosSpm

Build Machine: Mac 5