The Swift Package Index logo.Swift Package Index

Build Information

Failed to build SwiftCSVEncoder with Swift 5.7 for macOS (Xcode) using Xcode 14.2 at 0.2.0.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.28.4
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/scottmatthewman/swiftcsvencoder.git
Reference: 0.2.0
Initialized empty Git repository in /Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/scottmatthewman/swiftcsvencoder
 * tag               0.2.0      -> FETCH_HEAD
HEAD is now at d810868 Allow Boolean encoding to be governed by new BoolEncodingStrategy (#10)
Cloned https://github.com/scottmatthewman/swiftcsvencoder.git
Revision (git rev-parse @):
d8108683ce9fbdb8a8767fe4a43b49a1891e4509
SPI manifest file found: $PWD/checkout/.spi.yml
SUCCESS checkout https://github.com/scottmatthewman/swiftcsvencoder.git at 0.2.0
========================================
Build
========================================
Selected platform:         macosXcodebuild
Swift version:             5.7
Building package at path:  $PWD/checkout
Command line invocation:
    /Applications/Xcode-14.2.0.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies
User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph
package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.1
Resolved source packages:
  spi-builder-workspace: /Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace
Resolve Package Graph
package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.1
2024-01-03 18:02:15.379 xcodebuild[89346:7346781] Writing error result bundle to /var/folders/wy/f1cgtw1s2dq35nvlg5tpg7t00000gp/T/ResultBundle_2024-03-01_18-02-0015.xcresult
xcodebuild: error: Could not resolve package dependencies:
  package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.1
GENERIC FAILURE 5.7 macosXcodebuild

Build Machine: Mac 5