The Swift Package Index logo.Swift Package Index

Build Information

Failed to build XLIFFKit with Swift 5.7 for macOS (Xcode) using Xcode 14.2 at main.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.25.4
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/mattcomi/XLIFFKit.git
Reference: main
Initialized empty Git repository in /Users/admin/builds/Z6YBxSjp/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/mattcomi/XLIFFKit
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at a2367f4 Update README.md
Cloned https://github.com/mattcomi/XLIFFKit.git
Revision (git rev-parse @):
a2367f4942d8dda85538184eefdd5d0261cd71e9
SUCCESS checkout https://github.com/mattcomi/XLIFFKit.git at main
========================================
Build
========================================
Selected platform:         macosXcodebuild
Swift version:             5.7
Building package at path:  $PWD/checkout
Command line invocation:
    /Applications/Xcode-14.2.0.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/admin/builds/Z6YBxSjp/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies
User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/admin/builds/Z6YBxSjp/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph
Resolved source packages:
  spi-builder-workspace: /Users/admin/builds/Z6YBxSjp/0/finestructure/swiftpackageindex-builder/spi-builder-workspace
package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.1
Resolve Package Graph
package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.1
2023-11-21 10:25:55.638 xcodebuild[57146:54153108] Writing error result bundle to /var/folders/n8/pp_chp6x3jlfy1n94r6hdjv40000gn/T/ResultBundle_2023-21-11_10-25-0055.xcresult
xcodebuild: error: Could not resolve package dependencies:
  package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.1
GENERIC FAILURE 5.7 macosXcodebuild