The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build ProductHunt with Swift 5.10 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.10-latest swift build --triple x86_64-unknown-linux-gnu 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.34.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/appcraftconsulting/producthunt.git
Reference: 1.0.3
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/appcraftconsulting/producthunt
 * tag               1.0.3      -> FETCH_HEAD
HEAD is now at 7fd185e Updates images in README
Cloned https://github.com/appcraftconsulting/producthunt.git
Revision (git rev-parse @):
7fd185e352806a3745e4dfcae2ae18c9d263c5ab
SUCCESS checkout https://github.com/appcraftconsulting/producthunt.git at 1.0.3
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.10
Building package at path:  $workDir
https://github.com/appcraftconsulting/producthunt.git
Running build ...
bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.10-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
Building for debugging...
[0/3] Write sources
[1/3] Copying Assets.xcassets
[2/3] Write swift-version-24593BA9C3E375BF.txt
[4/16] Compiling ProductHunt ProductHuntButton.swift
[5/17] Compiling ProductHunt PHVotesCount.swift
[6/17] Compiling ProductHunt resource_bundle_accessor.swift
error: emit-module command failed with exit code 1 (use -v to see invocation)
[7/17] Compiling ProductHunt Color.swift
[8/17] Compiling ProductHunt Font.swift
[9/17] Compiling ProductHunt String.swift
[10/17] Compiling ProductHunt UIColor.swift
[11/17] Emitting module ProductHunt
/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:15:6: error: Objective-C interoperability is disabled
    @objc internal dynamic var productHuntVotesCount: Int {
    ~^~~~~

[12/17] Compiling ProductHunt PHButton.swift
[13/17] Compiling ProductHunt PHManager.swift
[14/17] Compiling ProductHunt PHPost.swift
[15/17] Compiling ProductHunt PHResponse.swift
[16/17] Compiling ProductHunt UIFont.swift
/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:15:6: error: Objective-C interoperability is disabled
    @objc internal dynamic var productHuntVotesCount: Int {
    ~^~~~~

/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:20:9: error: cannot find 'setValue' in scope
        setValue(votesCount, forKey: key)
        ^~~~~~~~
[17/17] Compiling ProductHunt UserDefaults.swift
/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:15:6: error: Objective-C interoperability is disabled
    @objc internal dynamic var productHuntVotesCount: Int {
    ~^~~~~

/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:20:9: error: cannot find 'setValue' in scope
        setValue(votesCount, forKey: key)
        ^~~~~~~~
error: fatalError
[0/1] Planning build
Building for debugging...
[0/1] Write swift-version-24593BA9C3E375BF.txt
[2/4] Compiling ProductHunt UIFont.swift
[3/4] Compiling ProductHunt UserDefaults.swift
/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:15:6: error: Objective-C interoperability is disabled
    @objc internal dynamic var productHuntVotesCount: Int {
    ~^~~~~

/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:20:9: error: cannot find 'setValue' in scope
        setValue(votesCount, forKey: key)
        ^~~~~~~~
error: emit-module command failed with exit code 1 (use -v to see invocation)
[4/4] Emitting module ProductHunt
/host/spi-builder-workspace/Sources/ProductHunt/Extensions/UserDefaults.swift:15:6: error: Objective-C interoperability is disabled
    @objc internal dynamic var productHuntVotesCount: Int {
    ~^~~~~

error: fatalError
BUILD FAILURE 5.10 linux