The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build StorageKit with Swift 5.9 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4606859-1":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build --triple x86_64-unknown-linux-gnu 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.35.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/NikSativa/StorageKit.git
Reference: main
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/NikSativa/StorageKit
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 41316e9 fix typo
Cloned https://github.com/NikSativa/StorageKit.git
Revision (git rev-parse @):
41316e97f62d7f4720a58feb1eac5daf32885aef
SUCCESS checkout https://github.com/NikSativa/StorageKit.git at main
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.9
Building package at path:  $workDir
https://github.com/NikSativa/StorageKit.git
Running build ...
bash -c docker run --rm -v "checkouts-4606859-1":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
Building for debugging...
[1/10] Compiling StorageKit KeychainStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[2/10] Compiling StorageKit StorageComposition.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[3/11] Compiling StorageKit InMemoryStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[4/11] Compiling StorageKit FileStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[5/11] Compiling StorageKit UserDefaultsStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
error: emit-module command failed with exit code 1 (use -v to see invocation)
[6/11] Emitting module StorageKit
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[7/11] Compiling StorageKit Storage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[8/11] Compiling StorageKit Expirable.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[9/11] Compiling StorageKit Keychain.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[10/11] Compiling StorageKit AnyStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[11/11] Compiling StorageKit Defaults.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
error: fatalError
[0/1] Planning build
Building for debugging...
[1/10] Compiling StorageKit KeychainStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[2/10] Compiling StorageKit FileStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[3/10] Compiling StorageKit InMemoryStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[4/11] Compiling StorageKit Storage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[5/11] Compiling StorageKit StorageComposition.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
error: emit-module command failed with exit code 1 (use -v to see invocation)
[6/11] Emitting module StorageKit
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[7/11] Compiling StorageKit Expirable.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[8/11] Compiling StorageKit Keychain.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[9/11] Compiling StorageKit AnyStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[10/11] Compiling StorageKit Defaults.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
[11/11] Compiling StorageKit UserDefaultsStorage.swift
/host/spi-builder-workspace/Source/Defaults.swift:1:8: error: no such module 'Combine'
import Combine
       ^
error: fatalError
BUILD FAILURE 5.9 linux