The Swift Package Index logo.Swift Package Index

Build Information

Failed to build ResearchKit with Swift 5.7 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4609320-1":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.7-latest swift build --triple x86_64-unknown-linux-gnu 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.34.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/StanfordBDHG/ResearchKit.git
Reference: 2.2.30
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/StanfordBDHG/ResearchKit
 * tag               2.2.30     -> FETCH_HEAD
HEAD is now at 3f70adf Create XCFramework for release 2.2.30
Updating files:  90% (3610/3981)
Updating files:  91% (3623/3981)
Updating files:  92% (3663/3981)
Updating files:  93% (3703/3981)
Updating files:  94% (3743/3981)
Updating files:  95% (3782/3981)
Updating files:  96% (3822/3981)
Updating files:  97% (3862/3981)
Updating files:  98% (3902/3981)
Updating files:  99% (3942/3981)
Updating files: 100% (3981/3981)
Updating files: 100% (3981/3981), done.
Cloned https://github.com/StanfordBDHG/ResearchKit.git
Revision (git rev-parse @):
3f70adf898b5985ba15e25d5074d86a9c657d305
SPI manifest file found: $workDir/.spi.yml
SUCCESS checkout https://github.com/StanfordBDHG/ResearchKit.git at 2.2.30
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.7
Building package at path:  $workDir
https://github.com/StanfordBDHG/ResearchKit.git
Running build ...
bash -c docker run --rm -v "checkouts-4609320-1":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.7-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.3
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.7.3
BUILD FAILURE 5.7 linux

Build Machine: Linux 2