The Swift Package Index logo.Swift Package Index

Build Information

Failed to build RealityGeometries with Swift 5.9 for Linux.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.27.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/maxxfrazer/RealityGeometries.git
Reference: 1.1.1
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/maxxfrazer/RealityGeometries
 * tag               1.1.1      -> FETCH_HEAD
HEAD is now at 6e3ce73 moved special Package.swift to the 5.9 version, and added spi yml
Cloned https://github.com/maxxfrazer/RealityGeometries.git
Revision (git rev-parse @):
6e3ce738df779a38f55c2cd532d6103844790636
SPI manifest file found: $PWD/checkout/.spi.yml
SUCCESS checkout https://github.com/maxxfrazer/RealityGeometries.git at 1.1.1
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.9
Building package at path:  $PWD/checkout
Running build ...
bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$PWD/checkout" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build 2>&1
Building for debugging...
error: emit-module command failed with exit code 1 (use -v to see invocation)
[1/9] Emitting module RealityGeometries
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[2/10] Compiling RealityGeometries RealityGeometry.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[3/10] Compiling RealityGeometries CompleteVertex.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[4/10] Compiling RealityGeometries MeshResource+Extensions.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[5/10] Compiling RealityGeometries RealityGeometry+Cylinder.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[6/10] Compiling RealityGeometries RealityGeometry+Path.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[7/10] Compiling RealityGeometries RealityGeometry+Torus.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[8/10] Compiling RealityGeometries RealityGeometry+Tube.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[9/10] Compiling RealityGeometries RealityGeometry+Cone.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[10/10] Compiling RealityGeometries RealityGeometry+Planes.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
error: fatalError
[0/1] Planning build
Building for debugging...
error: emit-module command failed with exit code 1 (use -v to see invocation)
[1/9] Emitting module RealityGeometries
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[2/9] Compiling RealityGeometries CompleteVertex.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[3/9] Compiling RealityGeometries MeshResource+Extensions.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[4/10] Compiling RealityGeometries RealityGeometry+Planes.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[5/10] Compiling RealityGeometries RealityGeometry+Torus.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[6/10] Compiling RealityGeometries RealityGeometry.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[7/10] Compiling RealityGeometries RealityGeometry+Tube.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[8/10] Compiling RealityGeometries RealityGeometry+Path.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[9/10] Compiling RealityGeometries RealityGeometry+Cone.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
[10/10] Compiling RealityGeometries RealityGeometry+Cylinder.swift
/host/spi-builder-workspace/Sources/RealityGeometries/CompleteVertex.swift:8:8: error: no such module 'RealityKit'
import RealityKit
       ^
error: fatalError
BUILD FAILURE 5.9 linux

Build Machine: Linux 2