The Swift Package Index logo.Swift Package Index

Build Information

Failed to build Source with Swift 5.7 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4606859-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.7-latest swift build --triple x86_64-unknown-linux-gnu 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.33.2
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/blackjacx/Source.git
Reference: 1.11.0
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/blackjacx/Source
 * tag               1.11.0     -> FETCH_HEAD
HEAD is now at c3efecc Merge branch 'release/1.11.0'
Cloned https://github.com/blackjacx/Source.git
Revision (git rev-parse @):
c3efeccfdf587a4d57c655c992a6478fbc878e2c
SUCCESS checkout https://github.com/blackjacx/Source.git at 1.11.0
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.7
Building package at path:  $workDir
https://github.com/blackjacx/Source.git
Running build ...
bash -c docker run --rm -v "checkouts-4606859-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.7-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.10.0 but the installed version is 5.7.3
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.10.0 but the installed version is 5.7.3
BUILD FAILURE 5.7 linux

Build Machine: Linux 1