The Swift Package Index logo.Swift Package Index

Build Information

Failed to build ResearchKit with Swift 5.8 for iOS using Xcode 14.3 at 2.2.30.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.34.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/StanfordBDHG/ResearchKit.git
Reference: 2.2.30
Initialized empty Git repository in /Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/StanfordBDHG/ResearchKit
 * tag               2.2.30     -> FETCH_HEAD
HEAD is now at 3f70adf Create XCFramework for release 2.2.30
Cloned https://github.com/StanfordBDHG/ResearchKit.git
Revision (git rev-parse @):
3f70adf898b5985ba15e25d5074d86a9c657d305
SPI manifest file found: $workDir/.spi.yml
SUCCESS checkout https://github.com/StanfordBDHG/ResearchKit.git at 2.2.30
========================================
Build
========================================
Selected platform:         iOS
Swift version:             5.8
Building package at path:  $workDir
https://github.com/StanfordBDHG/ResearchKit.git
Command line invocation:
    /Applications/Xcode-14.3.1.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies
User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
resolved source packages:
2024-04-03 00:00:08.834 xcodebuild[25390:3099393] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.1
error: fatalError
GENERIC FAILURE 5.8 iOS

Build Machine: Mac 5