Swift Package Index


Swift Module Map for PostgreSQL Server Extensions


  • The latest stable release is 1.0.3. Released over 1 year ago.
  • The last commit to master was over 1 year ago.

Swift Version Compatibility

  • 1.0.3 and master
    5.3
    5.2
    5.1
    5.0
    4.2
Full build results

Platform Compatibility

  • 1.0.3 and master
    iOS
    macOS(Intel)
    macOS(ARM)
    Linux
    tvOS
    watchOS
Full build results

PostgreSQL Swift3 Swift4 Swift5 macOS tuxOS

A Swift system library package (C wrapper) for PostgreSQL server extensions. This package is part of the PL/Swift effort.

Using the Package

Important: This version of the package requires that you install plswift. It installs the necessary shims.

Setup your Package.swift to include CPLSwift for either Swift 4.2 or later:

import PackageDescription

let package = Package(
  name: "MyTool",
	
  dependencies: [
    .Package(url: "git@github.com:PL-Swift/CPLSwift.git", from: "1.0.0"),
  ]
)

Import the CPLSwift module.

import CPLSwift

Note: If you are still using a Swift before Swift 4.2, there is a branch for that. Use from: 0.3.0 in your dependency.

Who

PL/Swift is brought to you by ZeeZide. We like feedback, GitHub stars, cool contract work, presumably any form of praise you can think of.