Swift Package Index

PerfectMongoDB

https://github.com/perfectlysoft/perfect-mongodb.git

A stand-alone Swift wrapper around the mongo-c client library, enabling access to MongoDB servers.


Compatibility

  • 3.1.2 and master
    5.3
    5.2
    5.1
    5.0
    4.2
  • 3.1.2 and master
    iOS
    macOS(Intel)
    macOS(ARM)
    Linux
    tvOS
    watchOS

Perfect - MongoDB Connector 简体中文

NOTE: This package is deprecated in favour of the official Mongo Swift Driver. We advise users to switch to that package if possible.

--

This project provides a Swift wrapper around the mongo-c client library, enabling access to MongoDB servers.

This package builds with Swift Package Manager and is part of the Perfect project. It was written to be stand-alone and so does not require PerfectLib or any other components.

Ensure you have installed and activated the latest Swift 4.0 tool chain.

macOS Build Notes

This package requires the Homebrew build of mongo-c.

To install Homebrew:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

To install mongo-c:

brew install mongo-c-driver

Linux Build Notes

Ensure that you have installed components below:

apt-get install libmongoc-dev libbson-dev libssl-dev

Building

Add this project as a dependency in your Package.swift file.

.package(url: "https://github.com/PerfectlySoft/Perfect-MongoDB.git", from: "3.0.0")

Documentation

Further information can be found at perfect.org.