Swift Package Index

PerfectPostgreSQL

https://github.com/perfectlysoft/perfect-postgresql.git

A stand-alone Swift wrapper around the libpq client library, enabling access to PostgreSQL servers.


Compatibility

  • 4.0.0 and master
    5.3
    5.2
    5.1
    5.0
    4.2
  • 4.0.0 and master
    iOS
    macOS(Intel)
    macOS(ARM)
    Linux
    tvOS
    watchOS

Perfect - PostgreSQL Connector

This project provides a Swift wrapper around the libpq client library, enabling access to PostgreSQL servers.

This package builds with Swift Package Manager and is part of the Perfect project. It was written to be stand-alone and so does not require PerfectLib or any other components.

Ensure you have installed and activated the latest Swift 4.0 tool chain.

macOS Build Notes

This package requires the Home Brew build of PostgreSQL.

To install Home Brew:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

To install postgres:

brew install postgres

Linux Build Notes

Ensure that you have installed libpq-dev.

sudo apt-get install libpq-dev

Building

Add this project as a dependency in your Package.swift file.

.Package(url: "https://github.com/PerfectlySoft/Perfect-PostgreSQL.git", majorVersion: 3)

Documentation

For more information, please visit perfect.org.