Build Information
Failed to build swift-noise, reference master (61dbc9), with Swift 6.1 for Linux on 29 Oct 2026 00:18:04 UTC.
Build Command
bash -c docker run --pull=always --rm -v "checkouts-53886768-0":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:linux-6.1-latest swift build --triple x86_64-unknown-linux-gnu 2>&1Build Log
========================================
RunAll
========================================
Builder version: 5.1.4
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/tayloraswift/swift-noise.git
Reference: master
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: git branch -m <name>
From https://github.com/tayloraswift/swift-noise
* branch master -> FETCH_HEAD
* [new branch] master -> origin/master
HEAD is now at 61dbc9c [autosync]
Cloned https://github.com/tayloraswift/swift-noise.git
Revision (git rev-parse @):
61dbc9ca7443d543e60b5edfa02a2ba0f3da37c9
SUCCESS checkout https://github.com/tayloraswift/swift-noise.git at master
========================================
Build
========================================
Selected platform: linux
Swift version: 6.1
Building package at path: $PWD
https://github.com/tayloraswift/swift-noise.git
https://github.com/tayloraswift/swift-noise.git
WARNING: environment variable SUPPRESS_SWIFT_6_FLAGS is not set
Running build ...
bash -c docker run --pull=always --rm -v "checkouts-53886768-0":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:linux-6.1-latest swift build --triple x86_64-unknown-linux-gnu -Xswiftc -Xfrontend -Xswiftc -stats-output-dir -Xswiftc -Xfrontend -Xswiftc .stats -Xswiftc -strict-concurrency=complete -Xswiftc -enable-upcoming-feature -Xswiftc StrictConcurrency -Xswiftc -enable-upcoming-feature -Xswiftc DisableOutwardActorInference -Xswiftc -enable-upcoming-feature -Xswiftc GlobalActorIsolatedTypesUsability -Xswiftc -enable-upcoming-feature -Xswiftc InferSendableFromCaptures 2>&1
linux-6.1-latest: Pulling from saguaro1/spi-images
Digest: sha256:b6bfb4c5da2c5a0e111d7eb0c087cb4f5887cce9a34b7779faa557952c747cfc
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:linux-6.1-latest
Fetching https://github.com/tayloraswift/swift-png
Fetching https://github.com/ordo-one/dollup
[1/56] Fetching dollup
[57/7682] Fetching dollup, swift-png
Fetched https://github.com/ordo-one/dollup from cache (3.14s)
Fetched https://github.com/tayloraswift/swift-png from cache (3.23s)
Computing version for https://github.com/ordo-one/dollup
error: Dependencies could not be resolved because 'dollup' contains incompatible tools version (6.2.0) and root depends on 'dollup' 1.0.1..<2.0.0.
Running build ...
bash -c docker run --pull=always --rm -v "checkouts-53886768-0":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:linux-6.1-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
linux-6.1-latest: Pulling from saguaro1/spi-images
Digest: sha256:b6bfb4c5da2c5a0e111d7eb0c087cb4f5887cce9a34b7779faa557952c747cfc
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:linux-6.1-latest
Updating https://github.com/ordo-one/dollup
Updated https://github.com/ordo-one/dollup (0.29s)
Updating https://github.com/tayloraswift/swift-png
Updated https://github.com/tayloraswift/swift-png (0.24s)
Computing version for https://github.com/ordo-one/dollup
error: Dependencies could not be resolved because 'dollup' contains incompatible tools version (6.2.0) and root depends on 'dollup' 1.0.1..<2.0.0.
BUILD FAILURE 6.1 linux