The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build Markdown with Swift 5.10 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.3.0-Beta.2.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.29.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/twostraws/markdown.git
Reference: 1.0.0
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/twostraws/markdown
 * tag               1.0.0      -> FETCH_HEAD
HEAD is now at ad895d1 Updated README.
Cloned https://github.com/twostraws/markdown.git
Revision (git rev-parse @):
ad895d1cd77d4f6b6775497cbff7b0c5995f7485
SUCCESS checkout https://github.com/twostraws/markdown.git at 1.0.0
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.10
Building package at path:  $workDir
https://github.com/twostraws/markdown.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.3.0-Beta.2.app xcrun swift build --arch arm64
Building for debugging...
[0/2] Write sources
[1/2] Write swift-version--423B1241ED78D482.txt
error: emit-module command failed with exit code 1 (use -v to see invocation)
[3/5] Emitting module Markdown
<module-includes>:1:9: note: in file included from <module-includes>:1:
#import "discount.h"
        ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/discount/discount.h:1:10: error: 'mkdio.h' file not found
#include <mkdio.h>
         ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/Markdown/Markdown.swift:1:8: error: could not build Objective-C module 'Discount'
import Discount
       ^
[4/5] Compiling Markdown Markdown.swift
<module-includes>:1:9: note: in file included from <module-includes>:1:
#import "discount.h"
        ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/discount/discount.h:1:10: error: 'mkdio.h' file not found
#include <mkdio.h>
         ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/Markdown/Markdown.swift:1:8: error: could not build Objective-C module 'Discount'
import Discount
       ^
[5/5] Compiling Markdown ParseOptions.swift
<module-includes>:1:9: note: in file included from <module-includes>:1:
#import "discount.h"
        ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/discount/discount.h:1:10: error: 'mkdio.h' file not found
#include <mkdio.h>
         ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/Markdown/Markdown.swift:1:8: error: could not build Objective-C module 'Discount'
import Discount
       ^
error: fatalError
warning: failed to retrieve search paths with pkg-config; maybe pkg-config is not installed
warning: you may be able to install libmarkdown using your system-packager:
    brew install discount
[0/1] Planning build
Building for debugging...
[0/1] Write swift-version--423B1241ED78D482.txt
error: emit-module command failed with exit code 1 (use -v to see invocation)
[2/4] Emitting module Markdown
<module-includes>:1:9: note: in file included from <module-includes>:1:
#import "discount.h"
        ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/discount/discount.h:1:10: error: 'mkdio.h' file not found
#include <mkdio.h>
         ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/Markdown/Markdown.swift:1:8: error: could not build Objective-C module 'Discount'
import Discount
       ^
[3/4] Compiling Markdown Markdown.swift
<module-includes>:1:9: note: in file included from <module-includes>:1:
#import "discount.h"
        ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/discount/discount.h:1:10: error: 'mkdio.h' file not found
#include <mkdio.h>
         ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/Markdown/Markdown.swift:1:8: error: could not build Objective-C module 'Discount'
import Discount
       ^
[4/4] Compiling Markdown ParseOptions.swift
<module-includes>:1:9: note: in file included from <module-includes>:1:
#import "discount.h"
        ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/discount/discount.h:1:10: error: 'mkdio.h' file not found
#include <mkdio.h>
         ^
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/Markdown/Markdown.swift:1:8: error: could not build Objective-C module 'Discount'
import Discount
       ^
error: fatalError
warning: failed to retrieve search paths with pkg-config; maybe pkg-config is not installed
warning: you may be able to install libmarkdown using your system-packager:
    brew install discount
BUILD FAILURE 5.10 macosSpm

Build Machine: Mac 7