The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build ConventionalCommitsKit with Swift 5.10 for macOS (Xcode) using Xcode 15.4 at main.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.29.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/alexanderwe/ConventionalCommitsKit.git
Reference: main
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/alexanderwe/ConventionalCommitsKit
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 2304425 chore(documentation): Generate documentation
Cloned https://github.com/alexanderwe/ConventionalCommitsKit.git
Revision (git rev-parse @):
2304425683199316103ddb4440e192a52d3496f0
SUCCESS checkout https://github.com/alexanderwe/ConventionalCommitsKit.git at main
========================================
Build
========================================
Selected platform:         macosXcodebuild
Swift version:             5.10
Building package at path:  $workDir
https://github.com/alexanderwe/ConventionalCommitsKit.git
Command line invocation:
    /Applications/Xcode-15.3.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies
User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph
Fetching from https://github.com/pointfreeco/swift-case-paths (cached)
Fetching from https://github.com/apple/swift-docc-plugin (cached)
Fetching from https://github.com/pointfreeco/xctest-dynamic-overlay (cached)
Fetching from https://github.com/pointfreeco/swift-parsing (cached)
Creating working copy of package ‘swift-case-paths’
Checking out 0.8.1 of package ‘swift-case-paths’
Creating working copy of package ‘swift-docc-plugin’
Checking out 1.0.0 of package ‘swift-docc-plugin’
Creating working copy of package ‘xctest-dynamic-overlay’
Checking out 0.2.1 of package ‘xctest-dynamic-overlay’
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/repositories/swift-parsing-271aaae5 is not valid git repository for 'https://github.com/pointfreeco/swift-parsing', will fetch again.Fetching from https://github.com/pointfreeco/swift-parsing (cached)
/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/repositories/swift-parsing-271aaae5 is not valid git repository for 'https://github.com/pointfreeco/swift-parsing', will fetch again.Fetching from https://github.com/pointfreeco/swift-parsing (cached)
Creating working copy of package ‘swift-parsing’
Checking out 0.9.2 of package ‘swift-parsing’
Resolved source packages:
  ConventionalCommitsKit: /Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace
  swift-case-paths: https://github.com/pointfreeco/swift-case-paths @ 0.8.1
  xctest-dynamic-overlay: https://github.com/pointfreeco/xctest-dynamic-overlay @ 0.2.1
  swift-parsing: https://github.com/pointfreeco/swift-parsing @ 0.9.2
  SwiftDocCPlugin: https://github.com/apple/swift-docc-plugin @ 1.0.0
resolved source packages: ConventionalCommitsKit, swift-case-paths, xctest-dynamic-overlay, swift-parsing, SwiftDocCPlugin
2024-02-15 16:15:00.293 xcodebuild[60644:16785266] Requested but did not find extension point with identifier Xcode.DVTDeviceFoundation.Aspect for extension Xcode.IDEiOSSupportCore.Aspect.NBDD of plug-in com.apple.dt.IDE.IDEiOSSupportCore
2024-02-15 16:15:04.316 xcodebuild[60644:16785266] [MT] DVTPlugInQuery: Requested but did not find extension point with identifier 'Xcode.DVTDeviceFoundation.CompatibleDeviceFamilyPair'. This is programmer error; code should only request extension points that are defined by itself or its dependencies.
{
  "workspace" : {
    "name" : "spi-builder-workspace",
    "schemes" : [
      "_URLRouting",
      "CasePaths",
      "ConventionalCommitsKit",
      "Parsing",
      "Parsing_watchOS",
      "swift-case-paths-benchmark",
      "swift-case-paths-Package",
      "swift-parsing-benchmark",
      "swift-parsing-Package",
      "variadics-generator"
    ]
  }
}
2024-02-15 16:15:04.691 xcodebuild[61118:16786860] Requested but did not find extension point with identifier Xcode.DVTDeviceFoundation.Aspect for extension Xcode.IDEiOSSupportCore.Aspect.NBDD of plug-in com.apple.dt.IDE.IDEiOSSupportCore
2024-02-15 16:15:08.358 xcodebuild[61118:16786860] [MT] DVTPlugInQuery: Requested but did not find extension point with identifier 'Xcode.DVTDeviceFoundation.CompatibleDeviceFamilyPair'. This is programmer error; code should only request extension points that are defined by itself or its dependencies.
{
  "workspace" : {
    "name" : "spi-builder-workspace",
    "schemes" : [
      "_URLRouting",
      "CasePaths",
      "ConventionalCommitsKit",
      "Parsing",
      "Parsing_watchOS",
      "swift-case-paths-benchmark",
      "swift-case-paths-Package",
      "swift-parsing-benchmark",
      "swift-parsing-Package",
      "variadics-generator"
    ]
  }
}
2024-02-15 16:15:08.662 xcodebuild[61454:16788263] Requested but did not find extension point with identifier Xcode.DVTDeviceFoundation.Aspect for extension Xcode.IDEiOSSupportCore.Aspect.NBDD of plug-in com.apple.dt.IDE.IDEiOSSupportCore
2024-02-15 16:15:12.732 xcodebuild[61454:16788263] [MT] DVTPlugInQuery: Requested but did not find extension point with identifier 'Xcode.DVTDeviceFoundation.CompatibleDeviceFamilyPair'. This is programmer error; code should only request extension points that are defined by itself or its dependencies.
{
  "dependencies" : [
    {
      "identity" : "swift-parsing",
      "requirement" : {
        "exact" : [
          "0.9.2"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/pointfreeco/swift-parsing"
    },
    {
      "identity" : "swift-docc-plugin",
      "requirement" : {
        "range" : [
          {
            "lower_bound" : "1.0.0",
            "upper_bound" : "2.0.0"
          }
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/apple/swift-docc-plugin"
    }
  ],
  "manifest_display_name" : "ConventionalCommitsKit",
  "name" : "ConventionalCommitsKit",
  "path" : "/Users/builder/builds/UKfvDsi8u/2/finestructure/swiftpackageindex-builder/spi-builder-workspace",
  "platforms" : [
    {
      "name" : "macos",
      "version" : "10.15"
    },
    {
      "name" : "ios",
      "version" : "13.0"
    },
    {
      "name" : "tvos",
      "version" : "13.0"
    }
  ],
  "products" : [
    {
      "name" : "ConventionalCommitsKit",
      "targets" : [
        "ConventionalCommitsKit"
      ],
      "type" : {
        "library" : [
          "automatic"
        ]
      }
    }
  ],
  "targets" : [
    {
      "c99name" : "ConventionalCommitsKitTests",
      "module_type" : "SwiftTarget",
      "name" : "ConventionalCommitsKitTests",
      "path" : "Tests",
      "sources" : [
        "ConventionalCommitsFooterTests.swift",
        "ConventionalCommitsHeaderTests.swift",
        "ConventionalCommitsTests.swift"
      ],
      "target_dependencies" : [
        "ConventionalCommitsKit"
      ],
      "type" : "test"
    },
    {
      "c99name" : "ConventionalCommitsKit",
      "module_type" : "SwiftTarget",
      "name" : "ConventionalCommitsKit",
      "path" : "Sources",
      "product_dependencies" : [
        "Parsing"
      ],
      "product_memberships" : [
        "ConventionalCommitsKit"
      ],
      "sources" : [
        "ConventionalCommit.swift",
        "Extensions/Parsing+Regex.swift",
        "Footer.swift",
        "Header.swift"
      ],
      "type" : "library"
    }
  ],
  "tools_version" : "5.6"
}
Schemes found:
  _URLRouting
  CasePaths
  ConventionalCommitsKit
  Parsing
  Parsing_watchOS
  swift-case-paths-benchmark
  swift-case-paths-Package
  swift-parsing-benchmark
  swift-parsing-Package
  variadics-generator
GENERIC FAILURE 5.10 macosXcodebuild

Build Machine: Mac 7