The Swift Package Index logo.Swift Package Index

Build Information

Successful build of swift-rfc-2045, reference main (0d5b95), with Swift 6.4 for Linux on 2 Oct 2026 23:30:14 UTC.

Swift 6 data race errors: 0

Build Command

bash -c docker run --pull=always --rm -v "checkouts-54344844-2":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest swift build --triple x86_64-unknown-linux-gnu 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 5.1.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/swift-ietf/swift-rfc-2045.git
Reference: main
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/swift-ietf/swift-rfc-2045
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 0d5b95e Split the Foundation integration out of the core
Cloned https://github.com/swift-ietf/swift-rfc-2045.git
Revision (git rev-parse @):
0d5b95ebeee3caf09fdfc9a587c22f31c7e5f334
SPI manifest file found: $PWD/.spi.yml
SUCCESS checkout https://github.com/swift-ietf/swift-rfc-2045.git at main
========================================
Build
========================================
Selected platform:         linux
Swift version:             6.4
Building package at path:  $PWD
https://github.com/swift-ietf/swift-rfc-2045.git
Running build ...
bash -c docker run --pull=always --rm -v "checkouts-54344844-2":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
basic-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:c77fcce225e223ac0fafed844619173fc6de8d62dd560eeb28db3182af6a282b
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest
Fetching https://github.com/swift-atoms/swift-ascii.git
[1/780] Fetching swift-ascii
Fetched https://github.com/swift-atoms/swift-ascii.git (0.83s)
Fetching https://github.com/swift-atoms/swift-byte.git
[1/594] Fetching swift-byte
Fetched https://github.com/swift-atoms/swift-byte.git (0.47s)
Fetching https://github.com/swift-ietf/swift-rfc-5322.git
[1/1337] Fetching swift-rfc-5322
Fetched https://github.com/swift-ietf/swift-rfc-5322.git (0.50s)
Fetching https://github.com/swift-atoms/swift-carrier.git
[1/1402] Fetching swift-carrier
Fetched https://github.com/swift-atoms/swift-carrier.git (0.56s)
Fetching https://github.com/swift-atoms/swift-checkpoint.git
[1/73] Fetching swift-checkpoint
Fetched https://github.com/swift-atoms/swift-checkpoint.git (0.42s)
Fetching https://github.com/swift-atoms/swift-coder.git
[1/1030] Fetching swift-coder
Fetched https://github.com/swift-atoms/swift-coder.git (0.50s)
Fetching https://github.com/swift-atoms/swift-cursor.git
[1/304] Fetching swift-cursor
Fetched https://github.com/swift-atoms/swift-cursor.git (0.45s)
Fetching https://github.com/swift-atoms/swift-iterator.git
[7/628] Fetching swift-iterator
Fetched https://github.com/swift-atoms/swift-iterator.git (0.45s)
Fetching https://github.com/swift-atoms/swift-parser.git
[1/4492] Fetching swift-parser
Fetched https://github.com/swift-atoms/swift-parser.git (0.51s)
Fetching https://github.com/swift-atoms/swift-serializer.git
[1/852] Fetching swift-serializer
Fetched https://github.com/swift-atoms/swift-serializer.git (0.40s)
Fetching https://github.com/swift-atoms/swift-bit.git
[1/853] Fetching swift-bit
Fetched https://github.com/swift-atoms/swift-bit.git (0.42s)
Fetching https://github.com/swift-atoms/swift-index.git
[1/1055] Fetching swift-index
Fetched https://github.com/swift-atoms/swift-index.git (0.49s)
Fetching https://github.com/swift-atoms/swift-finite.git
[1/824] Fetching swift-finite
Fetched https://github.com/swift-atoms/swift-finite.git (0.43s)
Fetching https://github.com/swift-atoms/swift-ordinal.git
[1/1465] Fetching swift-ordinal
Fetched https://github.com/swift-atoms/swift-ordinal.git (0.40s)
Fetching https://github.com/swift-atoms/swift-tagged.git
[1/1858] Fetching swift-tagged
Fetched https://github.com/swift-atoms/swift-tagged.git (0.44s)
Fetching https://github.com/swift-ietf/swift-rfc-1123.git
[1/605] Fetching swift-rfc-1123
Fetched https://github.com/swift-ietf/swift-rfc-1123.git (0.44s)
Fetching https://github.com/swift-atoms/swift-standard-library-extensions.git
[1/1234] Fetching swift-standard-library-extensions
Fetched https://github.com/swift-atoms/swift-standard-library-extensions.git (0.43s)
Fetching https://github.com/swift-atoms/swift-time.git
[1/1049] Fetching swift-time
Fetched https://github.com/swift-atoms/swift-time.git (0.44s)
Fetching https://github.com/swift-atoms/swift-calendar.git
[1/157] Fetching swift-calendar
Fetched https://github.com/swift-atoms/swift-calendar.git (0.38s)
Fetching https://github.com/swift-molecules/swift-calendar-gregorian.git
[1/139] Fetching swift-calendar-gregorian
Fetched https://github.com/swift-molecules/swift-calendar-gregorian.git (0.45s)
Fetching https://github.com/swift-incits/swift-incits-4-1986.git
[1/1301] Fetching swift-incits-4-1986
Fetched https://github.com/swift-incits/swift-incits-4-1986.git (0.53s)
Fetching https://github.com/swift-atoms/swift-always.git
[2/65] Fetching swift-always
Fetched https://github.com/swift-atoms/swift-always.git (0.37s)
Fetching https://github.com/swift-atoms/swift-repetition.git
[1/40] Fetching swift-repetition
Fetched https://github.com/swift-atoms/swift-repetition.git (0.38s)
Fetching https://github.com/swift-atoms/swift-cardinal.git
[1/1437] Fetching swift-cardinal
Fetched https://github.com/swift-atoms/swift-cardinal.git (0.42s)
Fetching https://github.com/swift-atoms/swift-predicate.git
[1/537] Fetching swift-predicate
Fetched https://github.com/swift-atoms/swift-predicate.git (0.52s)
Fetching https://github.com/swift-atoms/swift-either.git
[1/399] Fetching swift-either
Fetched https://github.com/swift-atoms/swift-either.git (0.46s)
Fetching https://github.com/swift-atoms/swift-pair.git
[1/375] Fetching swift-pair
Fetched https://github.com/swift-atoms/swift-pair.git (0.49s)
Fetching https://github.com/swift-atoms/swift-skip.git
[1/30] Fetching swift-skip
Fetched https://github.com/swift-atoms/swift-skip.git (0.41s)
Fetching https://github.com/swift-atoms/swift-map.git
[1/36] Fetching swift-map
Fetched https://github.com/swift-atoms/swift-map.git (0.35s)
Fetching https://github.com/swift-atoms/swift-optic.git
[1/761] Fetching swift-optic
Fetched https://github.com/swift-atoms/swift-optic.git (0.41s)
Fetching https://github.com/swift-atoms/swift-operation.git
[1/322] Fetching swift-operation
Fetched https://github.com/swift-atoms/swift-operation.git (0.49s)
Fetching https://github.com/swift-atoms/swift-empty.git
[1/178] Fetching swift-empty
Fetched https://github.com/swift-atoms/swift-empty.git (0.35s)
Fetching https://github.com/swift-atoms/swift-single.git
[1/199] Fetching swift-single
Fetched https://github.com/swift-atoms/swift-single.git (0.46s)
Fetching https://github.com/swift-atoms/swift-search.git
[1/45] Fetching swift-search
Fetched https://github.com/swift-atoms/swift-search.git (0.33s)
Fetching https://github.com/swift-atoms/swift-append.git
[1/33] Fetching swift-append
Fetched https://github.com/swift-atoms/swift-append.git (0.36s)
Fetching https://github.com/swift-atoms/swift-flatmap.git
[1/30] Fetching swift-flatmap
Fetched https://github.com/swift-atoms/swift-flatmap.git (0.34s)
Fetching https://github.com/swift-atoms/swift-lazy.git
[1/76] Fetching swift-lazy
Fetched https://github.com/swift-atoms/swift-lazy.git (0.32s)
Fetching https://github.com/swift-atoms/swift-collection.git
[1/1295] Fetching swift-collection
Fetched https://github.com/swift-atoms/swift-collection.git (0.44s)
Fetching https://github.com/swift-atoms/swift-product.git
[1/602] Fetching swift-product
Fetched https://github.com/swift-atoms/swift-product.git (0.40s)
Fetching https://github.com/swift-atoms/swift-difference.git
[1/176] Fetching swift-difference
Fetched https://github.com/swift-atoms/swift-difference.git (0.34s)
Fetching https://github.com/swift-atoms/swift-algebra.git
[1/1674] Fetching swift-algebra
Fetched https://github.com/swift-atoms/swift-algebra.git (0.48s)
Fetching https://github.com/swift-atoms/swift-polarity.git
[1/219] Fetching swift-polarity
Fetched https://github.com/swift-atoms/swift-polarity.git (0.34s)
Fetching https://github.com/swift-atoms/swift-magnitude.git
[1/103] Fetching swift-magnitude
Fetched https://github.com/swift-atoms/swift-magnitude.git (0.37s)
Fetching https://github.com/swift-atoms/swift-property.git
[1/1563] Fetching swift-property
Fetched https://github.com/swift-atoms/swift-property.git (0.49s)
Fetching https://github.com/swift-atoms/swift-successor.git
[1/68] Fetching swift-successor
Fetched https://github.com/swift-atoms/swift-successor.git (0.35s)
Fetching https://github.com/swift-atoms/swift-predecessor.git
[1/68] Fetching swift-predecessor
Fetched https://github.com/swift-atoms/swift-predecessor.git (0.36s)
Fetching https://github.com/swift-atoms/swift-advancement.git
[1/68] Fetching swift-advancement
Fetched https://github.com/swift-atoms/swift-advancement.git (0.33s)
Fetching https://github.com/swift-atoms/swift-retreat.git
[1/68] Fetching swift-retreat
Fetched https://github.com/swift-atoms/swift-retreat.git (0.31s)
Fetching https://github.com/swift-atoms/swift-distance.git
[1/68] Fetching swift-distance
Fetched https://github.com/swift-atoms/swift-distance.git (0.33s)
Fetching https://github.com/swift-ietf/swift-rfc-1035.git
[1/697] Fetching swift-rfc-1035
Fetched https://github.com/swift-ietf/swift-rfc-1035.git (0.48s)
Fetching https://github.com/swift-atoms/swift-addition.git
[1/79] Fetching swift-addition
Fetched https://github.com/swift-atoms/swift-addition.git (0.35s)
Fetching https://github.com/swift-atoms/swift-coordinate.git
[1/49] Fetching swift-coordinate
Fetched https://github.com/swift-atoms/swift-coordinate.git (0.33s)
Fetching https://github.com/swift-atoms/swift-translation.git
[1/47] Fetching swift-translation
Fetched https://github.com/swift-atoms/swift-translation.git (0.33s)
Fetching https://github.com/swift-atoms/swift-division.git
[1/84] Fetching swift-division
Fetched https://github.com/swift-atoms/swift-division.git (0.36s)
Fetching https://github.com/swift-atoms/swift-rational.git
[1/115] Fetching swift-rational
Fetched https://github.com/swift-atoms/swift-rational.git (0.33s)
Fetching https://github.com/swift-atoms/swift-ratio.git
[1/163] Fetching swift-ratio
Fetched https://github.com/swift-atoms/swift-ratio.git (0.38s)
Fetching https://github.com/swift-atoms/swift-subtraction.git
[1/59] Fetching swift-subtraction
Fetched https://github.com/swift-atoms/swift-subtraction.git (0.31s)
Fetching https://github.com/swift-atoms/swift-logic.git
[1/1008] Fetching swift-logic
Fetched https://github.com/swift-atoms/swift-logic.git (0.37s)
Fetching https://github.com/swift-atoms/swift-contramap.git
[1/33] Fetching swift-contramap
Fetched https://github.com/swift-atoms/swift-contramap.git (0.32s)
Fetching https://github.com/swift-atoms/swift-bifunctor.git
[1/213] Fetching swift-bifunctor
Fetched https://github.com/swift-atoms/swift-bifunctor.git (0.37s)
Fetching https://github.com/swift-atoms/swift-coproduct.git
[1/429] Fetching swift-coproduct
Fetched https://github.com/swift-atoms/swift-coproduct.git (0.37s)
Fetching https://github.com/swift-atoms/swift-sequence.git
[1/2186] Fetching swift-sequence
Fetched https://github.com/swift-atoms/swift-sequence.git (0.51s)
Fetching https://github.com/swift-atoms/swift-order.git
[1/864] Fetching swift-order
Fetched https://github.com/swift-atoms/swift-order.git (0.82s)
Fetching https://github.com/swift-atoms/swift-ownership.git
[1/3106] Fetching swift-ownership
Fetched https://github.com/swift-atoms/swift-ownership.git (0.99s)
Fetching https://github.com/swift-atoms/swift-vector.git
[1/118] Fetching swift-vector
Fetched https://github.com/swift-atoms/swift-vector.git (0.38s)
Fetching https://github.com/swift-atoms/swift-rounding.git
[1/61] Fetching swift-rounding
Fetched https://github.com/swift-atoms/swift-rounding.git (0.39s)
Fetching https://github.com/swift-atoms/swift-integer.git
[1/105] Fetching swift-integer
Fetched https://github.com/swift-atoms/swift-integer.git (0.34s)
Fetching https://github.com/swift-atoms/swift-multiplication.git
[1/79] Fetching swift-multiplication
Fetched https://github.com/swift-atoms/swift-multiplication.git (0.36s)
Fetching https://github.com/swift-atoms/swift-memory.git
[1/1981] Fetching swift-memory
Fetched https://github.com/swift-atoms/swift-memory.git (0.55s)
Fetching https://github.com/swift-atoms/swift-span.git
[1/433] Fetching swift-span
Fetched https://github.com/swift-atoms/swift-span.git (0.41s)
Fetching https://github.com/swift-atoms/swift-error.git
[1/350] Fetching swift-error
Fetched https://github.com/swift-atoms/swift-error.git (0.45s)
Fetching https://github.com/swiftlang/swift-syntax.git
[1/80201] Fetching swift-syntax
Fetched https://github.com/swiftlang/swift-syntax.git (3.63s)
Computing version for https://github.com/swiftlang/swift-syntax.git
Computed https://github.com/swiftlang/swift-syntax.git at 603.0.2 (4.84s)
Creating working copy for https://github.com/swift-atoms/swift-product.git
Working copy of https://github.com/swift-atoms/swift-product.git resolved at main (d4702f8)
Creating working copy for https://github.com/swift-atoms/swift-subtraction.git
Working copy of https://github.com/swift-atoms/swift-subtraction.git resolved at main (4614d98)
Creating working copy for https://github.com/swift-atoms/swift-parser.git
Working copy of https://github.com/swift-atoms/swift-parser.git resolved at main (0913ad9)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1035.git
Working copy of https://github.com/swift-ietf/swift-rfc-1035.git resolved at main (215fda4)
Creating working copy for https://github.com/swift-atoms/swift-ordinal.git
Working copy of https://github.com/swift-atoms/swift-ordinal.git resolved at main (bdb3f64)
Creating working copy for https://github.com/swift-atoms/swift-serializer.git
Working copy of https://github.com/swift-atoms/swift-serializer.git resolved at main (3971b0a)
Creating working copy for https://github.com/swift-atoms/swift-magnitude.git
Working copy of https://github.com/swift-atoms/swift-magnitude.git resolved at main (6c31511)
Creating working copy for https://github.com/swift-molecules/swift-calendar-gregorian.git
Working copy of https://github.com/swift-molecules/swift-calendar-gregorian.git resolved at main (301a29c)
Creating working copy for https://github.com/swift-atoms/swift-tagged.git
Working copy of https://github.com/swift-atoms/swift-tagged.git resolved at main (6e00f02)
Creating working copy for https://github.com/swift-ietf/swift-rfc-5322.git
Working copy of https://github.com/swift-ietf/swift-rfc-5322.git resolved at main (e9864e0)
Creating working copy for https://github.com/swift-atoms/swift-division.git
Working copy of https://github.com/swift-atoms/swift-division.git resolved at main (fe65e48)
Creating working copy for https://github.com/swift-atoms/swift-rounding.git
Working copy of https://github.com/swift-atoms/swift-rounding.git resolved at main (5481997)
Creating working copy for https://github.com/swift-atoms/swift-retreat.git
Working copy of https://github.com/swift-atoms/swift-retreat.git resolved at main (c78a367)
Creating working copy for https://github.com/swift-atoms/swift-operation.git
Working copy of https://github.com/swift-atoms/swift-operation.git resolved at main (6b09f83)
Creating working copy for https://github.com/swift-atoms/swift-rational.git
Working copy of https://github.com/swift-atoms/swift-rational.git resolved at main (f973aa9)
Creating working copy for https://github.com/swift-atoms/swift-ascii.git
Working copy of https://github.com/swift-atoms/swift-ascii.git resolved at main (a365691)
Creating working copy for https://github.com/swift-atoms/swift-ownership.git
Working copy of https://github.com/swift-atoms/swift-ownership.git resolved at main (f8702ec)
Creating working copy for https://github.com/swift-atoms/swift-always.git
Working copy of https://github.com/swift-atoms/swift-always.git resolved at main (1229653)
Creating working copy for https://github.com/swift-atoms/swift-iterator.git
Working copy of https://github.com/swift-atoms/swift-iterator.git resolved at main (e276f0c)
Creating working copy for https://github.com/swift-atoms/swift-byte.git
Working copy of https://github.com/swift-atoms/swift-byte.git resolved at main (50bd3e3)
Creating working copy for https://github.com/swift-atoms/swift-polarity.git
Working copy of https://github.com/swift-atoms/swift-polarity.git resolved at main (4880d7d)
Creating working copy for https://github.com/swift-atoms/swift-map.git
Working copy of https://github.com/swift-atoms/swift-map.git resolved at main (317c5f8)
Creating working copy for https://github.com/swift-atoms/swift-cursor.git
Working copy of https://github.com/swift-atoms/swift-cursor.git resolved at main (0c4eb8c)
Creating working copy for https://github.com/swiftlang/swift-syntax.git
Working copy of https://github.com/swiftlang/swift-syntax.git resolved at 603.0.2
Creating working copy for https://github.com/swift-atoms/swift-search.git
Working copy of https://github.com/swift-atoms/swift-search.git resolved at main (ab399f1)
Creating working copy for https://github.com/swift-atoms/swift-algebra.git
Working copy of https://github.com/swift-atoms/swift-algebra.git resolved at main (6f0468a)
Creating working copy for https://github.com/swift-atoms/swift-empty.git
Working copy of https://github.com/swift-atoms/swift-empty.git resolved at main (134c48b)
Creating working copy for https://github.com/swift-atoms/swift-logic.git
Working copy of https://github.com/swift-atoms/swift-logic.git resolved at main (91fbf3b)
Creating working copy for https://github.com/swift-atoms/swift-multiplication.git
Working copy of https://github.com/swift-atoms/swift-multiplication.git resolved at main (f07296d)
Creating working copy for https://github.com/swift-atoms/swift-span.git
Working copy of https://github.com/swift-atoms/swift-span.git resolved at main (81b5071)
Creating working copy for https://github.com/swift-atoms/swift-distance.git
Working copy of https://github.com/swift-atoms/swift-distance.git resolved at main (1856165)
Creating working copy for https://github.com/swift-atoms/swift-sequence.git
Working copy of https://github.com/swift-atoms/swift-sequence.git resolved at main (7c462e3)
Creating working copy for https://github.com/swift-atoms/swift-integer.git
Working copy of https://github.com/swift-atoms/swift-integer.git resolved at main (05212bf)
Creating working copy for https://github.com/swift-atoms/swift-vector.git
Working copy of https://github.com/swift-atoms/swift-vector.git resolved at main (915cd7c)
Creating working copy for https://github.com/swift-incits/swift-incits-4-1986.git
Working copy of https://github.com/swift-incits/swift-incits-4-1986.git resolved at main (b208aff)
Creating working copy for https://github.com/swift-atoms/swift-collection.git
Working copy of https://github.com/swift-atoms/swift-collection.git resolved at main (7013fe3)
Creating working copy for https://github.com/swift-atoms/swift-bifunctor.git
Working copy of https://github.com/swift-atoms/swift-bifunctor.git resolved at main (18fe386)
Creating working copy for https://github.com/swift-atoms/swift-coder.git
Working copy of https://github.com/swift-atoms/swift-coder.git resolved at main (627a31c)
Creating working copy for https://github.com/swift-atoms/swift-memory.git
Working copy of https://github.com/swift-atoms/swift-memory.git resolved at main (dc058d2)
Creating working copy for https://github.com/swift-atoms/swift-predecessor.git
Working copy of https://github.com/swift-atoms/swift-predecessor.git resolved at main (42a711d)
Creating working copy for https://github.com/swift-atoms/swift-advancement.git
Working copy of https://github.com/swift-atoms/swift-advancement.git resolved at main (b947ae1)
Creating working copy for https://github.com/swift-atoms/swift-predicate.git
Working copy of https://github.com/swift-atoms/swift-predicate.git resolved at main (57d2250)
Creating working copy for https://github.com/swift-atoms/swift-optic.git
Working copy of https://github.com/swift-atoms/swift-optic.git resolved at main (72cf3fd)
Creating working copy for https://github.com/swift-atoms/swift-standard-library-extensions.git
Working copy of https://github.com/swift-atoms/swift-standard-library-extensions.git resolved at main (a727a9e)
Creating working copy for https://github.com/swift-atoms/swift-coordinate.git
Working copy of https://github.com/swift-atoms/swift-coordinate.git resolved at main (6c56b05)
Creating working copy for https://github.com/swift-atoms/swift-order.git
Working copy of https://github.com/swift-atoms/swift-order.git resolved at main (a1866fe)
Creating working copy for https://github.com/swift-atoms/swift-contramap.git
Working copy of https://github.com/swift-atoms/swift-contramap.git resolved at main (c719674)
Creating working copy for https://github.com/swift-atoms/swift-lazy.git
Working copy of https://github.com/swift-atoms/swift-lazy.git resolved at main (f12c258)
Creating working copy for https://github.com/swift-atoms/swift-bit.git
Working copy of https://github.com/swift-atoms/swift-bit.git resolved at main (30f6189)
Creating working copy for https://github.com/swift-atoms/swift-error.git
Working copy of https://github.com/swift-atoms/swift-error.git resolved at main (f6ad8ee)
Creating working copy for https://github.com/swift-atoms/swift-coproduct.git
Working copy of https://github.com/swift-atoms/swift-coproduct.git resolved at main (224eb87)
Creating working copy for https://github.com/swift-atoms/swift-single.git
Working copy of https://github.com/swift-atoms/swift-single.git resolved at main (e468dca)
Creating working copy for https://github.com/swift-atoms/swift-repetition.git
Working copy of https://github.com/swift-atoms/swift-repetition.git resolved at main (b2fafee)
Creating working copy for https://github.com/swift-atoms/swift-time.git
Working copy of https://github.com/swift-atoms/swift-time.git resolved at main (c6cb993)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1123.git
Working copy of https://github.com/swift-ietf/swift-rfc-1123.git resolved at main (0563819)
Creating working copy for https://github.com/swift-atoms/swift-difference.git
Working copy of https://github.com/swift-atoms/swift-difference.git resolved at main (fb95a3f)
Creating working copy for https://github.com/swift-atoms/swift-cardinal.git
Working copy of https://github.com/swift-atoms/swift-cardinal.git resolved at main (a4beb26)
Creating working copy for https://github.com/swift-atoms/swift-checkpoint.git
Working copy of https://github.com/swift-atoms/swift-checkpoint.git resolved at main (aa7b4ec)
Creating working copy for https://github.com/swift-atoms/swift-translation.git
Working copy of https://github.com/swift-atoms/swift-translation.git resolved at main (32e900c)
Creating working copy for https://github.com/swift-atoms/swift-pair.git
Working copy of https://github.com/swift-atoms/swift-pair.git resolved at main (d71085f)
Creating working copy for https://github.com/swift-atoms/swift-successor.git
Working copy of https://github.com/swift-atoms/swift-successor.git resolved at main (ab8561a)
Creating working copy for https://github.com/swift-atoms/swift-index.git
Working copy of https://github.com/swift-atoms/swift-index.git resolved at main (425b76c)
Creating working copy for https://github.com/swift-atoms/swift-append.git
Working copy of https://github.com/swift-atoms/swift-append.git resolved at main (5a2c22d)
Creating working copy for https://github.com/swift-atoms/swift-ratio.git
Working copy of https://github.com/swift-atoms/swift-ratio.git resolved at main (089c5d6)
Creating working copy for https://github.com/swift-atoms/swift-flatmap.git
Working copy of https://github.com/swift-atoms/swift-flatmap.git resolved at main (03442d2)
Creating working copy for https://github.com/swift-atoms/swift-calendar.git
Working copy of https://github.com/swift-atoms/swift-calendar.git resolved at main (92ed545)
Creating working copy for https://github.com/swift-atoms/swift-either.git
Working copy of https://github.com/swift-atoms/swift-either.git resolved at main (46c666a)
Creating working copy for https://github.com/swift-atoms/swift-addition.git
Working copy of https://github.com/swift-atoms/swift-addition.git resolved at main (7662e87)
Creating working copy for https://github.com/swift-atoms/swift-finite.git
Working copy of https://github.com/swift-atoms/swift-finite.git resolved at main (f3eac5b)
Creating working copy for https://github.com/swift-atoms/swift-skip.git
Working copy of https://github.com/swift-atoms/swift-skip.git resolved at main (728b918)
Creating working copy for https://github.com/swift-atoms/swift-property.git
Working copy of https://github.com/swift-atoms/swift-property.git resolved at main (5b9a7f3)
Creating working copy for https://github.com/swift-atoms/swift-carrier.git
Working copy of https://github.com/swift-atoms/swift-carrier.git resolved at main (ee19248)
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-5322': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-5322': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
Building for debugging...
[Computing dependencies]
[Provisioning 1 / 143]
[Constructing description]
[Pre-planning 1 / 2194]
[Planning 315 / 2194]
[Planning 1690 / 2194]
[Planning deferred tasks]
[Constructing 977 / 5216]
[Starting]
[224 / 938] Multiplication
[450 / 955] Translation
[459 / 1003] Skip
[502 / 1020] Operation
[512 / 1020] Logic
[513 / 1020] Standard Library Extensions
[525 / 1020] Translation
[527 / 1020] Translation
[532 / 1021] Standard Library Extensions
[536 / 1021] Standard Library Extensions
[538 / 1022] Standard Library Extensions
[544 / 1023] Skip
[554 / 1024] Single
[559 / 1024] Search
[565 / 1025] Search
[575 / 1027] Product
[584 / 1027] Map-product
[591 / 1028] Logic-product
[607 / 1035] Either
[621 / 1070] Checkpoint
[650 / 1092] Lazy
[674 / 1110] Logic
[700 / 1112] FlatMap
[713 / 1114] Error
[720 / 1114] Contramap-product
[728 / 1115] Checkpoint
[735 / 1117] Either
[748 / 1117] Bit
[757 / 1117] Always-product
[763 / 1120] Append
[771 / 1121] Lazy
[778 / 1121] Carrier
[788 / 1133] Error
[807 / 1143] Tagged
[808 / 1144] Tagged
[810 / 1144] Polarity-product
[823 / 1145] Map-product
[835 / 1177] Ownership
[837 / 1185] Ownership
[849 / 1185] Addition
[867 / 1185] Ownership
[870 / 1185] Ownership
[872 / 1185] Optic-product
[873 / 1185] Optic-product
[875 / 1185] Predicate
[877 / 1185] Multiplication-product
[881 / 1186] Multiplication
[887 / 1186] Magnitude
[894 / 1187] Optic
[903 / 1216] Predicate
[913 / 1217] Property
[932 / 1218] Retreat
[940 / 1219] Predicate
[943 / 1219] Predicate-product
[954 / 1226] Addition
[978 / 1232] Predecessor-product
[992 / 1241] Distance
[1001 / 1260] Distance
[1003 / 1260] Order
[1010 / 1260] Order
[1012 / 1260] Order-product
[1014 / 1260] Rounding
[1023 / 1260] Cardinal
[1030 / 1263] Tagged
[1035 / 1263] Property
[1044 / 1274] Rounding
[1049 / 1274] Repetition
[1068 / 1279] Cardinal
[1078 / 1311] Successor
[1081 / 1311] Difference
[1086 / 1311] Division
[1092 / 1311] Difference
[1110 / 1311] Integer-product
[1117 / 1312] Rounding
[1121 / 1313] Division-product
[1126 / 1313] Difference
[1127 / 1313] Ordinal
[1132 / 1323] Predecessor
[1138 / 1324] Rational
[1141 / 1325] Rational
[1152 / 1326]
[1162 / 1335] Cursor
[1167 / 1344] Ordinal
[1178 / 1346] Ordinal
[1182 / 1346] Cardinal
[1189 / 1346] Cursor
[1190 / 1346] Ordinal
[1201 / 1352] Ordinal
[1217 / 1362] Sequence
[1219 / 1362] Index
[1221 / 1363] Finite
[1225 / 1372] Finite
[1226 / 1372] Finite
[1228 / 1372] Finite
[1230 / 1372] Sequence
[1242 / 1375] Byte
[1248 / 1393] Finite
[1255 / 1394] Sequence
[1258 / 1394] Sequence
[1262 / 1394] Collection
[1271 / 1394] Byte
[1276 / 1405] Collection
[1289 / 1415] Span
[1303 / 1416] Serializer
[1317 / 1419] Span
[1327 / 1438] Serializer
[1333 / 1438] Parser
[1334 / 1438] Parser
[1344 / 1439]
[1350 / 1450] Coder
[1356 / 1459] Ratio
[1373 / 1459] Coder
[1378 / 1459] Parser
[1381 / 1459] ASCII
[1384 / 1462] Coder
[1394 / 1481] Time
[1398 / 1482] Time
[1398 / 1482] ASCII
[1401 / 1482] Time
[1406 / 1482] Time-product
[1411 / 1482] Ratio
[1413 / 1482] Calendar
[1415 / 1482]
[1421 / 1492] ASCII
[1424 / 1492] ASCII
[1432 / 1492] Calendar
[1437 / 1494]
[1441 / 1512] RFC 1035
[1444 / 1513] Time
[1446 / 1514] Time
[1450 / 1515] ASCII
[1458 / 1515] RFC 1035
[1461 / 1515] INCITS 4 1986
[1466 / 1515] RFC 1123
[1470 / 1515]
[1481 / 1526] RFC 1123
[1483 / 1535] RFC 1123
[1494 / 1535] RFC 1123-product
[1495 / 1536] RFC 1123-product
[1499 / 1536] INCITS 4 1986
[1503 / 1536] RFC 1123
[1512 / 1538] INCITS 4 1986
[1517 / 1547] RFC 5322
[1519 / 1547] RFC 5322
[1520 / 1547] RFC 5322
[1523 / 1547] RFC 5322
[1530 / 1557] RFC 2045
[1534 / 1557] RFC 2045
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Charset.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentTransferEncoding.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentType.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Parameter.Name.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045.Parameter {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1538 / 1558] RFC 2045
[1548 / 1560] RFC 2045 Foundation Integration
[1552 / 1565] RFC 2045 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Charset.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Parameter.Name.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045.Parameter {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1554 / 1565] RFC 2045
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentTransferEncoding.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1559 / 1565] RFC 2045 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentType.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1567 / 1567] RFC 2045-product
Build complete! (28.79 secs)
Build complete.
{
  "dependencies" : [
    {
      "identity" : "swift-ascii",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-atoms/swift-ascii.git"
    },
    {
      "identity" : "swift-byte",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-atoms/swift-byte.git"
    },
    {
      "identity" : "swift-rfc-5322",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-ietf/swift-rfc-5322.git"
    }
  ],
  "manifest_display_name" : "swift-rfc-2045",
  "name" : "swift-rfc-2045",
  "path" : "/host/spi-builder-workspace",
  "platforms" : [
    {
      "name" : "macos",
      "version" : "27.0"
    },
    {
      "name" : "ios",
      "version" : "27.0"
    },
    {
      "name" : "tvos",
      "version" : "27.0"
    },
    {
      "name" : "watchos",
      "version" : "27.0"
    },
    {
      "name" : "visionos",
      "version" : "27.0"
    }
  ],
  "products" : [
    {
      "name" : "RFC 2045",
      "targets" : [
        "RFC 2045"
      ],
      "type" : {
        "library" : [
          "automatic"
        ]
      }
    },
    {
      "name" : "RFC 2045 Foundation Integration",
      "targets" : [
        "RFC 2045 Foundation Integration"
      ],
      "type" : {
        "library" : [
          "automatic"
        ]
      }
    }
  ],
  "swift_languages_versions" : [
    "6"
  ],
  "targets" : [
    {
      "c99name" : "RFC_2045_Tests",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Tests",
      "path" : "Tests/RFC 2045 Tests",
      "product_dependencies" : [
        "ASCII",
        "Byte",
        "Byte",
        "RFC 5322"
      ],
      "sources" : [
        "RFC_2045.Charset Tests.swift",
        "RFC_2045.ContentTransferEncoding Tests.swift",
        "RFC_2045.ContentType Tests.swift",
        "RFC_2045.Parameter.Name Tests.swift",
        "RFC_5322.Header.Name Tests.swift"
      ],
      "target_dependencies" : [
        "RFC 2045"
      ],
      "type" : "test"
    },
    {
      "c99name" : "RFC_2045_Foundation_Integration_Tests",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Foundation Integration Tests",
      "path" : "Tests/RFC 2045 Foundation Integration Tests",
      "sources" : [
        "RFC_2045+Codable Tests.swift"
      ],
      "target_dependencies" : [
        "RFC 2045",
        "RFC 2045 Foundation Integration"
      ],
      "type" : "test"
    },
    {
      "c99name" : "RFC_2045_Foundation_Integration",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Foundation Integration",
      "path" : "Sources/RFC 2045 Foundation Integration",
      "product_memberships" : [
        "RFC 2045 Foundation Integration"
      ],
      "sources" : [
        "RFC_2045.Charset+Codable.swift",
        "RFC_2045.ContentTransferEncoding+Codable.swift",
        "RFC_2045.ContentType+Codable.swift",
        "RFC_2045.Parameter.Name+Codable.swift"
      ],
      "target_dependencies" : [
        "RFC 2045"
      ],
      "type" : "library"
    },
    {
      "c99name" : "RFC_2045",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045",
      "path" : "Sources/RFC 2045",
      "product_dependencies" : [
        "ASCII",
        "Byte",
        "Byte",
        "RFC 5322"
      ],
      "product_memberships" : [
        "RFC 2045",
        "RFC 2045 Foundation Integration"
      ],
      "sources" : [
        "RFC_2045.Charset.Error.swift",
        "RFC_2045.Charset.swift",
        "RFC_2045.ContentTransferEncoding.Error.swift",
        "RFC_2045.ContentTransferEncoding.swift",
        "RFC_2045.ContentType.Error.swift",
        "RFC_2045.ContentType.swift",
        "RFC_2045.Grammar.swift",
        "RFC_2045.Parameter.Name.Error.swift",
        "RFC_2045.Parameter.Name.swift",
        "RFC_2045.Parameter.swift",
        "RFC_2045.swift",
        "RFC_5322.Header.Name.swift"
      ],
      "type" : "library"
    }
  ],
  "tools_version" : "6.4"
}
basic-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:c77fcce225e223ac0fafed844619173fc6de8d62dd560eeb28db3182af6a282b
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
Done.