The Swift Package Index logo.Swift Package Index

Build Information

Failed to build XLIFFKit with Swift 5.8 for macOS (Xcode) using Xcode 14.3 at main.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.25.4
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/mattcomi/XLIFFKit.git
Reference: main
Initialized empty Git repository in /Users/admin/builds/vMd7uqzK/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/mattcomi/XLIFFKit
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at a2367f4 Update README.md
Cloned https://github.com/mattcomi/XLIFFKit.git
Revision (git rev-parse @):
a2367f4942d8dda85538184eefdd5d0261cd71e9
SUCCESS checkout https://github.com/mattcomi/XLIFFKit.git at main
========================================
Build
========================================
Selected platform:         macosXcodebuild
Swift version:             5.8
Building package at path:  $PWD/checkout
Command line invocation:
    /Applications/Xcode-14.3.1.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/admin/builds/vMd7uqzK/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies
User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/admin/builds/vMd7uqzK/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph
package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.0
Resolved source packages:
  spi-builder-workspace: /Users/admin/builds/vMd7uqzK/0/finestructure/swiftpackageindex-builder/spi-builder-workspace
Resolve Package Graph
package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.0
2023-11-21 10:25:00.812 xcodebuild[13756:61969788] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
2023-11-21 10:25:00.915 xcodebuild[13756:61969788] Writing error result bundle to /var/folders/n8/pp_chp6x3jlfy1n94r6hdjv40000gn/T/ResultBundle_2023-21-11_10-25-0000.xcresult
2023-11-21 10:25:01.894 xcodebuild[13756:61969788] [MT] DVTAssertions: Warning in /System/Volumes/Data/SWE/Apps/DT/BuildRoots/BuildRoot7/ActiveBuildRoot/Library/Caches/com.apple.xbs/Sources/IDEFrameworks/IDEFrameworks-21815/IDEFoundation/Execution/RunContextManager/IDERunContextManager.m:842
Details:  Error deleting scheme: Cannot modify data because the process disallows saving.
Object:   <IDERunContextManager: 0x600000cb0ea0>
Method:   -deleteRunContexts:completionQueue:completionBlock:
Thread:   <_NSMainThread: 0x600002bb4200>{number = 1, name = main}
Please file a bug at https://feedbackassistant.apple.com with this warning message and any useful information you can provide.
2023-11-21 10:25:01.900 xcodebuild[13756:61969788] could not delete old scheme: Error Domain=DVTCustomDataStoringErrors Code=0 "Cannot modify data because the process disallows saving." UserInfo={NSLocalizedDescription=Cannot modify data because the process disallows saving.}
xcodebuild: error: Could not resolve package dependencies:
  package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.0
GENERIC FAILURE 5.8 macosXcodebuild