The Swift Package Index logo.Swift Package Index

Build Information

Failed to build elementary-components, reference 1.0.1 (03519c), with Swift 6.4 for macOS (SPM) on 23 Sep 2026 13:33:05 UTC.

Build Command

env DEVELOPER_DIR=/Applications/Xcode-27.0.0-Release.Candidate.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 5.1.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/h0p3zZ/elementary-components.git
Reference: 1.0.1
Initialized empty Git repository in /Users/admin/builder/spi-builder-workspace/.git/
From https://github.com/h0p3zZ/elementary-components
 * tag               1.0.1      -> FETCH_HEAD
HEAD is now at 03519c9 updated elementary package reference
Cloned https://github.com/h0p3zZ/elementary-components.git
Revision (git rev-parse @):
03519c93fae21bee03e367c50838d1b2563f5df9
SUCCESS checkout https://github.com/h0p3zZ/elementary-components.git at 1.0.1
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             6.4
Building package at path:  $PWD
https://github.com/h0p3zZ/elementary-components.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-27.0.0-Release.Candidate.app xcrun swift build --arch arm64
Building for debugging...
[Pre-planning 1 / 96]
[Planning deferred tasks]
Fetching https://github.com/elementary-swift/elementary.git
[1/2212] Fetching elementary
Fetched https://github.com/elementary-swift/elementary.git (1.07s)
Computing version for https://github.com/elementary-swift/elementary.git
Computed https://github.com/elementary-swift/elementary.git at 0.8.1 (1.73s)
Creating working copy for https://github.com/elementary-swift/elementary.git
Working copy of https://github.com/elementary-swift/elementary.git resolved at 0.8.1
error: The package product 'Elementary-product' requires minimum platform version 14.0 for the macOS platform, but this target supports 12.0
error: The package product 'Elementary-product' requires minimum platform version 14.0 for the macOS platform, but this target supports 12.0
error: Build failed
BUILD FAILURE 6.4 macosSpm