The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build swift-filter with Swift 5.8 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-14.3.1.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.37.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/roanutil/swift-filter.git
Reference: main
Initialized empty Git repository in /Users/builder/builds/o86TiJKT/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/roanutil/swift-filter
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 662d7e8 Merge pull request #10 from roanutil/feature/getter-for-values
Cloned https://github.com/roanutil/swift-filter.git
Revision (git rev-parse @):
662d7e8a237862f9d357d17e6aa4e0f694f9f728
SPI manifest file found: $workDir/.spi.yml
SUCCESS checkout https://github.com/roanutil/swift-filter.git at main
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.8
Building package at path:  $workDir
https://github.com/roanutil/swift-filter.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-14.3.1.app xcrun swift build --arch arm64
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.1
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.1
BUILD FAILURE 5.8 macosSpm

Build Machine: Mac 5