The Swift Package Index logo.Swift Package Index

Build Information

Failed to build DevCycle, reference main (8f1879), with Swift 6.3 for macOS (SPM) on 24 Oct 2026 19:51:38 UTC.

Build Command

env DEVELOPER_DIR=/Applications/Xcode-26.5.0.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 5.1.3
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/DevCycleHQ/ios-client-sdk.git
Reference: main
Initialized empty Git repository in /Users/admin/builder/spi-builder-workspace/.git/
From https://github.com/DevCycleHQ/ios-client-sdk
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 8f18790 build(deps): bump DevCycleHQ/release-action from 2.3.0 to 2.4.0 (#274)
Cloned https://github.com/DevCycleHQ/ios-client-sdk.git
Revision (git rev-parse @):
8f187907ed557a374af14443b584807c51cc083b
SUCCESS checkout https://github.com/DevCycleHQ/ios-client-sdk.git at main
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             6.3
Building package at path:  $PWD
https://github.com/DevCycleHQ/ios-client-sdk.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-26.5.0.app xcrun swift build --arch arm64
Fetching https://github.com/LaunchDarkly/swift-eventsource.git
[1/2077] Fetching swift-eventsource
Fetched https://github.com/LaunchDarkly/swift-eventsource.git from cache (1.10s)
Computing version for https://github.com/LaunchDarkly/swift-eventsource.git
Computed https://github.com/LaunchDarkly/swift-eventsource.git at 3.4.0 (1.79s)
Creating working copy for https://github.com/LaunchDarkly/swift-eventsource.git
Working copy of https://github.com/LaunchDarkly/swift-eventsource.git resolved at 3.4.0
error: the library 'DevCycle' requires macos 10.13, but depends on the product 'LDSwiftEventSource' which requires macos 12.0; consider changing the library 'DevCycle' to require macos 12.0 or later, or the product 'LDSwiftEventSource' to require macos 10.13 or earlier.
BUILD FAILURE 6.3 macosSpm