The Swift Package Index logo.Swift Package Index

Build Information

Failed to build Uridium with Swift 5.8 for Linux.

Build Command

docker run --rm -v "checkouts-4609320-0":/host -w "/host/spi-builder-workspace" registry.gitlab.com/finestructure/spi-images:basic-5.8-latest swift build 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.16.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/aestesis/Uridium.git
Reference: 2.0.1
Cloned https://github.com/aestesis/Uridium.git into spi-builder-workspace
SUCCESS checkout https://github.com/aestesis/Uridium.git at 2.0.1
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.8
Building package at path:  spi-builder-workspace
Running build ...
docker run --rm -v "checkouts-4609320-0":/host -w "/host/spi-builder-workspace" registry.gitlab.com/finestructure/spi-images:basic-5.8-latest swift build 2>&1
Fetching https://github.com/aestesis/xcb.git
Fetching https://github.com/aestesis/Vulkan.git
Fetched https://github.com/aestesis/xcb.git (0.19s)
Fetched https://github.com/aestesis/Vulkan.git (0.19s)
Computing version for https://github.com/aestesis/Vulkan.git
Computed https://github.com/aestesis/Vulkan.git at 1.0.6 (0.31s)
Computing version for https://github.com/aestesis/xcb.git
Computed https://github.com/aestesis/xcb.git at 1.0.1 (0.30s)
Creating working copy for https://github.com/aestesis/xcb.git
Working copy of https://github.com/aestesis/xcb.git resolved at 1.0.1
Creating working copy for https://github.com/aestesis/Vulkan.git
Working copy of https://github.com/aestesis/Vulkan.git resolved at 1.0.6
Building for debugging...
error: emit-module command failed with exit code 1 (use -v to see invocation)
[1/4] Emitting module Uridium
/host/spi-builder-workspace/.build/checkouts/Vulkan/Sources/Vulkan/module.modulemap:3:12: error: header '/usr/include/vulkan/vulkan.h' not found
    header "/usr/include/vulkan/vulkan.h"
           ^
/host/spi-builder-workspace/Sources/Uridium/LunarLayer.swift:1:8: error: could not build C module 'Vulkan'
import Vulkan
       ^
[2/4] Compiling Uridium LunarLayer.swift
/host/spi-builder-workspace/.build/checkouts/Vulkan/Sources/Vulkan/module.modulemap:3:12: error: header '/usr/include/vulkan/vulkan.h' not found
    header "/usr/include/vulkan/vulkan.h"
           ^
/host/spi-builder-workspace/Sources/Uridium/LunarLayer.swift:1:8: error: could not build C module 'Vulkan'
import Vulkan
       ^
[3/4] Compiling Uridium Tin.swift
/host/spi-builder-workspace/.build/checkouts/Vulkan/Sources/Vulkan/module.modulemap:3:12: error: header '/usr/include/vulkan/vulkan.h' not found
    header "/usr/include/vulkan/vulkan.h"
           ^
/host/spi-builder-workspace/Sources/Uridium/LunarLayer.swift:1:8: error: could not build C module 'Vulkan'
import Vulkan
       ^
[4/4] Compiling Uridium Window.swift
/host/spi-builder-workspace/.build/checkouts/Vulkan/Sources/Vulkan/module.modulemap:3:12: error: header '/usr/include/vulkan/vulkan.h' not found
    header "/usr/include/vulkan/vulkan.h"
           ^
/host/spi-builder-workspace/Sources/Uridium/LunarLayer.swift:1:8: error: could not build C module 'Vulkan'
import Vulkan
       ^
BUILD FAILURE 5.8 linux

Build Machine: Linux 2