The Swift Package Index logo.Swift Package Index

Build Information

Successful build of swift-rfc-2045, reference main (0d5b95), with Swift 6.4 for Android on 2 Oct 2026 23:30:28 UTC.

Swift 6 data race errors: 0

Build Command

bash -c docker run --pull=always --rm -v "checkouts-54344845-1":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:android-6.4-latest swift build --swift-sdk aarch64-unknown-linux-android28 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 5.1.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/swift-ietf/swift-rfc-2045.git
Reference: main
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/swift-ietf/swift-rfc-2045
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 0d5b95e Split the Foundation integration out of the core
Cloned https://github.com/swift-ietf/swift-rfc-2045.git
Revision (git rev-parse @):
0d5b95ebeee3caf09fdfc9a587c22f31c7e5f334
SPI manifest file found: $PWD/.spi.yml
SUCCESS checkout https://github.com/swift-ietf/swift-rfc-2045.git at main
========================================
Build
========================================
Selected platform:         android
Swift version:             6.4
Building package at path:  $PWD
https://github.com/swift-ietf/swift-rfc-2045.git
Running build ...
bash -c docker run --pull=always --rm -v "checkouts-54344845-1":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:android-6.4-latest swift build --swift-sdk aarch64-unknown-linux-android28 2>&1
android-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:abadcff584c273feba50641b454858d377ba30b35ea7287a94f45ebd8afd0ea0
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:android-6.4-latest
Fetching https://github.com/swift-atoms/swift-ascii.git
[1/780] Fetching swift-ascii
Fetched https://github.com/swift-atoms/swift-ascii.git (0.43s)
Fetching https://github.com/swift-atoms/swift-byte.git
[1/594] Fetching swift-byte
Fetched https://github.com/swift-atoms/swift-byte.git (0.43s)
Fetching https://github.com/swift-ietf/swift-rfc-5322.git
[1/1337] Fetching swift-rfc-5322
Fetched https://github.com/swift-ietf/swift-rfc-5322.git (0.45s)
Fetching https://github.com/swift-atoms/swift-carrier.git
[1/1402] Fetching swift-carrier
Fetched https://github.com/swift-atoms/swift-carrier.git (0.51s)
Fetching https://github.com/swift-atoms/swift-checkpoint.git
[1/73] Fetching swift-checkpoint
Fetched https://github.com/swift-atoms/swift-checkpoint.git (0.39s)
Fetching https://github.com/swift-atoms/swift-coder.git
[1/1030] Fetching swift-coder
Fetched https://github.com/swift-atoms/swift-coder.git (0.45s)
Fetching https://github.com/swift-atoms/swift-cursor.git
[1/304] Fetching swift-cursor
Fetched https://github.com/swift-atoms/swift-cursor.git (0.48s)
Fetching https://github.com/swift-atoms/swift-iterator.git
[1/628] Fetching swift-iterator
Fetched https://github.com/swift-atoms/swift-iterator.git (0.49s)
Fetching https://github.com/swift-atoms/swift-parser.git
[1/4492] Fetching swift-parser
Fetched https://github.com/swift-atoms/swift-parser.git (0.48s)
Fetching https://github.com/swift-atoms/swift-serializer.git
[1/852] Fetching swift-serializer
Fetched https://github.com/swift-atoms/swift-serializer.git (0.46s)
Fetching https://github.com/swift-atoms/swift-bit.git
[1/853] Fetching swift-bit
Fetched https://github.com/swift-atoms/swift-bit.git (0.46s)
Fetching https://github.com/swift-atoms/swift-index.git
[1/1055] Fetching swift-index
Fetched https://github.com/swift-atoms/swift-index.git (0.42s)
Fetching https://github.com/swift-atoms/swift-finite.git
[1/824] Fetching swift-finite
Fetched https://github.com/swift-atoms/swift-finite.git (0.37s)
Fetching https://github.com/swift-atoms/swift-ordinal.git
[1/1465] Fetching swift-ordinal
Fetched https://github.com/swift-atoms/swift-ordinal.git (0.40s)
Fetching https://github.com/swift-atoms/swift-tagged.git
[1/1858] Fetching swift-tagged
Fetched https://github.com/swift-atoms/swift-tagged.git (0.45s)
Fetching https://github.com/swift-ietf/swift-rfc-1123.git
[1/605] Fetching swift-rfc-1123
Fetched https://github.com/swift-ietf/swift-rfc-1123.git (0.46s)
Fetching https://github.com/swift-atoms/swift-standard-library-extensions.git
[1/1234] Fetching swift-standard-library-extensions
Fetched https://github.com/swift-atoms/swift-standard-library-extensions.git (0.46s)
Fetching https://github.com/swift-atoms/swift-time.git
[1/1049] Fetching swift-time
Fetched https://github.com/swift-atoms/swift-time.git (0.54s)
Fetching https://github.com/swift-atoms/swift-calendar.git
[1/157] Fetching swift-calendar
Fetched https://github.com/swift-atoms/swift-calendar.git (0.42s)
Fetching https://github.com/swift-molecules/swift-calendar-gregorian.git
[1/139] Fetching swift-calendar-gregorian
Fetched https://github.com/swift-molecules/swift-calendar-gregorian.git (0.41s)
Fetching https://github.com/swift-incits/swift-incits-4-1986.git
[1/1301] Fetching swift-incits-4-1986
Fetched https://github.com/swift-incits/swift-incits-4-1986.git (0.50s)
Fetching https://github.com/swift-atoms/swift-always.git
[1/65] Fetching swift-always
Fetched https://github.com/swift-atoms/swift-always.git (0.38s)
Fetching https://github.com/swift-atoms/swift-repetition.git
[1/40] Fetching swift-repetition
Fetched https://github.com/swift-atoms/swift-repetition.git (0.39s)
Fetching https://github.com/swift-atoms/swift-cardinal.git
[1/1437] Fetching swift-cardinal
Fetched https://github.com/swift-atoms/swift-cardinal.git (0.45s)
Fetching https://github.com/swift-atoms/swift-predicate.git
[1/537] Fetching swift-predicate
Fetched https://github.com/swift-atoms/swift-predicate.git (0.43s)
Fetching https://github.com/swift-atoms/swift-either.git
[1/399] Fetching swift-either
Fetched https://github.com/swift-atoms/swift-either.git (0.41s)
Fetching https://github.com/swift-atoms/swift-pair.git
[1/375] Fetching swift-pair
Fetched https://github.com/swift-atoms/swift-pair.git (0.43s)
Fetching https://github.com/swift-atoms/swift-skip.git
[1/30] Fetching swift-skip
Fetched https://github.com/swift-atoms/swift-skip.git (0.37s)
Fetching https://github.com/swift-atoms/swift-map.git
[1/36] Fetching swift-map
Fetched https://github.com/swift-atoms/swift-map.git (0.46s)
Fetching https://github.com/swift-atoms/swift-optic.git
[1/761] Fetching swift-optic
Fetched https://github.com/swift-atoms/swift-optic.git (0.60s)
Fetching https://github.com/swift-atoms/swift-operation.git
[1/322] Fetching swift-operation
Fetched https://github.com/swift-atoms/swift-operation.git (0.40s)
Fetching https://github.com/swift-atoms/swift-empty.git
[1/178] Fetching swift-empty
Fetched https://github.com/swift-atoms/swift-empty.git (0.77s)
Fetching https://github.com/swift-atoms/swift-single.git
[1/199] Fetching swift-single
Fetched https://github.com/swift-atoms/swift-single.git (0.74s)
Fetching https://github.com/swift-atoms/swift-search.git
[1/45] Fetching swift-search
Fetched https://github.com/swift-atoms/swift-search.git (0.34s)
Fetching https://github.com/swift-atoms/swift-append.git
[1/33] Fetching swift-append
Fetched https://github.com/swift-atoms/swift-append.git (0.37s)
Fetching https://github.com/swift-atoms/swift-flatmap.git
[1/30] Fetching swift-flatmap
Fetched https://github.com/swift-atoms/swift-flatmap.git (0.39s)
Fetching https://github.com/swift-atoms/swift-lazy.git
[1/76] Fetching swift-lazy
Fetched https://github.com/swift-atoms/swift-lazy.git (0.43s)
Fetching https://github.com/swift-atoms/swift-collection.git
[1/1295] Fetching swift-collection
Fetched https://github.com/swift-atoms/swift-collection.git (0.45s)
Fetching https://github.com/swift-atoms/swift-product.git
[1/602] Fetching swift-product
Fetched https://github.com/swift-atoms/swift-product.git (0.49s)
Fetching https://github.com/swift-atoms/swift-difference.git
[1/176] Fetching swift-difference
Fetched https://github.com/swift-atoms/swift-difference.git (0.41s)
Fetching https://github.com/swift-atoms/swift-algebra.git
[1/1674] Fetching swift-algebra
Fetched https://github.com/swift-atoms/swift-algebra.git (0.52s)
Fetching https://github.com/swift-atoms/swift-polarity.git
[1/219] Fetching swift-polarity
Fetched https://github.com/swift-atoms/swift-polarity.git (0.44s)
Fetching https://github.com/swift-atoms/swift-magnitude.git
[1/103] Fetching swift-magnitude
Fetched https://github.com/swift-atoms/swift-magnitude.git (0.38s)
Fetching https://github.com/swift-atoms/swift-property.git
[1/1563] Fetching swift-property
Fetched https://github.com/swift-atoms/swift-property.git (0.45s)
Fetching https://github.com/swift-atoms/swift-successor.git
[1/68] Fetching swift-successor
Fetched https://github.com/swift-atoms/swift-successor.git (0.40s)
Fetching https://github.com/swift-atoms/swift-predecessor.git
[1/68] Fetching swift-predecessor
Fetched https://github.com/swift-atoms/swift-predecessor.git (0.77s)
Fetching https://github.com/swift-atoms/swift-advancement.git
[1/68] Fetching swift-advancement
Fetched https://github.com/swift-atoms/swift-advancement.git (0.38s)
Fetching https://github.com/swift-atoms/swift-retreat.git
[1/68] Fetching swift-retreat
Fetched https://github.com/swift-atoms/swift-retreat.git (0.59s)
Fetching https://github.com/swift-atoms/swift-distance.git
[1/68] Fetching swift-distance
Fetched https://github.com/swift-atoms/swift-distance.git (0.39s)
Fetching https://github.com/swift-ietf/swift-rfc-1035.git
[1/697] Fetching swift-rfc-1035
Fetched https://github.com/swift-ietf/swift-rfc-1035.git (0.43s)
Fetching https://github.com/swift-atoms/swift-addition.git
[1/79] Fetching swift-addition
Fetched https://github.com/swift-atoms/swift-addition.git (0.42s)
Fetching https://github.com/swift-atoms/swift-coordinate.git
[1/49] Fetching swift-coordinate
Fetched https://github.com/swift-atoms/swift-coordinate.git (0.42s)
Fetching https://github.com/swift-atoms/swift-translation.git
[1/47] Fetching swift-translation
Fetched https://github.com/swift-atoms/swift-translation.git (0.39s)
Fetching https://github.com/swift-atoms/swift-division.git
[1/84] Fetching swift-division
Fetched https://github.com/swift-atoms/swift-division.git (0.38s)
Fetching https://github.com/swift-atoms/swift-rational.git
[1/115] Fetching swift-rational
Fetched https://github.com/swift-atoms/swift-rational.git (0.42s)
Fetching https://github.com/swift-atoms/swift-ratio.git
[1/163] Fetching swift-ratio
Fetched https://github.com/swift-atoms/swift-ratio.git (0.33s)
Fetching https://github.com/swift-atoms/swift-subtraction.git
[1/59] Fetching swift-subtraction
Fetched https://github.com/swift-atoms/swift-subtraction.git (0.33s)
Fetching https://github.com/swift-atoms/swift-logic.git
[1/1008] Fetching swift-logic
Fetched https://github.com/swift-atoms/swift-logic.git (0.40s)
Fetching https://github.com/swift-atoms/swift-contramap.git
[1/33] Fetching swift-contramap
Fetched https://github.com/swift-atoms/swift-contramap.git (0.36s)
Fetching https://github.com/swift-atoms/swift-bifunctor.git
[1/213] Fetching swift-bifunctor
Fetched https://github.com/swift-atoms/swift-bifunctor.git (1.13s)
Fetching https://github.com/swift-atoms/swift-coproduct.git
[1/429] Fetching swift-coproduct
Fetched https://github.com/swift-atoms/swift-coproduct.git (0.40s)
Fetching https://github.com/swift-atoms/swift-sequence.git
[1/2186] Fetching swift-sequence
Fetched https://github.com/swift-atoms/swift-sequence.git (0.48s)
Fetching https://github.com/swift-atoms/swift-order.git
[1/864] Fetching swift-order
Fetched https://github.com/swift-atoms/swift-order.git (0.38s)
Fetching https://github.com/swift-atoms/swift-ownership.git
[1/3106] Fetching swift-ownership
Fetched https://github.com/swift-atoms/swift-ownership.git (0.95s)
Fetching https://github.com/swift-atoms/swift-vector.git
[1/118] Fetching swift-vector
Fetched https://github.com/swift-atoms/swift-vector.git (0.37s)
Fetching https://github.com/swift-atoms/swift-rounding.git
[1/61] Fetching swift-rounding
Fetched https://github.com/swift-atoms/swift-rounding.git (0.35s)
Fetching https://github.com/swift-atoms/swift-integer.git
[1/105] Fetching swift-integer
Fetched https://github.com/swift-atoms/swift-integer.git (0.35s)
Fetching https://github.com/swift-atoms/swift-multiplication.git
[1/79] Fetching swift-multiplication
Fetched https://github.com/swift-atoms/swift-multiplication.git (0.33s)
Fetching https://github.com/swift-atoms/swift-memory.git
[1/1981] Fetching swift-memory
Fetched https://github.com/swift-atoms/swift-memory.git (0.45s)
Fetching https://github.com/swift-atoms/swift-span.git
[1/433] Fetching swift-span
Fetched https://github.com/swift-atoms/swift-span.git (0.37s)
Fetching https://github.com/swift-atoms/swift-error.git
[1/350] Fetching swift-error
Fetched https://github.com/swift-atoms/swift-error.git (0.36s)
Fetching https://github.com/swiftlang/swift-syntax.git
[1/80201] Fetching swift-syntax
Fetched https://github.com/swiftlang/swift-syntax.git (3.91s)
Computing version for https://github.com/swiftlang/swift-syntax.git
Computed https://github.com/swiftlang/swift-syntax.git at 603.0.2 (5.27s)
Creating working copy for https://github.com/swift-atoms/swift-iterator.git
Working copy of https://github.com/swift-atoms/swift-iterator.git resolved at main (e276f0c)
Creating working copy for https://github.com/swift-atoms/swift-addition.git
Working copy of https://github.com/swift-atoms/swift-addition.git resolved at main (7662e87)
Creating working copy for https://github.com/swift-atoms/swift-coproduct.git
Working copy of https://github.com/swift-atoms/swift-coproduct.git resolved at main (224eb87)
Creating working copy for https://github.com/swift-atoms/swift-byte.git
Working copy of https://github.com/swift-atoms/swift-byte.git resolved at main (50bd3e3)
Creating working copy for https://github.com/swift-atoms/swift-always.git
Working copy of https://github.com/swift-atoms/swift-always.git resolved at main (1229653)
Creating working copy for https://github.com/swift-atoms/swift-integer.git
Working copy of https://github.com/swift-atoms/swift-integer.git resolved at main (05212bf)
Creating working copy for https://github.com/swift-atoms/swift-algebra.git
Working copy of https://github.com/swift-atoms/swift-algebra.git resolved at main (6f0468a)
Creating working copy for https://github.com/swift-atoms/swift-operation.git
Working copy of https://github.com/swift-atoms/swift-operation.git resolved at main (6b09f83)
Creating working copy for https://github.com/swift-atoms/swift-append.git
Working copy of https://github.com/swift-atoms/swift-append.git resolved at main (5a2c22d)
Creating working copy for https://github.com/swift-atoms/swift-ascii.git
Working copy of https://github.com/swift-atoms/swift-ascii.git resolved at main (a365691)
Creating working copy for https://github.com/swift-atoms/swift-rational.git
Working copy of https://github.com/swift-atoms/swift-rational.git resolved at main (f973aa9)
Creating working copy for https://github.com/swift-atoms/swift-distance.git
Working copy of https://github.com/swift-atoms/swift-distance.git resolved at main (1856165)
Creating working copy for https://github.com/swift-atoms/swift-calendar.git
Working copy of https://github.com/swift-atoms/swift-calendar.git resolved at main (92ed545)
Creating working copy for https://github.com/swift-atoms/swift-ratio.git
Working copy of https://github.com/swift-atoms/swift-ratio.git resolved at main (089c5d6)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1035.git
Working copy of https://github.com/swift-ietf/swift-rfc-1035.git resolved at main (215fda4)
Creating working copy for https://github.com/swift-atoms/swift-cursor.git
Working copy of https://github.com/swift-atoms/swift-cursor.git resolved at main (0c4eb8c)
Creating working copy for https://github.com/swift-atoms/swift-difference.git
Working copy of https://github.com/swift-atoms/swift-difference.git resolved at main (fb95a3f)
Creating working copy for https://github.com/swift-atoms/swift-bifunctor.git
Working copy of https://github.com/swift-atoms/swift-bifunctor.git resolved at main (18fe386)
Creating working copy for https://github.com/swift-atoms/swift-rounding.git
Working copy of https://github.com/swift-atoms/swift-rounding.git resolved at main (5481997)
Creating working copy for https://github.com/swift-atoms/swift-successor.git
Working copy of https://github.com/swift-atoms/swift-successor.git resolved at main (ab8561a)
Creating working copy for https://github.com/swift-atoms/swift-error.git
Working copy of https://github.com/swift-atoms/swift-error.git resolved at main (f6ad8ee)
Creating working copy for https://github.com/swift-atoms/swift-tagged.git
Working copy of https://github.com/swift-atoms/swift-tagged.git resolved at main (6e00f02)
Creating working copy for https://github.com/swift-atoms/swift-checkpoint.git
Working copy of https://github.com/swift-atoms/swift-checkpoint.git resolved at main (aa7b4ec)
Creating working copy for https://github.com/swift-atoms/swift-lazy.git
Working copy of https://github.com/swift-atoms/swift-lazy.git resolved at main (f12c258)
Creating working copy for https://github.com/swift-atoms/swift-either.git
Working copy of https://github.com/swift-atoms/swift-either.git resolved at main (46c666a)
Creating working copy for https://github.com/swift-atoms/swift-translation.git
Working copy of https://github.com/swift-atoms/swift-translation.git resolved at main (32e900c)
Creating working copy for https://github.com/swift-atoms/swift-multiplication.git
Working copy of https://github.com/swift-atoms/swift-multiplication.git resolved at main (f07296d)
Creating working copy for https://github.com/swift-atoms/swift-predicate.git
Working copy of https://github.com/swift-atoms/swift-predicate.git resolved at main (57d2250)
Creating working copy for https://github.com/swift-atoms/swift-map.git
Working copy of https://github.com/swift-atoms/swift-map.git resolved at main (317c5f8)
Creating working copy for https://github.com/swift-atoms/swift-pair.git
Working copy of https://github.com/swift-atoms/swift-pair.git resolved at main (d71085f)
Creating working copy for https://github.com/swift-atoms/swift-subtraction.git
Working copy of https://github.com/swift-atoms/swift-subtraction.git resolved at main (4614d98)
Creating working copy for https://github.com/swift-incits/swift-incits-4-1986.git
Working copy of https://github.com/swift-incits/swift-incits-4-1986.git resolved at main (b208aff)
Creating working copy for https://github.com/swift-atoms/swift-coder.git
Working copy of https://github.com/swift-atoms/swift-coder.git resolved at main (627a31c)
Creating working copy for https://github.com/swift-atoms/swift-polarity.git
Working copy of https://github.com/swift-atoms/swift-polarity.git resolved at main (4880d7d)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1123.git
Working copy of https://github.com/swift-ietf/swift-rfc-1123.git resolved at main (0563819)
Creating working copy for https://github.com/swift-atoms/swift-retreat.git
Working copy of https://github.com/swift-atoms/swift-retreat.git resolved at main (c78a367)
Creating working copy for https://github.com/swift-atoms/swift-cardinal.git
Working copy of https://github.com/swift-atoms/swift-cardinal.git resolved at main (a4beb26)
Creating working copy for https://github.com/swift-atoms/swift-standard-library-extensions.git
Working copy of https://github.com/swift-atoms/swift-standard-library-extensions.git resolved at main (a727a9e)
Creating working copy for https://github.com/swift-atoms/swift-coordinate.git
Working copy of https://github.com/swift-atoms/swift-coordinate.git resolved at main (6c56b05)
Creating working copy for https://github.com/swift-atoms/swift-vector.git
Working copy of https://github.com/swift-atoms/swift-vector.git resolved at main (915cd7c)
Creating working copy for https://github.com/swift-atoms/swift-search.git
Working copy of https://github.com/swift-atoms/swift-search.git resolved at main (ab399f1)
Creating working copy for https://github.com/swift-atoms/swift-single.git
Working copy of https://github.com/swift-atoms/swift-single.git resolved at main (e468dca)
Creating working copy for https://github.com/swift-atoms/swift-division.git
Working copy of https://github.com/swift-atoms/swift-division.git resolved at main (fe65e48)
Creating working copy for https://github.com/swift-atoms/swift-serializer.git
Working copy of https://github.com/swift-atoms/swift-serializer.git resolved at main (3971b0a)
Creating working copy for https://github.com/swift-atoms/swift-advancement.git
Working copy of https://github.com/swift-atoms/swift-advancement.git resolved at main (b947ae1)
Creating working copy for https://github.com/swift-atoms/swift-span.git
Working copy of https://github.com/swift-atoms/swift-span.git resolved at main (81b5071)
Creating working copy for https://github.com/swift-atoms/swift-skip.git
Working copy of https://github.com/swift-atoms/swift-skip.git resolved at main (728b918)
Creating working copy for https://github.com/swift-atoms/swift-empty.git
Working copy of https://github.com/swift-atoms/swift-empty.git resolved at main (134c48b)
Creating working copy for https://github.com/swiftlang/swift-syntax.git
Working copy of https://github.com/swiftlang/swift-syntax.git resolved at 603.0.2
Creating working copy for https://github.com/swift-atoms/swift-collection.git
Working copy of https://github.com/swift-atoms/swift-collection.git resolved at main (7013fe3)
Creating working copy for https://github.com/swift-molecules/swift-calendar-gregorian.git
Working copy of https://github.com/swift-molecules/swift-calendar-gregorian.git resolved at main (301a29c)
Creating working copy for https://github.com/swift-atoms/swift-parser.git
Working copy of https://github.com/swift-atoms/swift-parser.git resolved at main (0913ad9)
Creating working copy for https://github.com/swift-atoms/swift-ownership.git
Working copy of https://github.com/swift-atoms/swift-ownership.git resolved at main (f8702ec)
Creating working copy for https://github.com/swift-atoms/swift-index.git
Working copy of https://github.com/swift-atoms/swift-index.git resolved at main (425b76c)
Creating working copy for https://github.com/swift-atoms/swift-repetition.git
Working copy of https://github.com/swift-atoms/swift-repetition.git resolved at main (b2fafee)
Creating working copy for https://github.com/swift-atoms/swift-sequence.git
Working copy of https://github.com/swift-atoms/swift-sequence.git resolved at main (7c462e3)
Creating working copy for https://github.com/swift-atoms/swift-bit.git
Working copy of https://github.com/swift-atoms/swift-bit.git resolved at main (30f6189)
Creating working copy for https://github.com/swift-atoms/swift-logic.git
Working copy of https://github.com/swift-atoms/swift-logic.git resolved at main (91fbf3b)
Creating working copy for https://github.com/swift-atoms/swift-magnitude.git
Working copy of https://github.com/swift-atoms/swift-magnitude.git resolved at main (6c31511)
Creating working copy for https://github.com/swift-atoms/swift-carrier.git
Working copy of https://github.com/swift-atoms/swift-carrier.git resolved at main (ee19248)
Creating working copy for https://github.com/swift-atoms/swift-optic.git
Working copy of https://github.com/swift-atoms/swift-optic.git resolved at main (72cf3fd)
Creating working copy for https://github.com/swift-atoms/swift-order.git
Working copy of https://github.com/swift-atoms/swift-order.git resolved at main (a1866fe)
Creating working copy for https://github.com/swift-atoms/swift-finite.git
Working copy of https://github.com/swift-atoms/swift-finite.git resolved at main (f3eac5b)
Creating working copy for https://github.com/swift-atoms/swift-memory.git
Working copy of https://github.com/swift-atoms/swift-memory.git resolved at main (dc058d2)
Creating working copy for https://github.com/swift-atoms/swift-contramap.git
Working copy of https://github.com/swift-atoms/swift-contramap.git resolved at main (c719674)
Creating working copy for https://github.com/swift-atoms/swift-ordinal.git
Working copy of https://github.com/swift-atoms/swift-ordinal.git resolved at main (bdb3f64)
Creating working copy for https://github.com/swift-atoms/swift-property.git
Working copy of https://github.com/swift-atoms/swift-property.git resolved at main (5b9a7f3)
Creating working copy for https://github.com/swift-atoms/swift-time.git
Working copy of https://github.com/swift-atoms/swift-time.git resolved at main (c6cb993)
Creating working copy for https://github.com/swift-ietf/swift-rfc-5322.git
Working copy of https://github.com/swift-ietf/swift-rfc-5322.git resolved at main (e9864e0)
Creating working copy for https://github.com/swift-atoms/swift-flatmap.git
Working copy of https://github.com/swift-atoms/swift-flatmap.git resolved at main (03442d2)
Creating working copy for https://github.com/swift-atoms/swift-product.git
Working copy of https://github.com/swift-atoms/swift-product.git resolved at main (d4702f8)
Creating working copy for https://github.com/swift-atoms/swift-predecessor.git
Working copy of https://github.com/swift-atoms/swift-predecessor.git resolved at main (42a711d)
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-5322': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-5322': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
Building for debugging...
[Computing dependencies]
[Constructing description]
[Pre-planning 1 / 2194]
[Planning 111 / 2194]
[Planning 1429 / 2194]
[Planning 1936 / 2194]
[Planning deferred tasks]
[Constructing 861 / 5216]
[Starting]
[183 / 938] Parser
[448 / 949] Operation
[457 / 1003] Product
[476 / 1020] Vector
[502 / 1020] Pair
[512 / 1020] Logic
[513 / 1020] Standard Library Extensions
[524 / 1020] Translation
[526 / 1020] Translation-product
[532 / 1021] Translation
[533 / 1021] Vector
[536 / 1021] Standard Library Extensions
[542 / 1022] Vector
[546 / 1024] Single
[549 / 1024] Skip
[552 / 1024] Search-product
[557 / 1024] Product
[561 / 1025] Product-product
[567 / 1025] Pair
[571 / 1025] Operation
[575 / 1026] Product
[584 / 1028] Standard Library Extensions
[591 / 1028] Logic
[595 / 1029] Standard Library Extensions
[602 / 1030] Standard Library Extensions
[618 / 1058] Either
[630 / 1073] Contramap
[656 / 1075] FlatMap-product
[669 / 1075] Error-product
[680 / 1075] Either
[684 / 1076] Either-product
[694 / 1077] Error
[701 / 1087] Carrier
[714 / 1103] Polarity
[729 / 1121] Always
[743 / 1121] Polarity
[752 / 1122] Polarity
[757 / 1122] Carrier
[769 / 1123] Carrier
[775 / 1125] Carrier
[779 / 1126] Append
[784 / 1126] Algebra
[788 / 1126] Always
[796 / 1130]
[806 / 1158] Tagged
[815 / 1159] Coordinate
[823 / 1160] Tagged
[827 / 1160] Tagged
[840 / 1160] Tagged-product
[843 / 1160] Optic
[845 / 1161] Multiplication
[846 / 1161] Multiplication-product
[853 / 1164]
[859 / 1177] Predicate
[863 / 1177] Predicate
[875 / 1177] Addition
[886 / 1183] Predicate-product
[900 / 1190] Successor-product
[911 / 1209] Subtraction
[925 / 1210] Magnitude
[930 / 1210] Ownership
[940 / 1210] Optic
[947 / 1215]
[952 / 1219]
[968 / 1225] Retreat
[980 / 1239] Retreat-product
[984 / 1240] Distance
[993 / 1240] Property
[1004 / 1241] Successor
[1014 / 1253] Cardinal
[1017 / 1261] Order
[1021 / 1261] Order
[1025 / 1261] Order
[1028 / 1262] Order
[1028 / 1262] Rounding
[1037 / 1262] Cardinal-product
[1038 / 1262] Cardinal-product
[1040 / 1262] Advancement
[1048 / 1267] Rounding
[1060 / 1274] Repetition
[1061 / 1283] Repetition
[1068 / 1283] Repetition
[1074 / 1284] Difference
[1082 / 1285] Rounding
[1084 / 1285] Ordinal
[1090 / 1303] Ordinal
[1093 / 1321] Iterator
[1094 / 1321] Division
[1101 / 1321] Iterator
[1115 / 1321] Ordinal
[1119 / 1321] Ordinal
[1120 / 1321] Ordinal-product
[1121 / 1321] Ordinal-product
[1123 / 1321] Iterator-product
[1126 / 1321] Sequence
[1129 / 1322] Ordinal
[1134 / 1322] Integer-product
[1138 / 1323] Iterator
[1143 / 1325] Property
[1146 / 1325] Index
[1150 / 1326]
[1154 / 1336] Rational
[1158 / 1345] Sequence
[1161 / 1346] Rational
[1169 / 1346] Sequence
[1170 / 1346] Sequence
[1171 / 1346] Sequence
[1172 / 1347] Rational-product
[1173 / 1347] Rational-product
[1177 / 1347] Division
[1183 / 1351] Index
[1191 / 1359] Sequence-product
[1202 / 1361] Index
[1215 / 1363] Order
[1223 / 1382] Finite
[1224 / 1382] Finite
[1228 / 1382] Collection
[1236 / 1382] Collection
[1240 / 1382]
[1249 / 1383] Rounding
[1253 / 1384] Division
[1264 / 1404] Byte
[1266 / 1404] Parser
[1271 / 1404] Byte
[1273 / 1405] Byte
[1281 / 1405] Parser-product
[1283 / 1405] Parser-product
[1287 / 1405] Byte
[1289 / 1405] Byte
[1307 / 1427] Serializer
[1312 / 1427] Span
[1323 / 1427] Serializer
[1335 / 1430] Serializer
[1344 / 1449] Coder
[1351 / 1449] Memory
[1355 / 1449] Coder
[1361 / 1449] Coder
[1365 / 1451] Coder
[1369 / 1460] ASCII
[1371 / 1460] ASCII
[1374 / 1460] Memory
[1376 / 1460] Memory
[1382 / 1470] Ratio
[1384 / 1470] Ratio
[1386 / 1470] Ratio
[1391 / 1471] Ratio
[1394 / 1471] Time
[1398 / 1472]
[1405 / 1474] INCITS 4 1986
[1412 / 1501] Time
[1413 / 1502] INCITS 4 1986
[1416 / 1503] Time
[1418 / 1503] Time
[1422 / 1503] RFC 1035
[1439 / 1503] Time-product
[1442 / 1503] Time-product
[1443 / 1503] RFC 1035-product
[1445 / 1503] RFC 1123
[1447 / 1503] RFC 1123
[1449 / 1503] INCITS 4 1986-product
[1453 / 1503]
[1458 / 1512] RFC 1123
[1461 / 1513] RFC 1123
[1464 / 1514] RFC 1123
[1474 / 1515] RFC 1035
[1483 / 1525] RFC 1035
[1487 / 1526] RFC 1123
[1495 / 1527] RFC 1123
[1503 / 1536] Calendar Gregorian
[1504 / 1537] Calendar
[1506 / 1537] Calendar
[1512 / 1537]
[1517 / 1547] Calendar Gregorian
[1519 / 1547] RFC 5322
[1520 / 1547] RFC 5322
[1522 / 1547] RFC 5322
[1529 / 1549]
[1532 / 1558] RFC 2045
[1535 / 1558] RFC 2045
[1537 / 1558] RFC 2045
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Charset.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentTransferEncoding.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentType.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Parameter.Name.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045.Parameter {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1545 / 1558] RFC 2045
[1548 / 1564] RFC 2045
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Parameter.Name.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045.Parameter {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Charset.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1551 / 1564] RFC 2045 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentTransferEncoding.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1556 / 1564] RFC 2045 Foundation Integration
[1556 / 1564] RFC 5322
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentType.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1564 / 1567] RFC 2045
Build complete! (37.35 secs)
Build complete.
{
  "dependencies" : [
    {
      "identity" : "swift-ascii",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-atoms/swift-ascii.git"
    },
    {
      "identity" : "swift-byte",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-atoms/swift-byte.git"
    },
    {
      "identity" : "swift-rfc-5322",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-ietf/swift-rfc-5322.git"
    }
  ],
  "manifest_display_name" : "swift-rfc-2045",
  "name" : "swift-rfc-2045",
  "path" : "/host/spi-builder-workspace",
  "platforms" : [
    {
      "name" : "macos",
      "version" : "27.0"
    },
    {
      "name" : "ios",
      "version" : "27.0"
    },
    {
      "name" : "tvos",
      "version" : "27.0"
    },
    {
      "name" : "watchos",
      "version" : "27.0"
    },
    {
      "name" : "visionos",
      "version" : "27.0"
    }
  ],
  "products" : [
    {
      "name" : "RFC 2045",
      "targets" : [
        "RFC 2045"
      ],
      "type" : {
        "library" : [
          "automatic"
        ]
      }
    },
    {
      "name" : "RFC 2045 Foundation Integration",
      "targets" : [
        "RFC 2045 Foundation Integration"
      ],
      "type" : {
        "library" : [
          "automatic"
        ]
      }
    }
  ],
  "swift_languages_versions" : [
    "6"
  ],
  "targets" : [
    {
      "c99name" : "RFC_2045_Tests",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Tests",
      "path" : "Tests/RFC 2045 Tests",
      "product_dependencies" : [
        "ASCII",
        "Byte",
        "Byte",
        "RFC 5322"
      ],
      "sources" : [
        "RFC_2045.Charset Tests.swift",
        "RFC_2045.ContentTransferEncoding Tests.swift",
        "RFC_2045.ContentType Tests.swift",
        "RFC_2045.Parameter.Name Tests.swift",
        "RFC_5322.Header.Name Tests.swift"
      ],
      "target_dependencies" : [
        "RFC 2045"
      ],
      "type" : "test"
    },
    {
      "c99name" : "RFC_2045_Foundation_Integration_Tests",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Foundation Integration Tests",
      "path" : "Tests/RFC 2045 Foundation Integration Tests",
      "sources" : [
        "RFC_2045+Codable Tests.swift"
      ],
      "target_dependencies" : [
        "RFC 2045",
        "RFC 2045 Foundation Integration"
      ],
      "type" : "test"
    },
    {
      "c99name" : "RFC_2045_Foundation_Integration",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Foundation Integration",
      "path" : "Sources/RFC 2045 Foundation Integration",
      "product_memberships" : [
        "RFC 2045 Foundation Integration"
      ],
      "sources" : [
        "RFC_2045.Charset+Codable.swift",
        "RFC_2045.ContentTransferEncoding+Codable.swift",
        "RFC_2045.ContentType+Codable.swift",
        "RFC_2045.Parameter.Name+Codable.swift"
      ],
      "target_dependencies" : [
        "RFC 2045"
      ],
      "type" : "library"
    },
    {
      "c99name" : "RFC_2045",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045",
      "path" : "Sources/RFC 2045",
      "product_dependencies" : [
        "ASCII",
        "Byte",
        "Byte",
        "RFC 5322"
      ],
      "product_memberships" : [
        "RFC 2045",
        "RFC 2045 Foundation Integration"
      ],
      "sources" : [
        "RFC_2045.Charset.Error.swift",
        "RFC_2045.Charset.swift",
        "RFC_2045.ContentTransferEncoding.Error.swift",
        "RFC_2045.ContentTransferEncoding.swift",
        "RFC_2045.ContentType.Error.swift",
        "RFC_2045.ContentType.swift",
        "RFC_2045.Grammar.swift",
        "RFC_2045.Parameter.Name.Error.swift",
        "RFC_2045.Parameter.Name.swift",
        "RFC_2045.Parameter.swift",
        "RFC_2045.swift",
        "RFC_5322.Header.Name.swift"
      ],
      "type" : "library"
    }
  ],
  "tools_version" : "6.4"
}
android-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:abadcff584c273feba50641b454858d377ba30b35ea7287a94f45ebd8afd0ea0
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:android-6.4-latest
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
Done.