The Swift Package Index logo.Swift Package Index

Build Information

Successful build of AlamofireImage with Swift 5.9 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.0.0.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.27.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/Alamofire/AlamofireImage.git
Reference: master
Initialized empty Git repository in /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/Alamofire/AlamofireImage
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at 25da70a Update CHANGELOG.md
Cloned https://github.com/Alamofire/AlamofireImage.git
Revision (git rev-parse @):
25da70a7b8f2f1b8c678be123fda5d9a98fac638
SUCCESS checkout https://github.com/Alamofire/AlamofireImage.git at master
warning: 'spi-builder-workspace': /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Package.swift:29:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                      platforms: [.iOS(.v11),
                                        ^
/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
warning: 'spi-builder-workspace': /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Package.swift:29:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                      platforms: [.iOS(.v11),
                                        ^
/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
Fetching https://github.com/Alamofire/Alamofire.git from cache
Fetched https://github.com/Alamofire/Alamofire.git (0.41s)
Computing version for https://github.com/Alamofire/Alamofire.git
warning: 'alamofire': /Package.swift:30:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                                  .iOS(.v11),
                                        ^
/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
Computed https://github.com/Alamofire/Alamofire.git at 5.8.0 (0.09s)
warning: 'alamofire': /Package.swift:30:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                                  .iOS(.v11),
                                        ^
/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
Creating working copy for https://github.com/Alamofire/Alamofire.git
Working copy of https://github.com/Alamofire/Alamofire.git resolved at 5.8.0
warning: 'alamofire': /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/Alamofire/Package.swift:30:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                                  .iOS(.v11),
                                        ^
/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/Alamofire/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
========================================
ResolveProductDependencies
========================================
Resolving dependencies ...
{
  "identity": ".resolve-product-dependencies",
  "name": "resolve-dependencies",
  "url": "/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies",
  "version": "unspecified",
  "path": "/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies",
  "dependencies": [
    {
      "identity": "alamofireimage",
      "name": "AlamofireImage",
      "url": "https://github.com/Alamofire/AlamofireImage.git",
      "version": "unspecified",
      "path": "/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/AlamofireImage",
      "dependencies": [
        {
          "identity": "alamofire",
          "name": "Alamofire",
          "url": "https://github.com/Alamofire/Alamofire.git",
          "version": "5.8.1",
          "path": "/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/Alamofire",
          "dependencies": [
          ]
        }
      ]
    }
  ]
}
Fetching https://github.com/Alamofire/AlamofireImage.git from cache
Fetched https://github.com/Alamofire/AlamofireImage.git (0.32s)
warning: 'alamofireimage': /Package.swift:29:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                      platforms: [.iOS(.v11),
                                        ^
/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
Fetching https://github.com/Alamofire/Alamofire.git from cache
Fetched https://github.com/Alamofire/Alamofire.git (0.28s)
Computing version for https://github.com/Alamofire/Alamofire.git
warning: 'alamofire': /Package.swift:30:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                                  .iOS(.v11),
                                        ^
/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
Computed https://github.com/Alamofire/Alamofire.git at 5.8.1 (0.05s)
warning: 'alamofire': /Package.swift:30:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                                  .iOS(.v11),
                                        ^
/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
Creating working copy for https://github.com/Alamofire/AlamofireImage.git
Working copy of https://github.com/Alamofire/AlamofireImage.git resolved at master
Creating working copy for https://github.com/Alamofire/Alamofire.git
Working copy of https://github.com/Alamofire/Alamofire.git resolved at 5.8.1
warning: 'alamofireimage': /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/AlamofireImage/Package.swift:29:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                      platforms: [.iOS(.v11),
                                        ^
/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/AlamofireImage/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
warning: 'alamofire': /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/Alamofire/Package.swift:30:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                                  .iOS(.v11),
                                        ^
/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/Alamofire/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
warning: '.resolve-product-dependencies': dependency 'alamofireimage' is not used by any target
Found 1 product dependencies
  - Alamofire
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.9
Building package at path:  $PWD/checkout
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.0.0.app xcrun swift build --arch arm64
Building for debugging...
[1/34] Compiling Alamofire ResponseSerialization.swift
[2/34] Compiling Alamofire Result+Alamofire.swift
[3/34] Compiling Alamofire RetryPolicy.swift
[4/34] Compiling Alamofire ServerTrustEvaluation.swift
[5/34] Compiling Alamofire Request.swift
[6/34] Compiling Alamofire RequestCompression.swift
[7/34] Compiling Alamofire RequestInterceptor.swift
[8/34] Compiling Alamofire RequestTaskMap.swift
[9/34] Compiling Alamofire Response.swift
[10/34] Emitting module Alamofire
[11/38] Compiling Alamofire AFError.swift
[12/38] Compiling Alamofire Alamofire.swift
[13/38] Compiling Alamofire AlamofireExtended.swift
[14/38] Compiling Alamofire AuthenticationInterceptor.swift
[15/38] Compiling Alamofire CachedResponseHandler.swift
[16/38] Compiling Alamofire Combine.swift
[17/38] Compiling Alamofire Concurrency.swift
[18/38] Compiling Alamofire DispatchQueue+Alamofire.swift
[19/38] Compiling Alamofire EventMonitor.swift
[20/38] Compiling Alamofire HTTPHeaders.swift
[21/38] Compiling Alamofire OperationQueue+Alamofire.swift
[22/38] Compiling Alamofire ParameterEncoder.swift
[23/38] Compiling Alamofire ParameterEncoding.swift
[24/38] Compiling Alamofire Protected.swift
[25/38] Compiling Alamofire RedirectHandler.swift
[26/38] Compiling Alamofire Session.swift
[27/38] Compiling Alamofire SessionDelegate.swift
[28/38] Compiling Alamofire StringEncoding+Alamofire.swift
[29/38] Compiling Alamofire URLConvertible+URLRequestConvertible.swift
[30/38] Compiling Alamofire HTTPMethod.swift
[31/38] Compiling Alamofire MultipartFormData.swift
[32/38] Compiling Alamofire MultipartUpload.swift
[33/38] Compiling Alamofire NetworkReachabilityManager.swift
[34/38] Compiling Alamofire Notifications.swift
[35/38] Compiling Alamofire URLEncodedFormEncoder.swift
[36/38] Compiling Alamofire URLRequest+Alamofire.swift
[37/38] Compiling Alamofire URLSessionConfiguration+Alamofire.swift
[38/38] Compiling Alamofire Validation.swift
[39/47] Compiling AlamofireImage UIImage+AlamofireImage.swift
[40/48] Emitting module AlamofireImage
[41/48] Compiling AlamofireImage UIButton+AlamofireImage.swift
[42/48] Compiling AlamofireImage UIImageView+AlamofireImage.swift
[43/48] Compiling AlamofireImage ImageFilter.swift
[44/48] Compiling AlamofireImage Request+AlamofireImage.swift
[45/48] Compiling AlamofireImage AFIError.swift
[46/48] Compiling AlamofireImage Image.swift
[47/48] Compiling AlamofireImage ImageCache.swift
[48/48] Compiling AlamofireImage ImageDownloader.swift
Build complete! (20.26s)
warning: 'spi-builder-workspace': /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Package.swift:29:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                      platforms: [.iOS(.v11),
                                        ^
/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
warning: 'alamofire': /Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/Alamofire/Package.swift:30:41: warning: 'v11' is deprecated: iOS 12.0 is the oldest supported version
                                  .iOS(.v11),
                                        ^
/Users/admin/builds/h8344Zi3/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/Alamofire/Package.swift:31:42: warning: 'v11' is deprecated: tvOS 12.0 is the oldest supported version
                                  .tvOS(.v11),
                                         ^
Build complete.
Done.