The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build PostgresWireServer with Swift 5.10 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4606859-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.10-latest swift build 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.29.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/pixelspark/postgres-wire-server.git
Reference: 1.0.2
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/pixelspark/postgres-wire-server
 * tag               1.0.2      -> FETCH_HEAD
HEAD is now at e34100e Add a way to obtain current database
Cloned https://github.com/pixelspark/postgres-wire-server.git
Revision (git rev-parse @):
e34100e120a51ea203e141193e14011cea55534c
SUCCESS checkout https://github.com/pixelspark/postgres-wire-server.git at 1.0.2
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.10
Building package at path:  $workDir
https://github.com/pixelspark/postgres-wire-server.git
Running build ...
bash -c docker run --rm -v "checkouts-4606859-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.10-latest swift build 2>&1
Fetching https://github.com/IBM-Swift/HeliumLogger.git
Fetching https://github.com/IBM-Swift/BlueSocket.git
[1/1267] Fetching heliumlogger
[1268/4209] Fetching heliumlogger, bluesocket
Fetched https://github.com/IBM-Swift/BlueSocket.git from cache (0.35s)
Fetched https://github.com/IBM-Swift/HeliumLogger.git from cache (0.35s)
Computing version for https://github.com/IBM-Swift/HeliumLogger.git
Computed https://github.com/IBM-Swift/HeliumLogger.git at 1.9.200 (1.07s)
Fetching https://github.com/Kitura/LoggerAPI.git
Fetching https://github.com/apple/swift-log.git
[1/771] Fetching loggerapi
[772/3941] Fetching loggerapi, swift-log
Fetched https://github.com/Kitura/LoggerAPI.git from cache (0.35s)
Fetched https://github.com/apple/swift-log.git from cache (0.35s)
Computing version for https://github.com/Kitura/LoggerAPI.git
Computed https://github.com/Kitura/LoggerAPI.git at 1.9.200 (0.39s)
Computing version for https://github.com/apple/swift-log.git
Computed https://github.com/apple/swift-log.git at 1.5.4 (0.39s)
Computing version for https://github.com/IBM-Swift/BlueSocket.git
error: the Swift tools version specification is missing a label; consider inserting 'swift-tools-version:' between the comment marker and the version specifier
Updating https://github.com/IBM-Swift/HeliumLogger.git
Updating https://github.com/IBM-Swift/BlueSocket.git
Updated https://github.com/IBM-Swift/BlueSocket.git (0.16s)
Updated https://github.com/IBM-Swift/HeliumLogger.git (0.16s)
Computing version for https://github.com/IBM-Swift/HeliumLogger.git
Computed https://github.com/IBM-Swift/HeliumLogger.git at 1.9.200 (1.07s)
Updating https://github.com/apple/swift-log.git
Updating https://github.com/Kitura/LoggerAPI.git
Updated https://github.com/Kitura/LoggerAPI.git (0.15s)
Updated https://github.com/apple/swift-log.git (0.15s)
Computing version for https://github.com/Kitura/LoggerAPI.git
Computed https://github.com/Kitura/LoggerAPI.git at 1.9.200 (0.41s)
Computing version for https://github.com/apple/swift-log.git
Computed https://github.com/apple/swift-log.git at 1.5.4 (0.41s)
Computing version for https://github.com/IBM-Swift/BlueSocket.git
error: the Swift tools version specification is missing a label; consider inserting 'swift-tools-version:' between the comment marker and the version specifier
BUILD FAILURE 5.10 linux

Build Machine: Linux 1