The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build MapboxMobileEvents with Swift 5.10 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.3.0-Beta.2.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.29.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/mapbox/mapbox-events-ios.git
Reference: v1.0.10
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/mapbox/mapbox-events-ios
 * tag               v1.0.10    -> FETCH_HEAD
HEAD is now at 91ae071 [build] Update Swift Package Manager checksum for Release v1.0.10. (#355)
Cloned https://github.com/mapbox/mapbox-events-ios.git
Revision (git rev-parse @):
91ae071c0232c144251dfe0d0724525deaf293d4
SUCCESS checkout https://github.com/mapbox/mapbox-events-ios.git at v1.0.10
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.10
Building package at path:  $workDir
https://github.com/mapbox/mapbox-events-ios.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.3.0-Beta.2.app xcrun swift build --arch arm64
warning: 'spi-builder-workspace': "Mapbox token wasn\'t founded in ~/.netrc. Fix this issue to integrate Mapbox SDK. Otherwise, you will see \'invalid status code 401\' or \'no XCFramework found. To clean issue in Xcode, remove ~/Library/Developer/Xcode/DerivedData folder"
Fetching binary artifact https://api.mapbox.com/downloads/v2/mapbox-events-ios/releases/ios/packages/1.0.10/MapboxMobileEvents.zip from cache
error: invalid archive returned from 'https://api.mapbox.com/downloads/v2/mapbox-events-ios/releases/ios/packages/1.0.10/MapboxMobileEvents.zip' which is required by binary target 'MapboxMobileEvents'
Fetching binary artifact https://api.mapbox.com/downloads/v2/mapbox-events-ios/releases/ios/packages/1.0.10/MapboxMobileEvents.zip from cache
error: invalid archive returned from 'https://api.mapbox.com/downloads/v2/mapbox-events-ios/releases/ios/packages/1.0.10/MapboxMobileEvents.zip' which is required by binary target 'MapboxMobileEvents'
BUILD FAILURE 5.10 macosSpm

Build Machine: Mac 7