The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build Axiomatic with Swift 5.10 for iOS using Xcode 15.4 at 1.1.1.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.29.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/jadengeller/axiomatic.git
Reference: 1.1.1
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/jadengeller/axiomatic
 * tag               1.1.1      -> FETCH_HEAD
HEAD is now at 772eec1 Update README.md
Cloned https://github.com/jadengeller/axiomatic.git
Revision (git rev-parse @):
772eec1c8ae0e3cc9a274870c90854b22b0d3b38
SUCCESS checkout https://github.com/jadengeller/axiomatic.git at 1.1.1
========================================
Build
========================================
Selected platform:         iOS
Swift version:             5.10
Building package at path:  $workDir
https://github.com/jadengeller/axiomatic.git
Command line invocation:
    /Applications/Xcode-15.3.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies
User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph
package 'package.swift' is using Swift tools version 3.1.0 which is no longer supported; consider using '// swift-tools-version: 5.10' to specify the current tools version
Resolved source packages:
  spi-builder-workspace: /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace
Resolve Package Graph
package 'package.swift' is using Swift tools version 3.1.0 which is no longer supported; consider using '// swift-tools-version: 5.10' to specify the current tools version
2024-02-14 04:45:16.716 xcodebuild[27748:73452] Requested but did not find extension point with identifier Xcode.DVTDeviceFoundation.Aspect for extension Xcode.IDEiOSSupportCore.Aspect.NBDD of plug-in com.apple.dt.IDE.IDEiOSSupportCore
2024-02-14 04:45:16.992 xcodebuild[27748:73452] Writing error result bundle to /var/folders/b3/8p5yvk0d16s637btgmtl295m0000gp/T/ResultBundle_2024-14-02_04-45-0016.xcresult
2024-02-14 04:45:17.089 xcodebuild[27748:73452] [MT] DVTPlugInQuery: Requested but did not find extension point with identifier 'Xcode.DVTDeviceFoundation.CompatibleDeviceFamilyPair'. This is programmer error; code should only request extension points that are defined by itself or its dependencies.
2024-02-14 04:45:17.975 xcodebuild[27748:73452] [MT] DVTAssertions: Warning in IDEFrameworks/IDEFoundation/Execution/RunContextManager/IDERunContextManager.m:857
Details:  Error deleting scheme: Cannot modify data because the process disallows saving.
Object:   <IDERunContextManager: 0x600001271540>
Method:   -deleteRunContexts:completionQueue:completionBlock:
Thread:   <_NSMainThread: 0x600003664180>{number = 1, name = main}
Please file a bug at https://feedbackassistant.apple.com with this warning message and any useful information you can provide.
2024-02-14 04:45:17.983 xcodebuild[27748:73452] could not delete old scheme: Error Domain=DVTCustomDataStoringErrors Code=0 "Cannot modify data because the process disallows saving." UserInfo={NSLocalizedDescription=Cannot modify data because the process disallows saving.}
xcodebuild: error: Could not resolve package dependencies:
  package 'package.swift' is using Swift tools version 3.1.0 which is no longer supported; consider using '// swift-tools-version: 5.10' to specify the current tools version
GENERIC FAILURE 5.10 iOS

Build Machine: Mac 7