The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build SofarKit with Swift 5.9 for visionOS using Xcode 15.2 at master.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.20.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/dreymonde/sofarkit.git
Reference: master
Initialized empty Git repository in /Users/builder/builds/TDmZkXJm/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/dreymonde/sofarkit
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at ff68082 Drop 'Sofar' from type names
Cloned https://github.com/dreymonde/sofarkit.git into spi-builder-workspace
ff6808234f96e4c29a1f586db16b759aff849180
SUCCESS checkout https://github.com/dreymonde/sofarkit.git at master
========================================
Build
========================================
Selected platform:         visionOS
Swift version:             5.9
Building package at path:  spi-builder-workspace
Command line invocation:
/Applications/Xcode-15.0.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/TDmZkXJm/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/TDmZkXJm/2/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph

Fetching from https://github.com/dreymonde/Light (cached)

Fetching from https://github.com/scinfu/SwiftSoup (cached)

Fetching from https://github.com/onevcat/Rainbow (cached)

Fetching from https://github.com/scottrhoyt/SwiftyTextTable (cached)

Fetching from https://github.com/dreymonde/Shallows.git (cached)

package 'package.swift' is using Swift tools version 3.1.0 which is no longer supported; consider using '// swift-tools-version: 5.9' to specify the current tools version
Resolve Package Graph

Updating from https://github.com/dreymonde/Shallows.git

Updating from https://github.com/scottrhoyt/SwiftyTextTable

Updating from https://github.com/onevcat/Rainbow

Updating from https://github.com/scinfu/SwiftSoup

Updating from https://github.com/dreymonde/Light
package 'package.swift' is using Swift tools version 3.1.0 which is no longer supported; consider using '// swift-tools-version: 5.9' to specify the current tools version
Resolve Package Graph

Updating from https://github.com/dreymonde/Light

Updating from https://github.com/onevcat/Rainbow

Updating from https://github.com/scinfu/SwiftSoup

Updating from https://github.com/scottrhoyt/SwiftyTextTable

Updating from https://github.com/dreymonde/Shallows.git

package 'package.swift' is using Swift tools version 3.1.0 which is no longer supported; consider using '// swift-tools-version: 5.9' to specify the current tools version

Resolved source packages:
  SofarKit: /Users/builder/builds/TDmZkXJm/2/finestructure/swiftpackageindex-builder/spi-builder-workspace
2023-06-29 00:11:52.193 xcodebuild[44547:158792] Writing error result bundle to /var/folders/4f/vmvvw7xn07sg3fzsc7v7mmx40000gp/T/ResultBundle_2023-29-06_00-11-0052.xcresult
xcodebuild: error: Could not resolve package dependencies:
  package 'package.swift' is using Swift tools version 3.1.0 which is no longer supported; consider using '// swift-tools-version: 5.9' to specify the current tools version
GENERIC FAILURE 5.9 visionOS