The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Successful build of DGFrameworkTemplate with Swift 5.9 for Linux.

Build Command

docker run --rm -v "checkouts-4609320-0":/host -w "/host/spi-builder-workspace" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.19.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/Digipolitan/framework-swift-template.git
Reference: master
Cloned https://github.com/Digipolitan/framework-swift-template.git into spi-builder-workspace
SUCCESS checkout https://github.com/Digipolitan/framework-swift-template.git at master
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.9
Building package at path:  spi-builder-workspace
Running build ...
docker run --rm -v "checkouts-4609320-0":/host -w "/host/spi-builder-workspace" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build 2>&1
Building for debugging...
[1/2] Compiling DGFrameworkTemplate TemplateClass.swift
/host/spi-builder-workspace/Sources/DGFrameworkTemplate/TemplateClass.swift:13:5: warning: non-'@objc' property in extensions cannot be overridden; use 'public' instead
    open var description: String {
    ^~~~
    public
[2/2] Emitting module DGFrameworkTemplate
/host/spi-builder-workspace/Sources/DGFrameworkTemplate/TemplateClass.swift:13:5: warning: non-'@objc' property in extensions cannot be overridden; use 'public' instead
    open var description: String {
    ^~~~
    public
Build complete! (4.60s)
Build complete.
Done.

Build Machine: Linux 2