The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build swift-biome with Swift 5.8 for macOS (SPM).

Build Command

env DEVELOPER_DIR="/Applications/Xcode-14.3.0.app" xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.22.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/tayloraswift/swift-biome.git
Reference: master
Initialized empty Git repository in /Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/tayloraswift/swift-biome
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at 06e06e3 point visitors to Swift Unidoc
Submodule 'resources' (https://github.com/swift-biome/swift-biome-resources.git) registered for path 'resources'
Cloning into '/Users/builder/builds/o86TiJKT/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/resources'...
Submodule path 'resources': checked out '050534312f30370f9ad4728def705fe024b0387e'
Cloned https://github.com/tayloraswift/swift-biome.git into spi-builder-workspace
06e06e3b0e93749db07ee45fb5b0848a29cb42b5
SUCCESS checkout https://github.com/tayloraswift/swift-biome.git at master
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.8
Building package at path:  spi-builder-workspace
Running build ...
env DEVELOPER_DIR="/Applications/Xcode-14.3.0.app" xcrun swift build --arch arm64
Fetching https://github.com/kelvin13/swift-json from cache
Fetched https://github.com/kelvin13/swift-json (0.20s)
Fetching https://github.com/apple/swift-markdown.git from cache
Fetched https://github.com/apple/swift-markdown.git (0.67s)
Fetching https://github.com/apple/swift-syntax.git from cache
Fetched https://github.com/apple/swift-syntax.git (0.76s)
Fetching https://github.com/apple/swift-cmark.git from cache
Fetched https://github.com/apple/swift-cmark.git (0.51s)
Fetching https://github.com/swift-server/swift-backtrace.git from cache
Fetching https://github.com/apple/swift-argument-parser.git from cache
Fetching https://github.com/kelvin13/swift-highlight from cache
Fetched https://github.com/kelvin13/swift-highlight (0.24s)
Fetching https://github.com/apple/swift-system.git from cache
Fetched https://github.com/swift-server/swift-backtrace.git (0.29s)
Fetching https://github.com/kelvin13/swift-grammar from cache
Fetched https://github.com/apple/swift-argument-parser.git (0.48s)
Fetching https://github.com/apple/swift-nio.git from cache
Fetched https://github.com/kelvin13/swift-grammar (0.29s)
Fetching https://github.com/kelvin13/swift-system-extras.git from cache
Fetched https://github.com/kelvin13/swift-system-extras.git (0.17s)
Fetching https://github.com/apple/swift-atomics.git from cache
Fetched https://github.com/apple/swift-system.git (0.65s)
Fetching https://github.com/kelvin13/swift-resource from cache
Fetched https://github.com/apple/swift-nio.git (0.58s)
Fetching https://github.com/kelvin13/swift-hash.git from cache
Fetched https://github.com/kelvin13/swift-resource (0.19s)
Fetching https://github.com/kelvin13/swift-dom from cache
Fetched https://github.com/kelvin13/swift-dom (0.19s)
Computing version for https://github.com/kelvin13/swift-grammar
Fetched https://github.com/apple/swift-atomics.git (0.53s)
Fetched https://github.com/kelvin13/swift-hash.git (0.23s)
Computed https://github.com/kelvin13/swift-grammar at 0.2.0 (0.67s)
Computing version for https://github.com/swift-server/swift-backtrace.git
Computed https://github.com/swift-server/swift-backtrace.git at 1.3.2 (0.03s)
Computing version for https://github.com/apple/swift-argument-parser.git
Computed https://github.com/apple/swift-argument-parser.git at 1.1.3 (0.03s)
Computing version for https://github.com/apple/swift-nio.git
Computed https://github.com/apple/swift-nio.git at 2.41.1 (0.51s)
Computing version for https://github.com/kelvin13/swift-system-extras.git
Computed https://github.com/kelvin13/swift-system-extras.git at 0.2.0 (0.46s)
Computing version for https://github.com/kelvin13/swift-dom
Computed https://github.com/kelvin13/swift-dom at 0.5.2 (0.50s)
Computing version for https://github.com/kelvin13/swift-resource
Computed https://github.com/kelvin13/swift-resource at 0.3.2 (0.48s)
Computing version for https://github.com/kelvin13/swift-highlight
Computed https://github.com/kelvin13/swift-highlight at 0.1.4 (0.48s)
Computing version for https://github.com/apple/swift-atomics.git
Computed https://github.com/apple/swift-atomics.git at 1.0.2 (0.02s)
Computing version for https://github.com/apple/swift-system.git
Computed https://github.com/apple/swift-system.git at 1.2.1 (0.02s)
Computing version for https://github.com/kelvin13/swift-hash.git
Computed https://github.com/kelvin13/swift-hash.git at 0.2.3 (0.49s)
Creating working copy for https://github.com/apple/swift-markdown.git
Working copy of https://github.com/apple/swift-markdown.git resolved at swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
Creating working copy for https://github.com/apple/swift-atomics.git
Working copy of https://github.com/apple/swift-atomics.git resolved at 1.0.2
Creating working copy for https://github.com/kelvin13/swift-grammar
Working copy of https://github.com/kelvin13/swift-grammar resolved at 0.2.0
Creating working copy for https://github.com/apple/swift-nio.git
Working copy of https://github.com/apple/swift-nio.git resolved at 2.41.1
Creating working copy for https://github.com/kelvin13/swift-resource
Working copy of https://github.com/kelvin13/swift-resource resolved at 0.3.2
Creating working copy for https://github.com/kelvin13/swift-hash.git
Working copy of https://github.com/kelvin13/swift-hash.git resolved at 0.2.3
Creating working copy for https://github.com/kelvin13/swift-highlight
Working copy of https://github.com/kelvin13/swift-highlight resolved at 0.1.4
Creating working copy for https://github.com/kelvin13/swift-system-extras.git
Working copy of https://github.com/kelvin13/swift-system-extras.git resolved at 0.2.0
Creating working copy for https://github.com/apple/swift-cmark.git
Working copy of https://github.com/apple/swift-cmark.git resolved at gfm
Creating working copy for https://github.com/apple/swift-argument-parser.git
Working copy of https://github.com/apple/swift-argument-parser.git resolved at 1.1.3
Creating working copy for https://github.com/kelvin13/swift-dom
Working copy of https://github.com/kelvin13/swift-dom resolved at 0.5.2
Creating working copy for https://github.com/apple/swift-syntax.git
Working copy of https://github.com/apple/swift-syntax.git resolved at swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
Creating working copy for https://github.com/apple/swift-system.git
Working copy of https://github.com/apple/swift-system.git resolved at 1.2.1
Creating working copy for https://github.com/kelvin13/swift-json
Working copy of https://github.com/kelvin13/swift-json resolved at master
Creating working copy for https://github.com/swift-server/swift-backtrace.git
Working copy of https://github.com/swift-server/swift-backtrace.git resolved at 1.3.2
error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntaxParser' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntaxParser' to require macos 10.13 or earlier.
error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntax' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntax' to require macos 10.13 or earlier.
error: the library 'PackageCatalogs' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the library 'PackageCatalogs' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier.
error: the executable 'Preview' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the executable 'Preview' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier.
ShellOut encountered an error
Status code: 1
Message: "Fetching https://github.com/kelvin13/swift-json from cache
Fetched https://github.com/kelvin13/swift-json (0.20s)
Fetching https://github.com/apple/swift-markdown.git from cache
Fetched https://github.com/apple/swift-markdown.git (0.67s)
Fetching https://github.com/apple/swift-syntax.git from cache
Fetched https://github.com/apple/swift-syntax.git (0.76s)
Fetching https://github.com/apple/swift-cmark.git from cache
Fetched https://github.com/apple/swift-cmark.git (0.51s)
Fetching https://github.com/swift-server/swift-backtrace.git from cache
Fetching https://github.com/apple/swift-argument-parser.git from cache
Fetching https://github.com/kelvin13/swift-highlight from cache
Fetched https://github.com/kelvin13/swift-highlight (0.24s)
Fetching https://github.com/apple/swift-system.git from cache
Fetched https://github.com/swift-server/swift-backtrace.git (0.29s)
Fetching https://github.com/kelvin13/swift-grammar from cache
Fetched https://github.com/apple/swift-argument-parser.git (0.48s)
Fetching https://github.com/apple/swift-nio.git from cache
Fetched https://github.com/kelvin13/swift-grammar (0.29s)
Fetching https://github.com/kelvin13/swift-system-extras.git from cache
Fetched https://github.com/kelvin13/swift-system-extras.git (0.17s)
Fetching https://github.com/apple/swift-atomics.git from cache
Fetched https://github.com/apple/swift-system.git (0.65s)
Fetching https://github.com/kelvin13/swift-resource from cache
Fetched https://github.com/apple/swift-nio.git (0.58s)
Fetching https://github.com/kelvin13/swift-hash.git from cache
Fetched https://github.com/kelvin13/swift-resource (0.19s)
Fetching https://github.com/kelvin13/swift-dom from cache
Fetched https://github.com/kelvin13/swift-dom (0.19s)
Computing version for https://github.com/kelvin13/swift-grammar
Fetched https://github.com/apple/swift-atomics.git (0.53s)
Fetched https://github.com/kelvin13/swift-hash.git (0.23s)
Computed https://github.com/kelvin13/swift-grammar at 0.2.0 (0.67s)
Computing version for https://github.com/swift-server/swift-backtrace.git
Computed https://github.com/swift-server/swift-backtrace.git at 1.3.2 (0.03s)
Computing version for https://github.com/apple/swift-argument-parser.git
Computed https://github.com/apple/swift-argument-parser.git at 1.1.3 (0.03s)
Computing version for https://github.com/apple/swift-nio.git
Computed https://github.com/apple/swift-nio.git at 2.41.1 (0.51s)
Computing version for https://github.com/kelvin13/swift-system-extras.git
Computed https://github.com/kelvin13/swift-system-extras.git at 0.2.0 (0.46s)
Computing version for https://github.com/kelvin13/swift-dom
Computed https://github.com/kelvin13/swift-dom at 0.5.2 (0.50s)
Computing version for https://github.com/kelvin13/swift-resource
Computed https://github.com/kelvin13/swift-resource at 0.3.2 (0.48s)
Computing version for https://github.com/kelvin13/swift-highlight
Computed https://github.com/kelvin13/swift-highlight at 0.1.4 (0.48s)
Computing version for https://github.com/apple/swift-atomics.git
Computed https://github.com/apple/swift-atomics.git at 1.0.2 (0.02s)
Computing version for https://github.com/apple/swift-system.git
Computed https://github.com/apple/swift-system.git at 1.2.1 (0.02s)
Computing version for https://github.com/kelvin13/swift-hash.git
Computed https://github.com/kelvin13/swift-hash.git at 0.2.3 (0.49s)
Creating working copy for https://github.com/apple/swift-markdown.git
Working copy of https://github.com/apple/swift-markdown.git resolved at swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
Creating working copy for https://github.com/apple/swift-atomics.git
Working copy of https://github.com/apple/swift-atomics.git resolved at 1.0.2
Creating working copy for https://github.com/kelvin13/swift-grammar
Working copy of https://github.com/kelvin13/swift-grammar resolved at 0.2.0
Creating working copy for https://github.com/apple/swift-nio.git
Working copy of https://github.com/apple/swift-nio.git resolved at 2.41.1
Creating working copy for https://github.com/kelvin13/swift-resource
Working copy of https://github.com/kelvin13/swift-resource resolved at 0.3.2
Creating working copy for https://github.com/kelvin13/swift-hash.git
Working copy of https://github.com/kelvin13/swift-hash.git resolved at 0.2.3
Creating working copy for https://github.com/kelvin13/swift-highlight
Working copy of https://github.com/kelvin13/swift-highlight resolved at 0.1.4
Creating working copy for https://github.com/kelvin13/swift-system-extras.git
Working copy of https://github.com/kelvin13/swift-system-extras.git resolved at 0.2.0
Creating working copy for https://github.com/apple/swift-cmark.git
Working copy of https://github.com/apple/swift-cmark.git resolved at gfm
Creating working copy for https://github.com/apple/swift-argument-parser.git
Working copy of https://github.com/apple/swift-argument-parser.git resolved at 1.1.3
Creating working copy for https://github.com/kelvin13/swift-dom
Working copy of https://github.com/kelvin13/swift-dom resolved at 0.5.2
Creating working copy for https://github.com/apple/swift-syntax.git
Working copy of https://github.com/apple/swift-syntax.git resolved at swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
Creating working copy for https://github.com/apple/swift-system.git
Working copy of https://github.com/apple/swift-system.git resolved at 1.2.1
Creating working copy for https://github.com/kelvin13/swift-json
Working copy of https://github.com/kelvin13/swift-json resolved at master
Creating working copy for https://github.com/swift-server/swift-backtrace.git
Working copy of https://github.com/swift-server/swift-backtrace.git resolved at 1.3.2
error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntaxParser' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntaxParser' to require macos 10.13 or earlier.
error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntax' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntax' to require macos 10.13 or earlier.
error: the library 'PackageCatalogs' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the library 'PackageCatalogs' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier.
error: the executable 'Preview' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the executable 'Preview' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier."
Output: ""
Retrying in 0.0 seconds ...
Building ... (attempt 2)
error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntaxParser' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntaxParser' to require macos 10.13 or earlier.
error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntax' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntax' to require macos 10.13 or earlier.
error: the library 'PackageCatalogs' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the library 'PackageCatalogs' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier.
error: the executable 'Preview' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the executable 'Preview' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier.
ShellOut encountered an error
Status code: 1
Message: "error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntaxParser' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntaxParser' to require macos 10.13 or earlier.
error: the library 'Biome' requires macos 10.13, but depends on the product 'SwiftSyntax' which requires macos 10.15; consider changing the library 'Biome' to require macos 10.15 or later, or the product 'SwiftSyntax' to require macos 10.13 or earlier.
error: the library 'PackageCatalogs' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the library 'PackageCatalogs' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier.
error: the executable 'Preview' requires macos 10.13, but depends on the product 'SystemExtras' which requires macos 11.0; consider changing the executable 'Preview' to require macos 11.0 or later, or the product 'SystemExtras' to require macos 10.13 or earlier."
Output: ""
BUILD FAILURE 5.8 macosSpm