The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build TabStriper with Swift 5.10 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.10-latest swift build 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.29.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/giiiita/TabStriper.git
Reference: master
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/giiiita/TabStriper
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at 8b06344 Merge pull request #4 from giiiita/fix/delete_spacer
Cloned https://github.com/giiiita/TabStriper.git
Revision (git rev-parse @):
8b0634476fa79822a2d2261fe7c6e9969d6403ee
SUCCESS checkout https://github.com/giiiita/TabStriper.git at master
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.10
Building package at path:  $workDir
https://github.com/giiiita/TabStriper.git
Running build ...
bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.10-latest swift build 2>&1
Building for debugging...
[0/2] Write sources
[1/2] Write swift-version-24593BA9C3E375BF.txt
[3/7] Compiling TabStriper TabStriper.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
error: emit-module command failed with exit code 1 (use -v to see invocation)
[4/7] Emitting module TabStriper
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[5/7] Compiling TabStriper StripBar.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[6/7] Compiling TabStriper StripView.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[7/7] Compiling TabStriper Buildable.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
error: fatalError
[0/1] Planning build
Building for debugging...
[0/1] Write swift-version-24593BA9C3E375BF.txt
error: emit-module command failed with exit code 1 (use -v to see invocation)
[2/6] Emitting module TabStriper
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[3/6] Compiling TabStriper Buildable.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[4/6] Compiling TabStriper StripBar.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[5/6] Compiling TabStriper StripView.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
[6/6] Compiling TabStriper TabStriper.swift
/host/spi-builder-workspace/Sources/TabStriper/StripBar.swift:8:8: error: no such module 'SwiftUI'
import SwiftUI
       ^
error: fatalError
BUILD FAILURE 5.10 linux

Build Machine: Linux 2