The Swift Package Index logo.Swift Package Index

Build Information

Failed to build SegmentAppsFlyer, reference 1.3.3 (91e844), with Swift 6.2 for macOS (SPM) on 12 Aug 2026 01:45:15 UTC.

Build Command

env DEVELOPER_DIR=/Applications/Xcode-26.3.0.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: undefined version: run 'make version' to update
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/segment-integrations/analytics-swift-appsflyer.git
Reference: 1.3.3
Initialized empty Git repository in /Users/admin/builder/spi-builder-workspace/.git/
From https://github.com/segment-integrations/analytics-swift-appsflyer
 * tag               1.3.3      -> FETCH_HEAD
HEAD is now at 91e844f Version 1.3.3
Cloned https://github.com/segment-integrations/analytics-swift-appsflyer.git
Revision (git rev-parse @):
91e844f65ec45f1675c4d672050521d3714d5c22
SUCCESS checkout https://github.com/segment-integrations/analytics-swift-appsflyer.git at 1.3.3
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             6.2
Building package at path:  $PWD
https://github.com/segment-integrations/analytics-swift-appsflyer.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-26.3.0.app xcrun swift build --arch arm64
Fetching https://github.com/AppsFlyerSDK/AppsFlyerFramework-Dynamic
Fetching https://github.com/segmentio/analytics-swift.git
[1/9860] Fetching analytics-swift
[2/9987] Fetching analytics-swift, appsflyerframework-dynamic
Fetched https://github.com/AppsFlyerSDK/AppsFlyerFramework-Dynamic from cache (1.58s)
Fetched https://github.com/segmentio/analytics-swift.git from cache (1.58s)
Computing version for https://github.com/AppsFlyerSDK/AppsFlyerFramework-Dynamic
Computed https://github.com/AppsFlyerSDK/AppsFlyerFramework-Dynamic at 6.17.9 (2.25s)
Computing version for https://github.com/segmentio/analytics-swift.git
Computed https://github.com/segmentio/analytics-swift.git at 1.10.0 (0.55s)
Fetching https://github.com/segmentio/sovran-swift.git
Fetching https://github.com/segmentio/jsonsafeencoding-swift.git
[1/94] Fetching jsonsafeencoding-swift
[36/483] Fetching jsonsafeencoding-swift, sovran-swift
Fetched https://github.com/segmentio/jsonsafeencoding-swift.git from cache (0.87s)
Fetched https://github.com/segmentio/sovran-swift.git from cache (0.87s)
Computing version for https://github.com/segmentio/jsonsafeencoding-swift.git
Computed https://github.com/segmentio/jsonsafeencoding-swift.git at 2.0.0 (1.54s)
Computing version for https://github.com/segmentio/sovran-swift.git
Computed https://github.com/segmentio/sovran-swift.git at 1.1.2 (0.65s)
Creating working copy for https://github.com/segmentio/jsonsafeencoding-swift.git
Working copy of https://github.com/segmentio/jsonsafeencoding-swift.git resolved at 2.0.0
Creating working copy for https://github.com/segmentio/analytics-swift.git
Working copy of https://github.com/segmentio/analytics-swift.git resolved at 1.10.0
Creating working copy for https://github.com/segmentio/sovran-swift.git
Working copy of https://github.com/segmentio/sovran-swift.git resolved at 1.1.2
Creating working copy for https://github.com/AppsFlyerSDK/AppsFlyerFramework-Dynamic
Working copy of https://github.com/AppsFlyerSDK/AppsFlyerFramework-Dynamic resolved at 6.17.9
Downloading binary artifact https://github.com/AppsFlyerSDK/AppsFlyerFramework/releases/download/6.17.9/AppsFlyerLib-Dynamic-SPM.xcframework.zip
[16375/8341930] Downloading https://github.com/AppsFlyerSDK/AppsFlyerFramework/releases/download/6.17.9/AppsFlyerLib-Dynamic-SPM.xcframework.zip
Downloaded https://github.com/AppsFlyerSDK/AppsFlyerFramework/releases/download/6.17.9/AppsFlyerLib-Dynamic-SPM.xcframework.zip (0.93s)
error: the library 'SegmentAppsFlyer' requires macos 10.13, but depends on the product 'Segment' which requires macos 10.15; consider changing the library 'SegmentAppsFlyer' to require macos 10.15 or later, or the product 'Segment' to require macos 10.13 or earlier.
BUILD FAILURE 6.2 macosSpm