The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build AEXML with Swift 5.8 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$PWD/checkout" registry.gitlab.com/finestructure/spi-images:basic-5.8-latest swift build 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.28.7
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/tadija/AEXML.git
Reference: master
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/tadija/AEXML
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at bcdfd48 Update README.md
Cloned https://github.com/tadija/AEXML.git
Revision (git rev-parse @):
bcdfd485a41a0bba5cfc61e3dc5204308728b7d0
SUCCESS checkout https://github.com/tadija/AEXML.git at master
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.8
Building package at path:  $PWD/checkout
https://github.com/tadija/AEXML.git
Running build ...
bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$PWD/checkout" registry.gitlab.com/finestructure/spi-images:basic-5.8-latest swift build 2>&1
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.1
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.1
BUILD FAILURE 5.8 linux

Build Machine: Linux 2