The Swift Package Index logo.Swift Package Index

Build Information

Failed to build Gtk with Swift 5.9 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.2.0.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.35.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/rhx/swiftgtk.git
Reference: main
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/rhx/swiftgtk
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at feed1e2 Update for gtk-4.14
Cloned https://github.com/rhx/swiftgtk.git
Revision (git rev-parse @):
feed1e245f181fc377a7095f1978a7db51b1ef31
SUCCESS checkout https://github.com/rhx/swiftgtk.git at main
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.9
Building package at path:  $workDir
https://github.com/rhx/swiftgtk.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.2.0.app xcrun swift build --arch arm64
Building for debugging...
[0/16] Compiling api.c
[1/16] Compiling scanner.c
[2/16] Compiling writer.c
[4/16] Compiling ArgumentParserToolInfo ToolInfo.swift
[5/16] Emitting module ArgumentParserToolInfo
[5/16] Compiling parser.c
[6/53] Compiling emitter.c
[7/53] Compiling reader.c
[9/68] Compiling SwiftLibXML XMLElement.swift
[10/68] Compiling SwiftLibXML XMLNameSpace.swift
[11/68] Compiling SwiftLibXML XMLPath.swift
[12/68] Compiling SwiftLibXML XMLAttribute.swift
[13/68] Compiling SwiftLibXML EmptySequence.swift
[14/68] Emitting module SwiftLibXML
[15/68] Compiling SwiftLibXML XMLDocument.swift
[16/68] Emitting module ArgumentParser
[17/73] Compiling Yams Node.Scalar.swift
[18/73] Compiling Yams Node.Sequence.swift
[19/74] Compiling Yams Node.swift
[20/74] Compiling Yams Parser.swift
[21/74] Compiling Yams Emitter.swift
[22/74] Compiling Yams Encoder.swift
[23/74] Compiling Yams Mark.swift
[24/74] Compiling ArgumentParser ArgumentVisibility.swift
[25/74] Compiling ArgumentParser CompletionKind.swift
[26/74] Compiling ArgumentParser Errors.swift
[27/74] Compiling ArgumentParser Flag.swift
[28/74] Compiling ArgumentParser NameSpecification.swift
[29/74] Compiling Yams YamlError.swift
[30/74] Compiling ArgumentParser CollectionExtensions.swift
[31/74] Compiling ArgumentParser Platform.swift
[32/74] Compiling ArgumentParser SequenceExtensions.swift
[33/74] Compiling ArgumentParser StringExtensions.swift
[34/74] Compiling ArgumentParser Tree.swift
[35/74] Compiling ArgumentParser Name.swift
[36/74] Compiling ArgumentParser Parsed.swift
[37/74] Compiling ArgumentParser ParsedValues.swift
[38/74] Compiling ArgumentParser ParserError.swift
[39/74] Compiling ArgumentParser SplitArguments.swift
[40/74] Compiling Yams Constructor.swift
[41/74] Compiling Yams Decoder.swift
[42/74] Compiling Yams Representer.swift
[43/74] Compiling Yams Resolver.swift
[44/74] Compiling Yams String+Yams.swift
[45/74] Compiling Yams Tag.swift
[54/74] Emitting module Yams
[58/74] Compiling Yams Node.Mapping.swift
[59/74] Compiling ArgumentParser ExpressibleByArgument.swift
[60/74] Compiling ArgumentParser ParsableArguments.swift
[61/74] Compiling ArgumentParser ParsableArgumentsValidation.swift
[62/74] Compiling ArgumentParser ParsableCommand.swift
[63/74] Compiling ArgumentParser ArgumentDecoder.swift
[64/74] Compiling ArgumentParser ArgumentDefinition.swift
[65/74] Compiling ArgumentParser ArgumentSet.swift
[66/74] Compiling ArgumentParser CommandParser.swift
[67/74] Compiling ArgumentParser InputKey.swift
[68/74] Compiling ArgumentParser InputOrigin.swift
[72/74] Compiling ArgumentParser MessageInfo.swift
[73/74] Compiling ArgumentParser UsageGenerator.swift
[74/115] Compiling libgir2swift GirEnumeration.swift
[75/115] Compiling libgir2swift GirField.swift
[76/115] Compiling libgir2swift GirFunction.swift
[77/115] Compiling libgir2swift GirInterface.swift
[78/115] Compiling libgir2swift GirMethod.swift
[79/115] Compiling libgir2swift GirProperty.swift
[80/120] Compiling libgir2swift Character+Utilities.swift
[81/120] Compiling libgir2swift Collection+Utilities.swift
[82/120] Compiling libgir2swift Streams.swift
[83/120] Compiling libgir2swift String+Substring.swift
[84/120] Compiling libgir2swift String+Utilities.swift
[85/120] Compiling libgir2swift GirBitfield.swift
[86/120] Compiling libgir2swift GirCType.swift
[87/120] Compiling libgir2swift GirCallback.swift
[88/120] Compiling libgir2swift GirClass.swift
[89/120] Compiling libgir2swift GirConstant.swift
[90/120] Compiling libgir2swift GirDatatype.swift
[91/120] Compiling libgir2swift GirRecord.swift
[92/120] Compiling libgir2swift GirSignal.swift
[93/120] Compiling libgir2swift GirThing.swift
[94/120] Compiling libgir2swift GirUnion.swift
[95/120] Compiling libgir2swift girtype+xml.swift
[96/120] Compiling libgir2swift gtk2swiftdoc.swift
[97/120] Compiling libgir2swift ConversionContext.swift
[98/120] Compiling libgir2swift Gir+Enums.swift
[99/120] Compiling libgir2swift Gir+KnowTypeSets.swift
[100/120] Compiling libgir2swift Gir+KnownTypes.swift
[101/120] Compiling libgir2swift Gir.swift
[102/120] Compiling libgir2swift Gir2Swift.swift
[103/120] Compiling libgir2swift GirType.swift
[104/120] Compiling libgir2swift TypeConversion.swift
[105/120] Compiling libgir2swift TypeReference.swift
[106/120] Compiling libgir2swift GirAlias.swift
[107/120] Compiling libgir2swift GirArgument.swift
[108/120] Emitting module libgir2swift
[109/120] Compiling libgir2swift System.swift
[110/120] Compiling libgir2swift XML+Utilities.swift
[111/120] Compiling libgir2swift generation.swift
[112/120] Compiling libgir2swift planning.swift
[113/120] Compiling libgir2swift postprocessing.swift
[114/120] Compiling libgir2swift CodeBuilder.swift
[115/120] Compiling libgir2swift c2swift.swift
[116/120] Compiling libgir2swift emit-class.swift
[117/120] Compiling libgir2swift emit-signals.swift
[118/120] Compiling libgir2swift gir+swift.swift
[119/120] Compiling libgir2swift girtypes+swift.swift
[120/122] Emitting module gir2swift
[121/122] Compiling gir2swift main.swift
[121/122] Linking gir2swift
Build complete! (10.87s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.10s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
[1/1] Compiling plugin GenerateManual
[2/2] Compiling plugin Swift-DocC
[3/3] Compiling plugin Swift-DocC Preview
[4/4] Compiling plugin gir2swift-plugin
Building for debugging...
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftHarfBuzz/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "HarfBuzz-0.0.gir")
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "Gtk-3.0.gir")
[4/26] Converting Gtk Gtk-3.0.gir
[4/26] Converting HarfBuzz HarfBuzz-0.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftPango/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "Pango-1.0.gir")
[4/26] Converting Pango Pango-1.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftGModule/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "GModule-2.0.gir")
[7/26] Converting GModule GModule-2.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftGdk/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "Gdk-3.0.gir")
[7/26] Converting Gdk Gdk-3.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftPangoCairo/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "PangoCairo-1.0.gir")
[8/26] Converting PangoCairo PangoCairo-1.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftGObject/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "GObject-2.0.gir")
[8/26] Converting GLibObject GObject-2.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftGdkPixbuf/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "GdkPixbuf-2.0.gir")
[11/26] Converting GdkPixBuf GdkPixbuf-2.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftGLib/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "GLib-2.0.gir")
[12/35] Converting GLib GLib-2.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftGIO/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "Gio-2.0.gir")
[12/35] Converting GIO Gio-2.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftCairo/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "cairo-1.0.gir")
[12/35] Converting Cairo cairo-1.0.gir
env: pkg-config: No such file or directory
Failed to load /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.build/checkouts/SwiftAtk/gir2swift-manifest.yaml for  manifest:
    girNotFound(named: "Atk-1.0.gir")
[12/35] Converting Atk Atk-1.0.gir
In file included from /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/GtkCHelpers/gtk_dialog.c:1:
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/GtkCHelpers/include/gtk_dialog.h:2:10: fatal error: 'gtk/gtk.h' file not found
#include <gtk/gtk.h>
         ^~~~~~~~~~~
1 error generated.
[16/35] Compiling GtkCHelpers gtk_dialog.c
[16/35] Compiling reader.c
[16/35] Compiling emitter.c
[16/35] Compiling writer.c
[16/35] Compiling scanner.c
[16/35] Compiling parser.c
[17/35] Emitting module ArgumentParserToolInfo
Fetching https://github.com/rhx/gir2swift.git from cache
Fetched https://github.com/rhx/gir2swift.git (0.13s)
Fetching https://github.com/rhx/SwiftAtk.git from cache
Fetched https://github.com/rhx/SwiftAtk.git (0.14s)
Fetching https://github.com/rhx/SwiftGdk.git from cache
Fetched https://github.com/rhx/SwiftGdk.git (0.13s)
Fetching https://github.com/rhx/SwiftLibXML.git from cache
Fetched https://github.com/rhx/SwiftLibXML.git (0.17s)
Fetching https://github.com/rhx/SwiftGObject.git from cache
Fetched https://github.com/rhx/SwiftGObject.git (0.13s)
Fetching https://github.com/rhx/SwiftGdkPixbuf.git from cache
Fetched https://github.com/rhx/SwiftGdkPixbuf.git (0.14s)
Fetching https://github.com/rhx/SwiftPangoCairo.git from cache
Fetched https://github.com/rhx/SwiftPangoCairo.git (0.13s)
Fetching https://github.com/rhx/SwiftGLib.git from cache
Fetched https://github.com/rhx/SwiftGLib.git (0.14s)
Fetching https://github.com/rhx/SwiftGIO.git from cache
Fetched https://github.com/rhx/SwiftGIO.git (0.13s)
Fetching https://github.com/rhx/SwiftGModule.git from cache
Fetched https://github.com/rhx/SwiftGModule.git (0.14s)
Fetching https://github.com/rhx/SwiftCairo.git from cache
Fetched https://github.com/rhx/SwiftCairo.git (0.15s)
Fetching https://github.com/rhx/SwiftPango.git from cache
Fetched https://github.com/rhx/SwiftPango.git (0.15s)
Fetching https://github.com/rhx/SwiftHarfBuzz.git from cache
Fetched https://github.com/rhx/SwiftHarfBuzz.git (0.14s)
Fetching https://github.com/apple/swift-argument-parser from cache
Fetching https://github.com/apple/swift-docc-plugin from cache
Fetching https://github.com/jpsim/Yams.git from cache
Fetched https://github.com/apple/swift-docc-plugin (0.20s)
Fetched https://github.com/jpsim/Yams.git (0.28s)
Fetched https://github.com/apple/swift-argument-parser (0.28s)
Computing version for https://github.com/jpsim/Yams.git
Computed https://github.com/jpsim/Yams.git at 4.0.6 (0.35s)
Computing version for https://github.com/apple/swift-docc-plugin
Computed https://github.com/apple/swift-docc-plugin at 1.3.0 (0.02s)
Fetching https://github.com/apple/swift-docc-symbolkit from cache
Fetched https://github.com/apple/swift-docc-symbolkit (0.30s)
Computing version for https://github.com/apple/swift-docc-symbolkit
Computed https://github.com/apple/swift-docc-symbolkit at 1.0.0 (0.02s)
Computing version for https://github.com/apple/swift-argument-parser
Computed https://github.com/apple/swift-argument-parser at 1.3.1 (0.02s)
Creating working copy for https://github.com/rhx/SwiftCairo.git
Working copy of https://github.com/rhx/SwiftCairo.git resolved at main
Creating working copy for https://github.com/rhx/SwiftGObject.git
Working copy of https://github.com/rhx/SwiftGObject.git resolved at main
Creating working copy for https://github.com/apple/swift-argument-parser
Working copy of https://github.com/apple/swift-argument-parser resolved at 1.3.1
Creating working copy for https://github.com/rhx/SwiftLibXML.git
Working copy of https://github.com/rhx/SwiftLibXML.git resolved at main
Creating working copy for https://github.com/rhx/SwiftGdk.git
Working copy of https://github.com/rhx/SwiftGdk.git resolved at main
Creating working copy for https://github.com/apple/swift-docc-plugin
Working copy of https://github.com/apple/swift-docc-plugin resolved at 1.3.0
Creating working copy for https://github.com/rhx/SwiftHarfBuzz.git
Working copy of https://github.com/rhx/SwiftHarfBuzz.git resolved at main
Creating working copy for https://github.com/rhx/SwiftGLib.git
Working copy of https://github.com/rhx/SwiftGLib.git resolved at main
Creating working copy for https://github.com/rhx/SwiftAtk.git
Working copy of https://github.com/rhx/SwiftAtk.git resolved at main
Creating working copy for https://github.com/rhx/SwiftGdkPixbuf.git
Working copy of https://github.com/rhx/SwiftGdkPixbuf.git resolved at main
Creating working copy for https://github.com/rhx/SwiftGIO.git
Working copy of https://github.com/rhx/SwiftGIO.git resolved at main
Creating working copy for https://github.com/jpsim/Yams.git
Working copy of https://github.com/jpsim/Yams.git resolved at 4.0.6
Creating working copy for https://github.com/rhx/SwiftGModule.git
Working copy of https://github.com/rhx/SwiftGModule.git resolved at main
Creating working copy for https://github.com/rhx/SwiftPangoCairo.git
Working copy of https://github.com/rhx/SwiftPangoCairo.git resolved at main
Creating working copy for https://github.com/rhx/gir2swift.git
Working copy of https://github.com/rhx/gir2swift.git resolved at main
Creating working copy for https://github.com/apple/swift-docc-symbolkit
Working copy of https://github.com/apple/swift-docc-symbolkit resolved at 1.0.0
Creating working copy for https://github.com/rhx/SwiftPango.git
Working copy of https://github.com/rhx/SwiftPango.git resolved at main
warning: failed to retrieve search paths with pkg-config; maybe pkg-config is not installed
warning: you may be able to install atk using your system-packager:
    brew install atk glib glib-networking gobject-introspection
warning: you may be able to install harfbuzz-gobject using your system-packager:
    brew install harfbuzz glib glib-networking gobject-introspection
warning: you may be able to install pango using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install cairo using your system-packager:
    brew install cairo glib glib-networking gobject-introspection
warning: you may be able to install pangocairo using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install gio-unix-2.0 using your system-packager:
    brew install glib glib-networking gobject-introspection
warning: you may be able to install gdk-pixbuf-2.0 using your system-packager:
    brew install gdk-pixbuf glib glib-networking gobject-introspection
warning: you may be able to install gdk-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
warning: you may be able to install gtk+-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
warning: you may be able to install atk using your system-packager:
    brew install atk glib glib-networking gobject-introspection
warning: you may be able to install harfbuzz-gobject using your system-packager:
    brew install harfbuzz glib glib-networking gobject-introspection
warning: you may be able to install pango using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install cairo using your system-packager:
    brew install cairo glib glib-networking gobject-introspection
warning: you may be able to install pangocairo using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install gio-unix-2.0 using your system-packager:
    brew install glib glib-networking gobject-introspection
warning: you may be able to install gdk-pixbuf-2.0 using your system-packager:
    brew install gdk-pixbuf glib glib-networking gobject-introspection
warning: you may be able to install gdk-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
warning: you may be able to install gtk+-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
Building for debugging...
Build complete! (0.13s)
Building for debugging...
Build complete! (0.09s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.08s)
Building for debugging...
Build complete! (0.09s)
Building for debugging...
Build complete! (0.09s)
Building for debugging...
Build complete! (0.08s)
[0/1] Planning build
[1/1] Compiling plugin GenerateManual
[2/2] Compiling plugin Swift-DocC
[3/3] Compiling plugin Swift-DocC Preview
[4/4] Compiling plugin gir2swift-plugin
Building for debugging...
In file included from /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/GtkCHelpers/gtk_dialog.c:1:
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/GtkCHelpers/include/gtk_dialog.h:2:10: fatal error: 'gtk/gtk.h' file not found
#include <gtk/gtk.h>
         ^~~~~~~~~~~
1 error generated.
[4/26] Compiling GtkCHelpers gtk_dialog.c
[4/26] Compiling api.c
[4/26] Compiling writer.c
[4/26] Compiling reader.c
[4/26] Compiling parser.c
[4/26] Compiling emitter.c
[4/26] Compiling scanner.c
warning: failed to retrieve search paths with pkg-config; maybe pkg-config is not installed
warning: you may be able to install gio-unix-2.0 using your system-packager:
    brew install glib glib-networking gobject-introspection
warning: you may be able to install harfbuzz-gobject using your system-packager:
    brew install harfbuzz glib glib-networking gobject-introspection
warning: you may be able to install pango using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install cairo using your system-packager:
    brew install cairo glib glib-networking gobject-introspection
warning: you may be able to install pangocairo using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install gdk-pixbuf-2.0 using your system-packager:
    brew install gdk-pixbuf glib glib-networking gobject-introspection
warning: you may be able to install gdk-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
warning: you may be able to install atk using your system-packager:
    brew install atk glib glib-networking gobject-introspection
warning: you may be able to install gtk+-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
warning: you may be able to install harfbuzz-gobject using your system-packager:
    brew install harfbuzz glib glib-networking gobject-introspection
warning: you may be able to install pango using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install cairo using your system-packager:
    brew install cairo glib glib-networking gobject-introspection
warning: you may be able to install pangocairo using your system-packager:
    brew install pango glib glib-networking gobject-introspection
warning: you may be able to install gio-unix-2.0 using your system-packager:
    brew install glib glib-networking gobject-introspection
warning: you may be able to install gdk-pixbuf-2.0 using your system-packager:
    brew install gdk-pixbuf glib glib-networking gobject-introspection
warning: you may be able to install gdk-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
warning: you may be able to install gtk+-3.0 using your system-packager:
    brew install gtk+3 glib glib-networking gobject-introspection
warning: you may be able to install atk using your system-packager:
    brew install atk glib glib-networking gobject-introspection
BUILD FAILURE 5.9 macosSpm

Build Machine: Mac 7