The Swift Package Index logo.Swift Package Index

Build Information

Failed to build SwordRPC with Swift 5.10 for macOS (Xcode) using Xcode 15.3 at 0.2.2.

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.29.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/Azoy/SwordRPC.git
Reference: 0.2.2
Initialized empty Git repository in /Users/admin/builds/J1XnyXFH/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/Azoy/SwordRPC
 * tag               0.2.2      -> FETCH_HEAD
HEAD is now at 97535a2 TMPDIR Function bby
Cloned https://github.com/Azoy/SwordRPC.git
Revision (git rev-parse @):
97535a22bdca462f8b91e8a7349391fb2344d757
SUCCESS checkout https://github.com/Azoy/SwordRPC.git at 0.2.2
========================================
Build
========================================
Selected platform:         macosXcodebuild
Swift version:             5.10
Building package at path:  $workDir
https://github.com/Azoy/SwordRPC.git
Command line invocation:
    /Applications/Xcode-15.3.0-Beta.2.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/admin/builds/J1XnyXFH/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies
User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/admin/builds/J1XnyXFH/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph
Fetching from https://github.com/IBM-Swift/BlueSocket.git
the Swift tools version specification is missing a label; consider inserting 'swift-tools-version:' between the comment marker and the version specifier
Resolved source packages:
  SwordRPC: /Users/admin/builds/J1XnyXFH/0/finestructure/swiftpackageindex-builder/spi-builder-workspace
2024-02-13 22:19:21.371 xcodebuild[82208:2169830] Requested but did not find extension point with identifier Xcode.DVTDeviceFoundation.Aspect for extension Xcode.IDEiOSSupportCore.Aspect.NBDD of plug-in com.apple.dt.IDE.IDEiOSSupportCore
2024-02-13 22:19:24.004 xcodebuild[82208:2169830] Writing error result bundle to /var/folders/c2/b2kmn__12wq57m82ltz0hl1w0000gn/T/ResultBundle_2024-13-02_22-19-0024.xcresult
2024-02-13 22:19:24.098 xcodebuild[82208:2169830] [MT] DVTPlugInQuery: Requested but did not find extension point with identifier 'Xcode.DVTDeviceFoundation.CompatibleDeviceFamilyPair'. This is programmer error; code should only request extension points that are defined by itself or its dependencies.
xcodebuild: error: Could not resolve package dependencies:
  the Swift tools version specification is missing a label; consider inserting 'swift-tools-version:' between the comment marker and the version specifier
GENERIC FAILURE 5.10 macosXcodebuild