The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build swift-biome with Swift 5.8 for macOS (Xcode) using Xcode 14.3 at master.

Build Command

env DEVELOPER_DIR="/Applications/Xcode-14.3.0.app" xcrun xcodebuild -IDEClonedSourcePackagesDirPathOverride="$PWD/.dependencies" -derivedDataPath "$PWD/.derivedData" build -scheme swift-biome-Package -destination 'platform=macos,arch=arm64'

Build Log

========================================
RunAll
========================================
Builder version: 4.22.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/tayloraswift/swift-biome.git
Reference: master
Initialized empty Git repository in /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/tayloraswift/swift-biome
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at 06e06e3 point visitors to Swift Unidoc
Submodule 'resources' (https://github.com/swift-biome/swift-biome-resources.git) registered for path 'resources'
Cloning into '/Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/resources'...
Submodule path 'resources': checked out '050534312f30370f9ad4728def705fe024b0387e'
Cloned https://github.com/tayloraswift/swift-biome.git into spi-builder-workspace
06e06e3b0e93749db07ee45fb5b0848a29cb42b5
SUCCESS checkout https://github.com/tayloraswift/swift-biome.git at master
========================================
Build
========================================
Selected platform:         macosXcodebuild
Swift version:             5.8
Building package at path:  spi-builder-workspace
2023-09-15 01:14:05.807 xcodebuild[57542:819883] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
Command line invocation:
/Applications/Xcode-14.3.0.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -resolvePackageDependencies

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph

Fetching from https://github.com/kelvin13/swift-json (cached)

Fetching from https://github.com/apple/swift-markdown.git (cached)

Fetching from https://github.com/apple/swift-syntax.git (cached)

Fetching from https://github.com/apple/swift-cmark.git (cached)

Fetching from https://github.com/kelvin13/swift-grammar (cached)

Fetching from https://github.com/apple/swift-atomics.git (cached)

Fetching from https://github.com/kelvin13/swift-system-extras.git (cached)

Fetching from https://github.com/kelvin13/swift-hash.git (cached)

Fetching from https://github.com/apple/swift-argument-parser.git (cached)

Fetching from https://github.com/kelvin13/swift-highlight (cached)

Fetching from https://github.com/kelvin13/swift-dom (cached)

Fetching from https://github.com/kelvin13/swift-resource (cached)


Fetching from https://github.com/apple/swift-system.git (cached)

Fetching from https://github.com/apple/swift-nio.git (cached)

Fetching from https://github.com/swift-server/swift-backtrace.git (cached)
Creating working copy of package ‘swift-argument-parser’

Checking out 1.1.3 of package ‘swift-argument-parser’

Creating working copy of package ‘swift-backtrace’

Checking out 1.3.2 of package ‘swift-backtrace’

Creating working copy of package ‘swift-atomics’

Checking out 1.0.2 of package ‘swift-atomics’

Creating working copy of package ‘swift-json’

Checking out master of package ‘swift-json’

Creating working copy of package ‘swift-resource’

Checking out 0.3.2 of package ‘swift-resource’

Creating working copy of package ‘swift-grammar’

Checking out 0.2.0 of package ‘swift-grammar’

Creating working copy of package ‘swift-cmark’

Checking out gfm of package ‘swift-cmark’

Creating working copy of package ‘swift-highlight’


Checking out 0.1.4 of package ‘swift-highlight’

Creating working copy of package ‘swift-system-extras’

Checking out 0.2.0 of package ‘swift-system-extras’

Creating working copy of package ‘swift-hash’

Checking out 0.2.3 of package ‘swift-hash’

Creating working copy of package ‘swift-nio’

Checking out 2.41.1 of package ‘swift-nio’

Creating working copy of package ‘swift-syntax’

Checking out swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a of package ‘swift-syntax’

Creating working copy of package ‘swift-markdown’

Checking out swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a of package ‘swift-markdown’

Creating working copy of package ‘swift-system’

Checking out 1.2.1 of package ‘swift-system’


Creating working copy of package ‘swift-dom’

Checking out 0.5.2 of package ‘swift-dom’

Resolve Package Graph


Resolved source packages:
  swift-atomics: https://github.com/apple/swift-atomics.git @ 1.0.2
  swift-json: https://github.com/kelvin13/swift-json @ master
  swift-grammar: https://github.com/kelvin13/swift-grammar @ 0.2.0
  swift-system: https://github.com/apple/swift-system.git @ 1.2.1
  swift-hash: https://github.com/kelvin13/swift-hash.git @ 0.2.3
  swift-argument-parser: https://github.com/apple/swift-argument-parser.git @ 1.1.3
  swift-markdown: https://github.com/apple/swift-markdown.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-backtrace: https://github.com/swift-server/swift-backtrace.git @ 1.3.2
  swift-resource: https://github.com/kelvin13/swift-resource @ 0.3.2
  SwiftSyntax: https://github.com/apple/swift-syntax.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-nio: https://github.com/apple/swift-nio.git @ 2.41.1
  swift-system-extras: https://github.com/kelvin13/swift-system-extras.git @ 0.2.0
  swift-biome: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace
  swift-highlight: https://github.com/kelvin13/swift-highlight @ 0.1.4
  cmark-gfm: https://github.com/apple/swift-cmark.git @ gfm
  swift-dom: https://github.com/kelvin13/swift-dom @ 0.5.2
resolved source packages: swift-atomics, swift-json, swift-grammar, swift-system, swift-hash, swift-argument-parser, swift-markdown, swift-backtrace, swift-resource, SwiftSyntax, swift-nio, swift-system-extras, swift-biome, swift-highlight, cmark-gfm, swift-dom
2023-09-15 01:14:44.204 xcodebuild[58463:822532] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
{
  "workspace" : {
    "name" : "spi-builder-workspace",
    "schemes" : [
      "Biome",
      "PackageCatalogs",
      "PackageLoader",
      "PackageResolution",
      "preview",
      "swift-biome-Package",
      "swift-symbolgraphc",
      "SymbolGraphs",
      "Versions"
    ]
  }
}
Running build ...
env DEVELOPER_DIR="/Applications/Xcode-14.3.0.app" xcrun xcodebuild -IDEClonedSourcePackagesDirPathOverride="$PWD/.dependencies" -derivedDataPath "$PWD/.derivedData" build -scheme swift-biome-Package -destination 'platform=macos,arch=arm64'
2023-09-15 01:14:45.269 xcodebuild[58472:822590] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
Command line invocation:
/Applications/Xcode-14.3.0.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme swift-biome-Package -destination platform=macos,arch=arm64

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph

Resolve Package Graph


Resolved source packages:
  swift-argument-parser: https://github.com/apple/swift-argument-parser.git @ 1.1.3
  swift-nio: https://github.com/apple/swift-nio.git @ 2.41.1
  swift-markdown: https://github.com/apple/swift-markdown.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-dom: https://github.com/kelvin13/swift-dom @ 0.5.2
  swift-json: https://github.com/kelvin13/swift-json @ master
  cmark-gfm: https://github.com/apple/swift-cmark.git @ gfm
  swift-highlight: https://github.com/kelvin13/swift-highlight @ 0.1.4
  SwiftSyntax: https://github.com/apple/swift-syntax.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-system: https://github.com/apple/swift-system.git @ 1.2.1
  swift-biome: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace
  swift-system-extras: https://github.com/kelvin13/swift-system-extras.git @ 0.2.0
  swift-backtrace: https://github.com/swift-server/swift-backtrace.git @ 1.3.2
  swift-grammar: https://github.com/kelvin13/swift-grammar @ 0.2.0
  swift-hash: https://github.com/kelvin13/swift-hash.git @ 0.2.3
  swift-atomics: https://github.com/apple/swift-atomics.git @ 1.0.2
  swift-resource: https://github.com/kelvin13/swift-resource @ 0.3.2

--- xcodebuild: WARNING: Using the first of multiple matching destinations:
{ platform:macOS, arch:arm64, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Mac Catalyst, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:DriverKit, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Designed for [iPad,iPhone], id:00008103-000604DE26D2001E }
Prepare packages

2023-09-15 01:14:48.626 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003ac300: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntax/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.629 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003d1100: name:SwiftParser.docc path:group:SwiftParser.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftParser/SwiftParser.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.632 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003d2100: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.635 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003a9600: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxBuilder/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.655 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003aa200: name:Markdown.docc path:group:Markdown.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-markdown/Sources/Markdown/Markdown.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.667 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003be400: name:JSON.docc path:group:JSON.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-json/Sources/JSON/JSON.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.720 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600000399700: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-argument-parser/Sources/ArgumentParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
Computing target dependency graph and provisioning inputs

Create build description
Build description signature: 6e853eb092a14c87310cf678f5fa059f
Build description path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData/Build/Intermediates.noindex/XCBuildData/6e853eb092a14c87310cf678f5fa059f.xcbuilddata
note: Building targets in dependency order
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'swift-symbolgraphc' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageCatalogs' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'SymbolGraphConvert' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
Resolve Package Graph
** BUILD FAILED **
ShellOut encountered an error
Status code: 65
Message: "2023-09-15 01:14:45.269 xcodebuild[58472:822590] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
--- xcodebuild: WARNING: Using the first of multiple matching destinations:
{ platform:macOS, arch:arm64, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Mac Catalyst, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:DriverKit, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Designed for [iPad,iPhone], id:00008103-000604DE26D2001E }
2023-09-15 01:14:48.626 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003ac300: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntax/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.629 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003d1100: name:SwiftParser.docc path:group:SwiftParser.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftParser/SwiftParser.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.632 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003d2100: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.635 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003a9600: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxBuilder/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.655 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003aa200: name:Markdown.docc path:group:Markdown.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-markdown/Sources/Markdown/Markdown.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.667 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x6000003be400: name:JSON.docc path:group:JSON.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-json/Sources/JSON/JSON.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:48.720 xcodebuild[58472:822590] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600000399700: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-argument-parser/Sources/ArgumentParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
** BUILD FAILED **
"
Output: "Command line invocation:
    /Applications/Xcode-14.3.0.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme swift-biome-Package -destination platform=macos,arch=arm64

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES

Resolve Package Graph

Resolve Package Graph


Resolved source packages:
  swift-argument-parser: https://github.com/apple/swift-argument-parser.git @ 1.1.3
  swift-nio: https://github.com/apple/swift-nio.git @ 2.41.1
  swift-markdown: https://github.com/apple/swift-markdown.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-dom: https://github.com/kelvin13/swift-dom @ 0.5.2
  swift-json: https://github.com/kelvin13/swift-json @ master
  cmark-gfm: https://github.com/apple/swift-cmark.git @ gfm
  swift-highlight: https://github.com/kelvin13/swift-highlight @ 0.1.4
  SwiftSyntax: https://github.com/apple/swift-syntax.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-system: https://github.com/apple/swift-system.git @ 1.2.1
  swift-biome: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace
  swift-system-extras: https://github.com/kelvin13/swift-system-extras.git @ 0.2.0
  swift-backtrace: https://github.com/swift-server/swift-backtrace.git @ 1.3.2
  swift-grammar: https://github.com/kelvin13/swift-grammar @ 0.2.0
  swift-hash: https://github.com/kelvin13/swift-hash.git @ 0.2.3
  swift-atomics: https://github.com/apple/swift-atomics.git @ 1.0.2
  swift-resource: https://github.com/kelvin13/swift-resource @ 0.3.2

Prepare packages

Computing target dependency graph and provisioning inputs

Create build description
Build description signature: 6e853eb092a14c87310cf678f5fa059f
Build description path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData/Build/Intermediates.noindex/XCBuildData/6e853eb092a14c87310cf678f5fa059f.xcbuilddata

note: Building targets in dependency order
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'swift-symbolgraphc' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageCatalogs' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'SymbolGraphConvert' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
Resolve Package Graph"
Retrying in 0.0 seconds ...
Building ... (attempt 2)
2023-09-15 01:14:51.142 xcodebuild[58646:823282] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
Command line invocation:
/Applications/Xcode-14.3.0.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme swift-biome-Package -destination platform=macos,arch=arm64

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES
Resolve Package Graph


Resolved source packages:
  swift-atomics: https://github.com/apple/swift-atomics.git @ 1.0.2
  swift-biome: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace
  swift-json: https://github.com/kelvin13/swift-json @ master
  swift-markdown: https://github.com/apple/swift-markdown.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-system: https://github.com/apple/swift-system.git @ 1.2.1
  cmark-gfm: https://github.com/apple/swift-cmark.git @ gfm
  swift-system-extras: https://github.com/kelvin13/swift-system-extras.git @ 0.2.0
  swift-highlight: https://github.com/kelvin13/swift-highlight @ 0.1.4
  swift-resource: https://github.com/kelvin13/swift-resource @ 0.3.2
  swift-hash: https://github.com/kelvin13/swift-hash.git @ 0.2.3
  swift-nio: https://github.com/apple/swift-nio.git @ 2.41.1
  swift-grammar: https://github.com/kelvin13/swift-grammar @ 0.2.0
  swift-dom: https://github.com/kelvin13/swift-dom @ 0.5.2
  SwiftSyntax: https://github.com/apple/swift-syntax.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-argument-parser: https://github.com/apple/swift-argument-parser.git @ 1.1.3
  swift-backtrace: https://github.com/swift-server/swift-backtrace.git @ 1.3.2
--- xcodebuild: WARNING: Using the first of multiple matching destinations:
{ platform:macOS, arch:arm64, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Mac Catalyst, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:DriverKit, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Designed for [iPad,iPhone], id:00008103-000604DE26D2001E }
Prepare packages

2023-09-15 01:14:52.236 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x60000164ce00: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.239 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x60000164e000: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntax/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.243 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001631700: name:SwiftParser.docc path:group:SwiftParser.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftParser/SwiftParser.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.246 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001633c00: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxBuilder/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.303 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x60000164b500: name:Markdown.docc path:group:Markdown.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-markdown/Sources/Markdown/Markdown.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.306 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001677900: name:JSON.docc path:group:JSON.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-json/Sources/JSON/JSON.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.316 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001784500: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-argument-parser/Sources/ArgumentParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
Computing target dependency graph and provisioning inputs

Create build description
Build description signature: 6e853eb092a14c87310cf678f5fa059f
Build description path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData/Build/Intermediates.noindex/XCBuildData/6e853eb092a14c87310cf678f5fa059f.xcbuilddata

note: Building targets in dependency order
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'SymbolGraphConvert' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageCatalogs' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'swift-symbolgraphc' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
** BUILD FAILED **
ShellOut encountered an error
Status code: 65
Message: "2023-09-15 01:14:51.142 xcodebuild[58646:823282] DVTCoreDeviceEnabledState: DVTCoreDeviceEnabledState_Disabled set via user default (DVTEnableCoreDevice=disabled)
--- xcodebuild: WARNING: Using the first of multiple matching destinations:
{ platform:macOS, arch:arm64, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Mac Catalyst, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:DriverKit, id:00008103-000604DE26D2001E }
{ platform:macOS, arch:arm64, variant:Designed for [iPad,iPhone], id:00008103-000604DE26D2001E }
2023-09-15 01:14:52.236 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x60000164ce00: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.239 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x60000164e000: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntax/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.243 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001631700: name:SwiftParser.docc path:group:SwiftParser.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftParser/SwiftParser.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "SwiftParser.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.246 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001633c00: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-syntax/Sources/SwiftSyntaxBuilder/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.303 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x60000164b500: name:Markdown.docc path:group:Markdown.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-markdown/Sources/Markdown/Markdown.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Markdown.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.306 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001677900: name:JSON.docc path:group:JSON.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-json/Sources/JSON/JSON.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "JSON.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
2023-09-15 01:14:52.316 xcodebuild[58646:823282] [MT] IDEFileReferenceDebug: [Load] <IDESwiftPackageCore.IDESwiftPackageSpecialFolderFileReference, 0x600001784500: name:Documentation.docc path:group:Documentation.docc> Failed to load container at path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies/checkouts/swift-argument-parser/Sources/ArgumentParser/Documentation.docc, Error: Error Domain=com.apple.dt.IDEContainerErrorDomain Code=6 "Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder"." UserInfo={NSLocalizedDescription=Cannot open "Documentation.docc" as a "Swift Package Folder" because it is already open as a "Folder".}
** BUILD FAILED **
"
Output: "Command line invocation:
    /Applications/Xcode-14.3.0.app/Contents/Developer/usr/bin/xcodebuild -IDEClonedSourcePackagesDirPathOverride=/Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies -derivedDataPath /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData build -scheme swift-biome-Package -destination platform=macos,arch=arm64

User defaults from command line:
    IDEClonedSourcePackagesDirPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.dependencies
    IDEDerivedDataPathOverride = /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData
    IDEPackageSupportUseBuiltinSCM = YES

Resolve Package Graph


Resolved source packages:
  swift-atomics: https://github.com/apple/swift-atomics.git @ 1.0.2
  swift-biome: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace
  swift-json: https://github.com/kelvin13/swift-json @ master
  swift-markdown: https://github.com/apple/swift-markdown.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-system: https://github.com/apple/swift-system.git @ 1.2.1
  cmark-gfm: https://github.com/apple/swift-cmark.git @ gfm
  swift-system-extras: https://github.com/kelvin13/swift-system-extras.git @ 0.2.0
  swift-highlight: https://github.com/kelvin13/swift-highlight @ 0.1.4
  swift-resource: https://github.com/kelvin13/swift-resource @ 0.3.2
  swift-hash: https://github.com/kelvin13/swift-hash.git @ 0.2.3
  swift-nio: https://github.com/apple/swift-nio.git @ 2.41.1
  swift-grammar: https://github.com/kelvin13/swift-grammar @ 0.2.0
  swift-dom: https://github.com/kelvin13/swift-dom @ 0.5.2
  SwiftSyntax: https://github.com/apple/swift-syntax.git @ swift-DEVELOPMENT-SNAPSHOT-2022-08-24-a
  swift-argument-parser: https://github.com/apple/swift-argument-parser.git @ 1.1.3
  swift-backtrace: https://github.com/swift-server/swift-backtrace.git @ 1.3.2

Prepare packages

Computing target dependency graph and provisioning inputs

Create build description
Build description signature: 6e853eb092a14c87310cf678f5fa059f
Build description path: /Users/builder/builds/o86TiJKT/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.derivedData/Build/Intermediates.noindex/XCBuildData/6e853eb092a14c87310cf678f5fa059f.xcbuilddata

note: Building targets in dependency order
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Biome' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'Preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'SymbolGraphConvert' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageCatalogs' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'preview' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'swift-symbolgraphc' from project 'swift-biome')
error: The package product 'SystemExtras' requires minimum platform version 11.0 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntaxParser' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')
error: The package product 'SwiftSyntax' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.13 (in target 'PackageLoader' from project 'swift-biome')"
BUILD FAILURE 5.8 macosXcodebuild