The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build Source with Swift 5.10 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.3.0.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.33.2
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/blackjacx/Source.git
Reference: 1.11.0
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/blackjacx/Source
 * tag               1.11.0     -> FETCH_HEAD
HEAD is now at c3efecc Merge branch 'release/1.11.0'
Cloned https://github.com/blackjacx/Source.git
Revision (git rev-parse @):
c3efeccfdf587a4d57c655c992a6478fbc878e2c
SUCCESS checkout https://github.com/blackjacx/Source.git at 1.11.0
========================================
ResolveProductDependencies
========================================
Resolving dependencies ...
{
  "identity": ".resolve-product-dependencies",
  "name": "resolve-dependencies",
  "url": "/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies",
  "version": "unspecified",
  "path": "/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies",
  "dependencies": [
    {
      "identity": "source",
      "name": "Source",
      "url": "https://github.com/blackjacx/Source.git",
      "version": "unspecified",
      "path": "/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/Source",
      "dependencies": [
      ]
    }
  ]
}
Fetching https://github.com/blackjacx/Source.git
[1/2177] Fetching source
Fetched https://github.com/blackjacx/Source.git from cache (0.36s)
Creating working copy for https://github.com/blackjacx/Source.git
Working copy of https://github.com/blackjacx/Source.git resolved at 1.11.0 (c3efecc)
warning: '.resolve-product-dependencies': dependency 'source' is not used by any target
Found 0 product dependencies
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.10
Building package at path:  $workDir
https://github.com/blackjacx/Source.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.3.0.app xcrun swift build --arch arm64
Building for debugging...
[0/2] Write sources
[1/2] Write swift-version-6044DDE57671499D.txt
[3/13] Compiling Source UITableViewCell+Extensions.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
error: emit-module command failed with exit code 1 (use -v to see invocation)
[4/13] Emitting module Source
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[5/13] Compiling Source SupplementaryViewModel.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[6/13] Compiling Source Reusable.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[7/13] Compiling Source DataSource.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[8/13] Compiling Source HeightConfigurable.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[9/14] Compiling Source ModelCollection.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[10/14] Compiling Source NSDirectionalLayoutEdges+Extensions.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[11/14] Compiling Source Section.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[12/14] Compiling Source Configurable.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[13/14] Compiling Source ConfigurableSupplementaryView.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[14/14] Compiling Source ViewModel.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
error: fatalError
[0/1] Planning build
Building for debugging...
[0/1] Write swift-version-6044DDE57671499D.txt
[2/12] Compiling Source UITableViewCell+Extensions.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[3/13] Compiling Source SupplementaryViewModel.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[4/13] Compiling Source Configurable.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[5/13] Compiling Source ConfigurableSupplementaryView.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[6/13] Compiling Source Reusable.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[7/13] Compiling Source Section.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[8/13] Compiling Source DataSource.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[9/13] Compiling Source HeightConfigurable.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
error: emit-module command failed with exit code 1 (use -v to see invocation)
[10/13] Emitting module Source
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[11/13] Compiling Source ModelCollection.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[12/13] Compiling Source NSDirectionalLayoutEdges+Extensions.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[13/13] Compiling Source ViewModel.swift
/Users/builder/builds/UKfvDsi8u/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/Source/ConfigurableSupplementaryView.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
error: fatalError
BUILD FAILURE 5.10 macosSpm

Build Machine: Mac 7