The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build PackageGeneratorPlugin with Swift 5.9 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.2.0.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.38.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/mackoj/PackageGeneratorPlugin.git
Reference: main
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/mackoj/PackageGeneratorPlugin
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 001bfeb update cli version
Cloned https://github.com/mackoj/PackageGeneratorPlugin.git
Revision (git rev-parse @):
001bfeb6fdaedbd4e5e6fbfd6aaa32bf1caddc46
SUCCESS checkout https://github.com/mackoj/PackageGeneratorPlugin.git at main
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.9
Building package at path:  $workDir
https://github.com/mackoj/PackageGeneratorPlugin.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.2.0.app xcrun swift build --arch arm64
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.10.0 but the installed version is 5.9.0
BUILD FAILURE 5.9 macosSpm

Build Machine: Mac 7