Build Information
Successful build of swift-rfc-5322, reference main (e9864e), with Swift 6.4 for Linux on 3 Oct 2026 09:10:49 UTC.
Swift 6 data race errors: 0
Build Command
bash -c docker run --pull=always --rm -v "checkouts-54344844-2":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest swift build --triple x86_64-unknown-linux-gnu 2>&1Build Log
========================================
RunAll
========================================
Builder version: 5.1.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/swift-ietf/swift-rfc-5322.git
Reference: main
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: git branch -m <name>
From https://github.com/swift-ietf/swift-rfc-5322
* branch main -> FETCH_HEAD
* [new branch] main -> origin/main
HEAD is now at e9864e0 Refuse signed numeric fields and unsigned zones in RFC 5322 date-times
Cloned https://github.com/swift-ietf/swift-rfc-5322.git
Revision (git rev-parse @):
e9864e0e8d7de38612fdd23bd7a5d38f43892ef3
SPI manifest file found: $PWD/.spi.yml
SUCCESS checkout https://github.com/swift-ietf/swift-rfc-5322.git at main
========================================
Build
========================================
Selected platform: linux
Swift version: 6.4
Building package at path: $PWD
https://github.com/swift-ietf/swift-rfc-5322.git
Running build ...
bash -c docker run --pull=always --rm -v "checkouts-54344844-2":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
basic-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:c77fcce225e223ac0fafed844619173fc6de8d62dd560eeb28db3182af6a282b
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest
Fetching https://github.com/swift-ietf/swift-rfc-1123.git
[1/605] Fetching swift-rfc-1123
Fetched https://github.com/swift-ietf/swift-rfc-1123.git (0.39s)
Fetching https://github.com/swift-atoms/swift-standard-library-extensions.git
[1/1234] Fetching swift-standard-library-extensions
Fetched https://github.com/swift-atoms/swift-standard-library-extensions.git (0.43s)
Fetching https://github.com/swift-atoms/swift-time.git
[1/1049] Fetching swift-time
Fetched https://github.com/swift-atoms/swift-time.git (0.40s)
Fetching https://github.com/swift-atoms/swift-calendar.git
[1/157] Fetching swift-calendar
Fetched https://github.com/swift-atoms/swift-calendar.git (0.42s)
Fetching https://github.com/swift-molecules/swift-calendar-gregorian.git
[1/139] Fetching swift-calendar-gregorian
Fetched https://github.com/swift-molecules/swift-calendar-gregorian.git (0.41s)
Fetching https://github.com/swift-atoms/swift-ascii.git
[1/780] Fetching swift-ascii
Fetched https://github.com/swift-atoms/swift-ascii.git (0.44s)
Fetching https://github.com/swift-incits/swift-incits-4-1986.git
[1/1301] Fetching swift-incits-4-1986
Fetched https://github.com/swift-incits/swift-incits-4-1986.git (0.44s)
Fetching https://github.com/swift-atoms/swift-byte.git
[1/594] Fetching swift-byte
Fetched https://github.com/swift-atoms/swift-byte.git (0.41s)
Fetching https://github.com/swift-ietf/swift-rfc-1035.git
[1/697] Fetching swift-rfc-1035
Fetched https://github.com/swift-ietf/swift-rfc-1035.git (0.48s)
Fetching https://github.com/swift-atoms/swift-addition.git
[1/79] Fetching swift-addition
Fetched https://github.com/swift-atoms/swift-addition.git (0.36s)
Fetching https://github.com/swift-atoms/swift-magnitude.git
[1/103] Fetching swift-magnitude
Fetched https://github.com/swift-atoms/swift-magnitude.git (0.41s)
Fetching https://github.com/swift-atoms/swift-polarity.git
[1/219] Fetching swift-polarity
Fetched https://github.com/swift-atoms/swift-polarity.git (0.47s)
Fetching https://github.com/swift-atoms/swift-coordinate.git
[1/49] Fetching swift-coordinate
Fetched https://github.com/swift-atoms/swift-coordinate.git (0.38s)
Fetching https://github.com/swift-atoms/swift-translation.git
[1/47] Fetching swift-translation
Fetched https://github.com/swift-atoms/swift-translation.git (0.39s)
Fetching https://github.com/swift-atoms/swift-cardinal.git
[1/1437] Fetching swift-cardinal
Fetched https://github.com/swift-atoms/swift-cardinal.git (0.43s)
Fetching https://github.com/swift-atoms/swift-difference.git
[1/176] Fetching swift-difference
Fetched https://github.com/swift-atoms/swift-difference.git (0.39s)
Fetching https://github.com/swift-atoms/swift-division.git
[1/84] Fetching swift-division
Fetched https://github.com/swift-atoms/swift-division.git (0.40s)
Fetching https://github.com/swift-atoms/swift-rational.git
[1/115] Fetching swift-rational
Fetched https://github.com/swift-atoms/swift-rational.git (0.43s)
Fetching https://github.com/swift-atoms/swift-ratio.git
[1/163] Fetching swift-ratio
Fetched https://github.com/swift-atoms/swift-ratio.git (0.37s)
Fetching https://github.com/swift-atoms/swift-tagged.git
[1/1858] Fetching swift-tagged
Fetched https://github.com/swift-atoms/swift-tagged.git (0.44s)
Fetching https://github.com/swift-atoms/swift-optic.git
[1/761] Fetching swift-optic
Fetched https://github.com/swift-atoms/swift-optic.git (0.42s)
Fetching https://github.com/swift-atoms/swift-either.git
[1/399] Fetching swift-either
Fetched https://github.com/swift-atoms/swift-either.git (0.42s)
Fetching https://github.com/swift-atoms/swift-carrier.git
[1/1402] Fetching swift-carrier
Fetched https://github.com/swift-atoms/swift-carrier.git (0.42s)
Fetching https://github.com/swift-atoms/swift-checkpoint.git
[1/73] Fetching swift-checkpoint
Fetched https://github.com/swift-atoms/swift-checkpoint.git (0.35s)
Fetching https://github.com/swift-atoms/swift-coder.git
[1/1030] Fetching swift-coder
Fetched https://github.com/swift-atoms/swift-coder.git (0.40s)
Fetching https://github.com/swift-atoms/swift-cursor.git
[1/304] Fetching swift-cursor
Fetched https://github.com/swift-atoms/swift-cursor.git (0.41s)
Fetching https://github.com/swift-atoms/swift-iterator.git
[1/628] Fetching swift-iterator
Fetched https://github.com/swift-atoms/swift-iterator.git (0.80s)
Fetching https://github.com/swift-atoms/swift-parser.git
[1/4492] Fetching swift-parser
Fetched https://github.com/swift-atoms/swift-parser.git (0.44s)
Fetching https://github.com/swift-atoms/swift-serializer.git
[1/852] Fetching swift-serializer
Fetched https://github.com/swift-atoms/swift-serializer.git (0.39s)
Fetching https://github.com/swift-atoms/swift-bit.git
[1/853] Fetching swift-bit
Fetched https://github.com/swift-atoms/swift-bit.git (0.44s)
Fetching https://github.com/swift-atoms/swift-index.git
[1/1055] Fetching swift-index
Fetched https://github.com/swift-atoms/swift-index.git (0.40s)
Fetching https://github.com/swift-atoms/swift-finite.git
[1/824] Fetching swift-finite
Fetched https://github.com/swift-atoms/swift-finite.git (0.40s)
Fetching https://github.com/swift-atoms/swift-ordinal.git
[1/1465] Fetching swift-ordinal
Fetched https://github.com/swift-atoms/swift-ordinal.git (0.40s)
Fetching https://github.com/swift-atoms/swift-pair.git
[1/375] Fetching swift-pair
Fetched https://github.com/swift-atoms/swift-pair.git (0.38s)
Fetching https://github.com/swift-atoms/swift-vector.git
[1/118] Fetching swift-vector
Fetched https://github.com/swift-atoms/swift-vector.git (0.43s)
Fetching https://github.com/swift-atoms/swift-subtraction.git
[1/59] Fetching swift-subtraction
Fetched https://github.com/swift-atoms/swift-subtraction.git (0.40s)
Fetching https://github.com/swift-atoms/swift-property.git
[1/1563] Fetching swift-property
Fetched https://github.com/swift-atoms/swift-property.git (0.91s)
Fetching https://github.com/swift-atoms/swift-rounding.git
[1/61] Fetching swift-rounding
Fetched https://github.com/swift-atoms/swift-rounding.git (0.40s)
Fetching https://github.com/swift-atoms/swift-integer.git
[1/105] Fetching swift-integer
Fetched https://github.com/swift-atoms/swift-integer.git (0.41s)
Fetching https://github.com/swift-atoms/swift-multiplication.git
[1/79] Fetching swift-multiplication
Fetched https://github.com/swift-atoms/swift-multiplication.git (0.38s)
Fetching https://github.com/swift-atoms/swift-memory.git
[1/1981] Fetching swift-memory
Fetched https://github.com/swift-atoms/swift-memory.git (1.01s)
Fetching https://github.com/swift-atoms/swift-bifunctor.git
[1/213] Fetching swift-bifunctor
Fetched https://github.com/swift-atoms/swift-bifunctor.git (0.41s)
Fetching https://github.com/swift-atoms/swift-algebra.git
[1/1674] Fetching swift-algebra
Fetched https://github.com/swift-atoms/swift-algebra.git (0.42s)
Fetching https://github.com/swift-atoms/swift-coproduct.git
[1/429] Fetching swift-coproduct
Fetched https://github.com/swift-atoms/swift-coproduct.git (0.46s)
Fetching https://github.com/swift-atoms/swift-always.git
[1/65] Fetching swift-always
Fetched https://github.com/swift-atoms/swift-always.git (0.58s)
Fetching https://github.com/swift-atoms/swift-repetition.git
[1/40] Fetching swift-repetition
Fetched https://github.com/swift-atoms/swift-repetition.git (0.37s)
Fetching https://github.com/swift-atoms/swift-predicate.git
[1/537] Fetching swift-predicate
Fetched https://github.com/swift-atoms/swift-predicate.git (0.42s)
Fetching https://github.com/swift-atoms/swift-skip.git
[1/30] Fetching swift-skip
Fetched https://github.com/swift-atoms/swift-skip.git (0.41s)
Fetching https://github.com/swift-atoms/swift-map.git
[1/36] Fetching swift-map
Fetched https://github.com/swift-atoms/swift-map.git (0.35s)
Fetching https://github.com/swift-atoms/swift-operation.git
[1/322] Fetching swift-operation
Fetched https://github.com/swift-atoms/swift-operation.git (0.39s)
Fetching https://github.com/swift-atoms/swift-empty.git
[1/178] Fetching swift-empty
Fetched https://github.com/swift-atoms/swift-empty.git (0.80s)
Fetching https://github.com/swift-atoms/swift-single.git
[1/199] Fetching swift-single
Fetched https://github.com/swift-atoms/swift-single.git (0.37s)
Fetching https://github.com/swift-atoms/swift-search.git
[1/45] Fetching swift-search
Fetched https://github.com/swift-atoms/swift-search.git (0.45s)
Fetching https://github.com/swift-atoms/swift-append.git
[1/33] Fetching swift-append
Fetched https://github.com/swift-atoms/swift-append.git (0.37s)
Fetching https://github.com/swift-atoms/swift-flatmap.git
[1/30] Fetching swift-flatmap
Fetched https://github.com/swift-atoms/swift-flatmap.git (0.37s)
Fetching https://github.com/swift-atoms/swift-lazy.git
[1/76] Fetching swift-lazy
Fetched https://github.com/swift-atoms/swift-lazy.git (0.35s)
Fetching https://github.com/swift-atoms/swift-collection.git
[1/1295] Fetching swift-collection
Fetched https://github.com/swift-atoms/swift-collection.git (0.89s)
Fetching https://github.com/swift-atoms/swift-product.git
[1/602] Fetching swift-product
Fetched https://github.com/swift-atoms/swift-product.git (0.41s)
Fetching https://github.com/swift-atoms/swift-successor.git
[1/68] Fetching swift-successor
Fetched https://github.com/swift-atoms/swift-successor.git (0.37s)
Fetching https://github.com/swift-atoms/swift-predecessor.git
[1/68] Fetching swift-predecessor
Fetched https://github.com/swift-atoms/swift-predecessor.git (0.40s)
Fetching https://github.com/swift-atoms/swift-advancement.git
[1/68] Fetching swift-advancement
Fetched https://github.com/swift-atoms/swift-advancement.git (0.39s)
Fetching https://github.com/swift-atoms/swift-retreat.git
[1/68] Fetching swift-retreat
Fetched https://github.com/swift-atoms/swift-retreat.git (0.40s)
Fetching https://github.com/swift-atoms/swift-distance.git
[1/68] Fetching swift-distance
Fetched https://github.com/swift-atoms/swift-distance.git (0.38s)
Fetching https://github.com/swift-atoms/swift-ownership.git
[1/3106] Fetching swift-ownership
Fetched https://github.com/swift-atoms/swift-ownership.git (0.99s)
Fetching https://github.com/swift-atoms/swift-order.git
[1/864] Fetching swift-order
Fetched https://github.com/swift-atoms/swift-order.git (0.91s)
Fetching https://github.com/swift-atoms/swift-sequence.git
[1/2186] Fetching swift-sequence
Fetched https://github.com/swift-atoms/swift-sequence.git (0.47s)
Fetching https://github.com/swift-atoms/swift-span.git
[1/433] Fetching swift-span
Fetched https://github.com/swift-atoms/swift-span.git (0.45s)
Fetching https://github.com/swift-atoms/swift-error.git
[1/350] Fetching swift-error
Fetched https://github.com/swift-atoms/swift-error.git (0.43s)
Fetching https://github.com/swift-atoms/swift-logic.git
[1/1008] Fetching swift-logic
Fetched https://github.com/swift-atoms/swift-logic.git (0.40s)
Fetching https://github.com/swift-atoms/swift-contramap.git
[1/33] Fetching swift-contramap
Fetched https://github.com/swift-atoms/swift-contramap.git (0.38s)
Fetching https://github.com/swiftlang/swift-syntax.git
[1/80206] Fetching swift-syntax
Fetched https://github.com/swiftlang/swift-syntax.git (3.36s)
Computing version for https://github.com/swiftlang/swift-syntax.git
Computed https://github.com/swiftlang/swift-syntax.git at 603.0.2 (4.56s)
Creating working copy for https://github.com/swift-atoms/swift-coordinate.git
Working copy of https://github.com/swift-atoms/swift-coordinate.git resolved at main (6c56b05)
Creating working copy for https://github.com/swift-atoms/swift-bifunctor.git
Working copy of https://github.com/swift-atoms/swift-bifunctor.git resolved at main (18fe386)
Creating working copy for https://github.com/swift-atoms/swift-cardinal.git
Working copy of https://github.com/swift-atoms/swift-cardinal.git resolved at main (a4beb26)
Creating working copy for https://github.com/swift-atoms/swift-algebra.git
Working copy of https://github.com/swift-atoms/swift-algebra.git resolved at main (6f0468a)
Creating working copy for https://github.com/swift-atoms/swift-ordinal.git
Working copy of https://github.com/swift-atoms/swift-ordinal.git resolved at main (bdb3f64)
Creating working copy for https://github.com/swift-atoms/swift-span.git
Working copy of https://github.com/swift-atoms/swift-span.git resolved at main (81b5071)
Creating working copy for https://github.com/swift-atoms/swift-retreat.git
Working copy of https://github.com/swift-atoms/swift-retreat.git resolved at main (c78a367)
Creating working copy for https://github.com/swift-atoms/swift-bit.git
Working copy of https://github.com/swift-atoms/swift-bit.git resolved at main (30f6189)
Creating working copy for https://github.com/swift-atoms/swift-either.git
Working copy of https://github.com/swift-atoms/swift-either.git resolved at main (46c666a)
Creating working copy for https://github.com/swift-atoms/swift-ascii.git
Working copy of https://github.com/swift-atoms/swift-ascii.git resolved at main (a365691)
Creating working copy for https://github.com/swift-atoms/swift-difference.git
Working copy of https://github.com/swift-atoms/swift-difference.git resolved at main (fb95a3f)
Creating working copy for https://github.com/swift-atoms/swift-carrier.git
Working copy of https://github.com/swift-atoms/swift-carrier.git resolved at main (ee19248)
Creating working copy for https://github.com/swift-atoms/swift-error.git
Working copy of https://github.com/swift-atoms/swift-error.git resolved at main (f6ad8ee)
Creating working copy for https://github.com/swift-atoms/swift-successor.git
Working copy of https://github.com/swift-atoms/swift-successor.git resolved at main (ab8561a)
Creating working copy for https://github.com/swift-atoms/swift-standard-library-extensions.git
Working copy of https://github.com/swift-atoms/swift-standard-library-extensions.git resolved at main (a727a9e)
Creating working copy for https://github.com/swift-atoms/swift-collection.git
Working copy of https://github.com/swift-atoms/swift-collection.git resolved at main (7013fe3)
Creating working copy for https://github.com/swift-atoms/swift-polarity.git
Working copy of https://github.com/swift-atoms/swift-polarity.git resolved at main (4880d7d)
Creating working copy for https://github.com/swift-atoms/swift-finite.git
Working copy of https://github.com/swift-atoms/swift-finite.git resolved at main (f3eac5b)
Creating working copy for https://github.com/swift-atoms/swift-multiplication.git
Working copy of https://github.com/swift-atoms/swift-multiplication.git resolved at main (f07296d)
Creating working copy for https://github.com/swift-atoms/swift-rounding.git
Working copy of https://github.com/swift-atoms/swift-rounding.git resolved at main (5481997)
Creating working copy for https://github.com/swift-atoms/swift-distance.git
Working copy of https://github.com/swift-atoms/swift-distance.git resolved at main (1856165)
Creating working copy for https://github.com/swift-atoms/swift-translation.git
Working copy of https://github.com/swift-atoms/swift-translation.git resolved at main (32e900c)
Creating working copy for https://github.com/swift-atoms/swift-checkpoint.git
Working copy of https://github.com/swift-atoms/swift-checkpoint.git resolved at main (aa7b4ec)
Creating working copy for https://github.com/swift-atoms/swift-single.git
Working copy of https://github.com/swift-atoms/swift-single.git resolved at main (e468dca)
Creating working copy for https://github.com/swift-atoms/swift-operation.git
Working copy of https://github.com/swift-atoms/swift-operation.git resolved at main (6b09f83)
Creating working copy for https://github.com/swift-atoms/swift-product.git
Working copy of https://github.com/swift-atoms/swift-product.git resolved at main (d4702f8)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1123.git
Working copy of https://github.com/swift-ietf/swift-rfc-1123.git resolved at main (0563819)
Creating working copy for https://github.com/swift-atoms/swift-subtraction.git
Working copy of https://github.com/swift-atoms/swift-subtraction.git resolved at main (4614d98)
Creating working copy for https://github.com/swift-atoms/swift-repetition.git
Working copy of https://github.com/swift-atoms/swift-repetition.git resolved at main (b2fafee)
Creating working copy for https://github.com/swift-atoms/swift-advancement.git
Working copy of https://github.com/swift-atoms/swift-advancement.git resolved at main (b947ae1)
Creating working copy for https://github.com/swift-atoms/swift-logic.git
Working copy of https://github.com/swift-atoms/swift-logic.git resolved at main (91fbf3b)
Creating working copy for https://github.com/swift-atoms/swift-ratio.git
Working copy of https://github.com/swift-atoms/swift-ratio.git resolved at main (089c5d6)
Creating working copy for https://github.com/swift-atoms/swift-contramap.git
Working copy of https://github.com/swift-atoms/swift-contramap.git resolved at main (c719674)
Creating working copy for https://github.com/swift-atoms/swift-search.git
Working copy of https://github.com/swift-atoms/swift-search.git resolved at main (ab399f1)
Creating working copy for https://github.com/swift-atoms/swift-empty.git
Working copy of https://github.com/swift-atoms/swift-empty.git resolved at main (134c48b)
Creating working copy for https://github.com/swift-atoms/swift-flatmap.git
Working copy of https://github.com/swift-atoms/swift-flatmap.git resolved at main (03442d2)
Creating working copy for https://github.com/swift-atoms/swift-parser.git
Working copy of https://github.com/swift-atoms/swift-parser.git resolved at main (0913ad9)
Creating working copy for https://github.com/swift-atoms/swift-integer.git
Working copy of https://github.com/swift-atoms/swift-integer.git resolved at main (05212bf)
Creating working copy for https://github.com/swift-atoms/swift-serializer.git
Working copy of https://github.com/swift-atoms/swift-serializer.git resolved at main (3971b0a)
Creating working copy for https://github.com/swift-atoms/swift-division.git
Working copy of https://github.com/swift-atoms/swift-division.git resolved at main (fe65e48)
Creating working copy for https://github.com/swift-atoms/swift-tagged.git
Working copy of https://github.com/swift-atoms/swift-tagged.git resolved at main (6e00f02)
Creating working copy for https://github.com/swift-atoms/swift-optic.git
Working copy of https://github.com/swift-atoms/swift-optic.git resolved at main (72cf3fd)
Creating working copy for https://github.com/swift-atoms/swift-addition.git
Working copy of https://github.com/swift-atoms/swift-addition.git resolved at main (7662e87)
Creating working copy for https://github.com/swift-atoms/swift-property.git
Working copy of https://github.com/swift-atoms/swift-property.git resolved at main (5b9a7f3)
Creating working copy for https://github.com/swift-atoms/swift-always.git
Working copy of https://github.com/swift-atoms/swift-always.git resolved at main (1229653)
Creating working copy for https://github.com/swift-atoms/swift-magnitude.git
Working copy of https://github.com/swift-atoms/swift-magnitude.git resolved at main (6c31511)
Creating working copy for https://github.com/swift-atoms/swift-sequence.git
Working copy of https://github.com/swift-atoms/swift-sequence.git resolved at main (7c462e3)
Creating working copy for https://github.com/swift-atoms/swift-skip.git
Working copy of https://github.com/swift-atoms/swift-skip.git resolved at main (728b918)
Creating working copy for https://github.com/swift-atoms/swift-index.git
Working copy of https://github.com/swift-atoms/swift-index.git resolved at main (425b76c)
Creating working copy for https://github.com/swift-atoms/swift-predecessor.git
Working copy of https://github.com/swift-atoms/swift-predecessor.git resolved at main (42a711d)
Creating working copy for https://github.com/swift-atoms/swift-iterator.git
Working copy of https://github.com/swift-atoms/swift-iterator.git resolved at main (e276f0c)
Creating working copy for https://github.com/swift-atoms/swift-calendar.git
Working copy of https://github.com/swift-atoms/swift-calendar.git resolved at main (92ed545)
Creating working copy for https://github.com/swift-atoms/swift-cursor.git
Working copy of https://github.com/swift-atoms/swift-cursor.git resolved at main (0c4eb8c)
Creating working copy for https://github.com/swift-incits/swift-incits-4-1986.git
Working copy of https://github.com/swift-incits/swift-incits-4-1986.git resolved at main (b208aff)
Creating working copy for https://github.com/swift-atoms/swift-coproduct.git
Working copy of https://github.com/swift-atoms/swift-coproduct.git resolved at main (224eb87)
Creating working copy for https://github.com/swift-atoms/swift-map.git
Working copy of https://github.com/swift-atoms/swift-map.git resolved at main (317c5f8)
Creating working copy for https://github.com/swift-atoms/swift-vector.git
Working copy of https://github.com/swift-atoms/swift-vector.git resolved at main (915cd7c)
Creating working copy for https://github.com/swift-atoms/swift-memory.git
Working copy of https://github.com/swift-atoms/swift-memory.git resolved at main (dc058d2)
Creating working copy for https://github.com/swift-atoms/swift-time.git
Working copy of https://github.com/swift-atoms/swift-time.git resolved at main (c6cb993)
Creating working copy for https://github.com/swift-atoms/swift-append.git
Working copy of https://github.com/swift-atoms/swift-append.git resolved at main (5a2c22d)
Creating working copy for https://github.com/swiftlang/swift-syntax.git
Working copy of https://github.com/swiftlang/swift-syntax.git resolved at 603.0.2
Creating working copy for https://github.com/swift-atoms/swift-lazy.git
Working copy of https://github.com/swift-atoms/swift-lazy.git resolved at main (f12c258)
Creating working copy for https://github.com/swift-atoms/swift-predicate.git
Working copy of https://github.com/swift-atoms/swift-predicate.git resolved at main (57d2250)
Creating working copy for https://github.com/swift-molecules/swift-calendar-gregorian.git
Working copy of https://github.com/swift-molecules/swift-calendar-gregorian.git resolved at main (301a29c)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1035.git
Working copy of https://github.com/swift-ietf/swift-rfc-1035.git resolved at main (215fda4)
Creating working copy for https://github.com/swift-atoms/swift-ownership.git
Working copy of https://github.com/swift-atoms/swift-ownership.git resolved at main (f8702ec)
Creating working copy for https://github.com/swift-atoms/swift-order.git
Working copy of https://github.com/swift-atoms/swift-order.git resolved at main (a1866fe)
Creating working copy for https://github.com/swift-atoms/swift-byte.git
Working copy of https://github.com/swift-atoms/swift-byte.git resolved at main (50bd3e3)
Creating working copy for https://github.com/swift-atoms/swift-rational.git
Working copy of https://github.com/swift-atoms/swift-rational.git resolved at main (f973aa9)
Creating working copy for https://github.com/swift-atoms/swift-coder.git
Working copy of https://github.com/swift-atoms/swift-coder.git resolved at main (627a31c)
Creating working copy for https://github.com/swift-atoms/swift-pair.git
Working copy of https://github.com/swift-atoms/swift-pair.git resolved at main (d71085f)
warning: 'spi-builder-workspace': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
Building for debugging...
[Computing dependencies]
[Constructing description]
[Pre-planning 1 / 2164]
[Planning 232 / 2164]
[Planning 1631 / 2164]
[Planning deferred tasks]
[Constructing 775 / 5144]
[Starting]
[219 / 925] Multiplication
[444 / 940] Single
[452 / 986] Skip
[481 / 998] Vector
[503 / 998] Map
[506 / 998] Vector
[515 / 998] Translation-product
[521 / 999] Translation
[522 / 999] Translation
[524 / 1000] Standard Library Extensions-product
[530 / 1001] Skip-product
[534 / 1002] Search
[540 / 1002] Search-product
[544 / 1002] Product-product
[552 / 1003] Pair
[559 / 1004] Operation
[568 / 1005] Map
[583 / 1012] Operation
[592 / 1058] Product
[599 / 1070] FlatMap
[613 / 1081] Logic
[647 / 1086] Map
[676 / 1087] Always
[689 / 1087] FlatMap
[699 / 1089] Either
[708 / 1091] Either
[714 / 1091] Checkpoint-product
[723 / 1092] Contramap
[728 / 1093] Bit
[736 / 1094] Append
[749 / 1095] Logic
[768 / 1112] Coordinate
[776 / 1139] Polarity
[785 / 1140] Coordinate
[790 / 1140] Tagged
[791 / 1140] Optic
[805 / 1140] Tagged
[813 / 1140] Tagged-product
[817 / 1140] Multiplication
[819 / 1140] Coordinate-product
[821 / 1140] Contramap
[825 / 1141] Coordinate
[827 / 1141] Algebra-product
[828 / 1141] Algebra-product
[831 / 1141] Addition
[836 / 1153] Optic
[839 / 1154] Ownership
[848 / 1162] Predicate
[853 / 1162] Predicate-product
[855 / 1164] Algebra
[859 / 1164] Ownership
[867 / 1164] Logic-product
[877 / 1180] Polarity
[883 / 1185] Multiplication
[903 / 1185] Magnitude
[910 / 1189] Subtraction
[920 / 1204] Successor
[928 / 1206] Subtraction
[945 / 1207] Predecessor
[957 / 1219] Predecessor
[979 / 1220] Retreat
[987 / 1228] Distance
[992 / 1246] Distance
[999 / 1246] Order
[1004 / 1246] Order
[1008 / 1246] Distance-product
[1014 / 1249] Cardinal
[1023 / 1250] Property
[1029 / 1250] Distance
[1034 / 1251] Order
[1041 / 1261] Repetition
[1045 / 1261] Repetition
[1052 / 1261] Rounding
[1071 / 1267] Repetition
[1081 / 1298] Cardinal
[1084 / 1298] Iterator
[1084 / 1298] Division
[1091 / 1300] Rounding
[1097 / 1300] Iterator
[1109 / 1300] Iterator-product
[1116 / 1300] Integer-product
[1119 / 1300] Division
[1124 / 1301] Rational
[1127 / 1301] Difference-product
[1131 / 1302]
[1135 / 1320] Difference
[1141 / 1330] Rational
[1155 / 1331] Rational-product
[1160 / 1331] Ordinal
[1162 / 1332] Rational
[1166 / 1332] Difference
[1174 / 1332] Ordinal
[1180 / 1333] Order-product
[1188 / 1338]
[1202 / 1348] Sequence
[1203 / 1348] Sequence
[1204 / 1349] Sequence
[1205 / 1349] Ordinal
[1205 / 1349] Integer
[1211 / 1350]
[1214 / 1359] Finite
[1217 / 1359] Finite
[1219 / 1359] Finite
[1225 / 1359] Sequence
[1230 / 1360] Index
[1235 / 1369] Collection
[1236 / 1369] Collection
[1240 / 1370] Finite
[1247 / 1370]
[1256 / 1381] Finite
[1261 / 1381] Collection
[1266 / 1382] Byte
[1276 / 1393] Span
[1278 / 1411] Parser
[1280 / 1411] Span
[1286 / 1411] Span
[1296 / 1411] Serializer
[1300 / 1413] Serializer-product
[1313 / 1414] Parser
[1316 / 1414] Parser-product
[1326 / 1416]
[1329 / 1417] Coder
[1338 / 1435] Memory
[1342 / 1435] Memory
[1347 / 1435] Coder
[1348 / 1435] Parser
[1355 / 1436] Coder-product
[1359 / 1438] ASCII
[1363 / 1447] Coder
[1367 / 1447] Memory
[1372 / 1447] Memory
[1374 / 1448]
[1377 / 1458] Ratio
[1379 / 1458] Ratio
[1380 / 1458] Ratio
[1387 / 1458] Ratio
[1392 / 1459] ASCII
[1403 / 1470] Time
[1406 / 1488] Time
[1407 / 1489] Time
[1408 / 1490] Time
[1410 / 1490] RFC 1035
[1416 / 1490] Time
[1427 / 1490] Time-product
[1431 / 1490] Ratio
[1433 / 1490] RFC 1035-product
[1435 / 1490] RFC 1123
[1439 / 1490] INCITS 4 1986
[1442 / 1491] Time
[1446 / 1491] Time
[1449 / 1491]
[1456 / 1510] RFC 1123
[1457 / 1510] Time
[1460 / 1510] RFC 1123
[1469 / 1511] Calendar
[1478 / 1512] Calendar
[1481 / 1512] Calendar-product
[1483 / 1512] Calendar Gregorian
[1488 / 1514] RFC 1035
[1494 / 1523] Calendar Gregorian
[1494 / 1523] RFC 1123
[1496 / 1523] Calendar Gregorian
[1498 / 1524] Calendar
[1499 / 1524] Calendar Gregorian
[1500 / 1524] Calendar
[1506 / 1524]
[1508 / 1534] RFC 5322
[1511 / 1534] RFC 5322
[1512 / 1534] RFC 5322
[1513 / 1534] RFC 5322
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Header.Name.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1514 / 1534] RFC 5322
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.DateTime.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m public import Time
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Header.Name.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Header.Value.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Header.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Mailbox.LocalPart.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Mailbox.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m public import RFC_1123
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Message.ID.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m public import RFC_1123
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1516 / 1534] RFC 5322
[1518 / 1534] RFC 5322
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Mailbox.LocalPart.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1525 / 1543] RFC 5322 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Message.ID.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m public import RFC_1123
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1527 / 1543] RFC 5322 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Mailbox.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m public import RFC_1123
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1528 / 1543] RFC 5322 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Header.Value.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.Header.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1529 / 1543] RFC 5322 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 5322/RFC_5322.DateTime.swift:3:8: [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m1 |[0;0m import ASCII
[0;36m2 |[0;0m public import Byte
[0;36m|[0;0m `- [1;39mnote: [1;39mimported 'public' here[0;0m
[0;36m3 |[0;0m import Byte
[0;36m|[0;0m `- [1;33mwarning: [1;39mmodule 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored[0;0m [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
[0;36m4 |[0;0m import INCITS_4_1986
[0;36m5 |[0;0m public import Time
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1529 / 1544] RFC 5322
[1531 / 1545] RFC 5322
[1532 / 1545] RFC 5322 Foundation Integration
[1540 / 1545] Calendar Gregorian
[1542 / 1545] RFC 5322-product
[1542 / 1545] RFC 5322 Foundation Integration
Build complete! (34.98 secs)
Build complete.
{
"dependencies" : [
{
"identity" : "swift-rfc-1123",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-ietf/swift-rfc-1123.git"
},
{
"identity" : "swift-standard-library-extensions",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-atoms/swift-standard-library-extensions.git"
},
{
"identity" : "swift-time",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-atoms/swift-time.git"
},
{
"identity" : "swift-calendar",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-atoms/swift-calendar.git"
},
{
"identity" : "swift-calendar-gregorian",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-molecules/swift-calendar-gregorian.git"
},
{
"identity" : "swift-ascii",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-atoms/swift-ascii.git"
},
{
"identity" : "swift-incits-4-1986",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-incits/swift-incits-4-1986.git"
},
{
"identity" : "swift-byte",
"requirement" : {
"branch" : [
"main"
]
},
"type" : "sourceControl",
"url" : "https://github.com/swift-atoms/swift-byte.git"
}
],
"manifest_display_name" : "swift-rfc-5322",
"name" : "swift-rfc-5322",
"path" : "/host/spi-builder-workspace",
"platforms" : [
{
"name" : "macos",
"version" : "27.0"
},
{
"name" : "ios",
"version" : "27.0"
},
{
"name" : "tvos",
"version" : "27.0"
},
{
"name" : "watchos",
"version" : "27.0"
},
{
"name" : "visionos",
"version" : "27.0"
}
],
"products" : [
{
"name" : "RFC 5322",
"targets" : [
"RFC 5322"
],
"type" : {
"library" : [
"automatic"
]
}
},
{
"name" : "RFC 5322 Foundation Integration",
"targets" : [
"RFC 5322 Foundation Integration"
],
"type" : {
"library" : [
"automatic"
]
}
}
],
"swift_languages_versions" : [
"6"
],
"targets" : [
{
"c99name" : "RFC_5322_Tests",
"module_type" : "SwiftTarget",
"name" : "RFC 5322 Tests",
"path" : "Tests/RFC 5322 Tests",
"product_dependencies" : [
"ASCII",
"Byte",
"Byte",
"Time"
],
"sources" : [
"README Tests.swift",
"RFC_5322.DateTime Signed Field Tests.swift",
"RFC_5322.DateTime Tests.swift",
"RFC_5322.Header Tests.swift",
"RFC_5322.Mailbox Tests.swift",
"RFC_5322.Mailbox+Edge Case.swift",
"RFC_5322.Message Tests.swift",
"RFC_5322.Message+Edge Case.swift"
],
"target_dependencies" : [
"RFC 5322"
],
"type" : "test"
},
{
"c99name" : "RFC_5322_Foundation_Integration_Tests",
"module_type" : "SwiftTarget",
"name" : "RFC 5322 Foundation Integration Tests",
"path" : "Tests/RFC 5322 Foundation Integration Tests",
"sources" : [
"RFC_5322+Codable Tests.swift",
"RFC_5322.Date.FormatStyle Tests.swift"
],
"target_dependencies" : [
"RFC 5322",
"RFC 5322 Foundation Integration"
],
"type" : "test"
},
{
"c99name" : "RFC_5322_Foundation_Integration",
"module_type" : "SwiftTarget",
"name" : "RFC 5322 Foundation Integration",
"path" : "Sources/RFC 5322 Foundation Integration",
"product_dependencies" : [
"Byte"
],
"product_memberships" : [
"RFC 5322 Foundation Integration"
],
"sources" : [
"RFC_5322.Date.FormatStyle.swift",
"RFC_5322.DateTime+Codable.swift",
"RFC_5322.Header+Codable.swift",
"RFC_5322.Header.Name+Codable.swift",
"RFC_5322.Header.Value+Codable.swift",
"RFC_5322.Mailbox+Codable.swift",
"RFC_5322.Message.ID+Codable.swift"
],
"target_dependencies" : [
"RFC 5322"
],
"type" : "library"
},
{
"c99name" : "RFC_5322",
"module_type" : "SwiftTarget",
"name" : "RFC 5322",
"path" : "Sources/RFC 5322",
"product_dependencies" : [
"Standard Library Extensions",
"Time",
"Calendar",
"Calendar Gregorian",
"RFC 1123",
"ASCII",
"Byte",
"Calendar Gregorian",
"INCITS 4 1986"
],
"product_memberships" : [
"RFC 5322",
"RFC 5322 Foundation Integration"
],
"sources" : [
"RFC_5322.DateTime.Components.Error.swift",
"RFC_5322.DateTime.Components.swift",
"RFC_5322.DateTime.Error.swift",
"RFC_5322.DateTime.swift",
"RFC_5322.Error.swift",
"RFC_5322.Header.Error.swift",
"RFC_5322.Header.Name.Error.swift",
"RFC_5322.Header.Name.swift",
"RFC_5322.Header.Value.Error.swift",
"RFC_5322.Header.Value.swift",
"RFC_5322.Header.swift",
"RFC_5322.Mailbox.Error.swift",
"RFC_5322.Mailbox.Limits.swift",
"RFC_5322.Mailbox.LocalPart.Error.swift",
"RFC_5322.Mailbox.LocalPart.swift",
"RFC_5322.Mailbox.swift",
"RFC_5322.Message.Error.swift",
"RFC_5322.Message.ID.Error.swift",
"RFC_5322.Message.ID.swift",
"RFC_5322.Message.swift",
"RFC_5322.swift",
"Swift.String+RFC_5322.swift",
"exports.swift"
],
"type" : "library"
}
],
"tools_version" : "6.4"
}
basic-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:c77fcce225e223ac0fafed844619173fc6de8d62dd560eeb28db3182af6a282b
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:basic-6.4-latest
warning: 'spi-builder-workspace': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
Done.