The Swift Package Index logo.Swift Package Index

Build Information

Successful build of swift-rfc-2045, reference main (0d5b95), with Swift 6.4 for Wasm on 2 Oct 2026 23:29:04 UTC.

Swift 6 data race errors: 0

Build Command

bash -c docker run --pull=always --rm -v "checkouts-54344844-0":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:wasm-6.4-latest swift build --swift-sdk swift-6.4.x-DEVELOPMENT-SNAPSHOT-2026-09-04-a_wasm 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 5.1.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/swift-ietf/swift-rfc-2045.git
Reference: main
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/swift-ietf/swift-rfc-2045
 * branch            main       -> FETCH_HEAD
 * [new branch]      main       -> origin/main
HEAD is now at 0d5b95e Split the Foundation integration out of the core
Cloned https://github.com/swift-ietf/swift-rfc-2045.git
Revision (git rev-parse @):
0d5b95ebeee3caf09fdfc9a587c22f31c7e5f334
SPI manifest file found: $PWD/.spi.yml
SUCCESS checkout https://github.com/swift-ietf/swift-rfc-2045.git at main
========================================
Build
========================================
Selected platform:         wasm
Swift version:             6.4
Building package at path:  $PWD
https://github.com/swift-ietf/swift-rfc-2045.git
Running build ...
bash -c docker run --pull=always --rm -v "checkouts-54344844-0":/host -w "$PWD" -e JAVA_HOME="/root/.sdkman/candidates/java/current" -e SPI_BUILD="1" -e SPI_PROCESSING="1" registry.gitlab.com/saguaro1/spi-images:wasm-6.4-latest swift build --swift-sdk swift-6.4.x-DEVELOPMENT-SNAPSHOT-2026-09-04-a_wasm 2>&1
wasm-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:4328fdb43c680d205c1d6761b1e3267aa38277eefdda9ddfb17b6a0f1a77857a
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:wasm-6.4-latest
Fetching https://github.com/swift-atoms/swift-ascii.git
[1/780] Fetching swift-ascii
Fetched https://github.com/swift-atoms/swift-ascii.git (0.43s)
Fetching https://github.com/swift-atoms/swift-byte.git
[1/594] Fetching swift-byte
Fetched https://github.com/swift-atoms/swift-byte.git (0.43s)
Fetching https://github.com/swift-ietf/swift-rfc-5322.git
[1/1337] Fetching swift-rfc-5322
Fetched https://github.com/swift-ietf/swift-rfc-5322.git (0.43s)
Fetching https://github.com/swift-atoms/swift-carrier.git
[1/1402] Fetching swift-carrier
Fetched https://github.com/swift-atoms/swift-carrier.git (0.41s)
Fetching https://github.com/swift-atoms/swift-checkpoint.git
[1/73] Fetching swift-checkpoint
Fetched https://github.com/swift-atoms/swift-checkpoint.git (0.39s)
Fetching https://github.com/swift-atoms/swift-coder.git
[1/1030] Fetching swift-coder
Fetched https://github.com/swift-atoms/swift-coder.git (0.42s)
Fetching https://github.com/swift-atoms/swift-cursor.git
[1/304] Fetching swift-cursor
Fetched https://github.com/swift-atoms/swift-cursor.git (0.38s)
Fetching https://github.com/swift-atoms/swift-iterator.git
[1/628] Fetching swift-iterator
Fetched https://github.com/swift-atoms/swift-iterator.git (0.90s)
Fetching https://github.com/swift-atoms/swift-parser.git
[1/4492] Fetching swift-parser
Fetched https://github.com/swift-atoms/swift-parser.git (0.51s)
Fetching https://github.com/swift-atoms/swift-serializer.git
[1/852] Fetching swift-serializer
Fetched https://github.com/swift-atoms/swift-serializer.git (0.39s)
Fetching https://github.com/swift-atoms/swift-bit.git
[1/853] Fetching swift-bit
Fetched https://github.com/swift-atoms/swift-bit.git (0.40s)
Fetching https://github.com/swift-atoms/swift-index.git
[1/1055] Fetching swift-index
Fetched https://github.com/swift-atoms/swift-index.git (0.45s)
Fetching https://github.com/swift-atoms/swift-finite.git
[1/824] Fetching swift-finite
Fetched https://github.com/swift-atoms/swift-finite.git (0.42s)
Fetching https://github.com/swift-atoms/swift-ordinal.git
[1/1465] Fetching swift-ordinal
Fetched https://github.com/swift-atoms/swift-ordinal.git (0.40s)
Fetching https://github.com/swift-atoms/swift-tagged.git
[1/1858] Fetching swift-tagged
Fetched https://github.com/swift-atoms/swift-tagged.git (0.44s)
Fetching https://github.com/swift-ietf/swift-rfc-1123.git
[1/605] Fetching swift-rfc-1123
Fetched https://github.com/swift-ietf/swift-rfc-1123.git (0.59s)
Fetching https://github.com/swift-atoms/swift-standard-library-extensions.git
[1/1234] Fetching swift-standard-library-extensions
Fetched https://github.com/swift-atoms/swift-standard-library-extensions.git (0.47s)
Fetching https://github.com/swift-atoms/swift-time.git
[1/1049] Fetching swift-time
Fetched https://github.com/swift-atoms/swift-time.git (0.47s)
Fetching https://github.com/swift-atoms/swift-calendar.git
[1/157] Fetching swift-calendar
Fetched https://github.com/swift-atoms/swift-calendar.git (0.35s)
Fetching https://github.com/swift-molecules/swift-calendar-gregorian.git
[1/139] Fetching swift-calendar-gregorian
Fetched https://github.com/swift-molecules/swift-calendar-gregorian.git (0.37s)
Fetching https://github.com/swift-incits/swift-incits-4-1986.git
[1/1301] Fetching swift-incits-4-1986
Fetched https://github.com/swift-incits/swift-incits-4-1986.git (0.60s)
Fetching https://github.com/swift-atoms/swift-always.git
[1/65] Fetching swift-always
Fetched https://github.com/swift-atoms/swift-always.git (0.36s)
Fetching https://github.com/swift-atoms/swift-repetition.git
[1/40] Fetching swift-repetition
Fetched https://github.com/swift-atoms/swift-repetition.git (0.34s)
Fetching https://github.com/swift-atoms/swift-cardinal.git
[1/1437] Fetching swift-cardinal
Fetched https://github.com/swift-atoms/swift-cardinal.git (0.49s)
Fetching https://github.com/swift-atoms/swift-predicate.git
[1/537] Fetching swift-predicate
Fetched https://github.com/swift-atoms/swift-predicate.git (0.47s)
Fetching https://github.com/swift-atoms/swift-either.git
[1/399] Fetching swift-either
Fetched https://github.com/swift-atoms/swift-either.git (0.45s)
Fetching https://github.com/swift-atoms/swift-pair.git
[1/375] Fetching swift-pair
Fetched https://github.com/swift-atoms/swift-pair.git (0.36s)
Fetching https://github.com/swift-atoms/swift-skip.git
[1/30] Fetching swift-skip
Fetched https://github.com/swift-atoms/swift-skip.git (0.38s)
Fetching https://github.com/swift-atoms/swift-map.git
[1/36] Fetching swift-map
Fetched https://github.com/swift-atoms/swift-map.git (0.64s)
Fetching https://github.com/swift-atoms/swift-optic.git
[1/761] Fetching swift-optic
Fetched https://github.com/swift-atoms/swift-optic.git (0.52s)
Fetching https://github.com/swift-atoms/swift-operation.git
[1/322] Fetching swift-operation
Fetched https://github.com/swift-atoms/swift-operation.git (0.45s)
Fetching https://github.com/swift-atoms/swift-empty.git
[1/178] Fetching swift-empty
Fetched https://github.com/swift-atoms/swift-empty.git (0.35s)
Fetching https://github.com/swift-atoms/swift-single.git
[1/199] Fetching swift-single
Fetched https://github.com/swift-atoms/swift-single.git (1.43s)
Fetching https://github.com/swift-atoms/swift-search.git
[1/45] Fetching swift-search
Fetched https://github.com/swift-atoms/swift-search.git (0.33s)
Fetching https://github.com/swift-atoms/swift-append.git
[1/33] Fetching swift-append
Fetched https://github.com/swift-atoms/swift-append.git (0.34s)
Fetching https://github.com/swift-atoms/swift-flatmap.git
[1/30] Fetching swift-flatmap
Fetched https://github.com/swift-atoms/swift-flatmap.git (0.33s)
Fetching https://github.com/swift-atoms/swift-lazy.git
[1/76] Fetching swift-lazy
Fetched https://github.com/swift-atoms/swift-lazy.git (0.36s)
Fetching https://github.com/swift-atoms/swift-collection.git
[1/1295] Fetching swift-collection
Fetched https://github.com/swift-atoms/swift-collection.git (0.53s)
Fetching https://github.com/swift-atoms/swift-product.git
[1/602] Fetching swift-product
Fetched https://github.com/swift-atoms/swift-product.git (0.45s)
Fetching https://github.com/swift-atoms/swift-difference.git
[1/176] Fetching swift-difference
Fetched https://github.com/swift-atoms/swift-difference.git (0.34s)
Fetching https://github.com/swift-atoms/swift-algebra.git
[1/1674] Fetching swift-algebra
Fetched https://github.com/swift-atoms/swift-algebra.git (0.42s)
Fetching https://github.com/swift-atoms/swift-polarity.git
[1/219] Fetching swift-polarity
Fetched https://github.com/swift-atoms/swift-polarity.git (0.41s)
Fetching https://github.com/swift-atoms/swift-magnitude.git
[1/103] Fetching swift-magnitude
Fetched https://github.com/swift-atoms/swift-magnitude.git (0.35s)
Fetching https://github.com/swift-atoms/swift-property.git
[1/1563] Fetching swift-property
Fetched https://github.com/swift-atoms/swift-property.git (0.44s)
Fetching https://github.com/swift-atoms/swift-successor.git
[1/68] Fetching swift-successor
Fetched https://github.com/swift-atoms/swift-successor.git (0.31s)
Fetching https://github.com/swift-atoms/swift-predecessor.git
[1/68] Fetching swift-predecessor
Fetched https://github.com/swift-atoms/swift-predecessor.git (0.35s)
Fetching https://github.com/swift-atoms/swift-advancement.git
[1/68] Fetching swift-advancement
Fetched https://github.com/swift-atoms/swift-advancement.git (0.32s)
Fetching https://github.com/swift-atoms/swift-retreat.git
[1/68] Fetching swift-retreat
Fetched https://github.com/swift-atoms/swift-retreat.git (0.34s)
Fetching https://github.com/swift-atoms/swift-distance.git
[1/68] Fetching swift-distance
Fetched https://github.com/swift-atoms/swift-distance.git (0.34s)
Fetching https://github.com/swift-ietf/swift-rfc-1035.git
[1/697] Fetching swift-rfc-1035
Fetched https://github.com/swift-ietf/swift-rfc-1035.git (0.43s)
Fetching https://github.com/swift-atoms/swift-addition.git
[1/79] Fetching swift-addition
Fetched https://github.com/swift-atoms/swift-addition.git (0.34s)
Fetching https://github.com/swift-atoms/swift-coordinate.git
[1/49] Fetching swift-coordinate
Fetched https://github.com/swift-atoms/swift-coordinate.git (0.43s)
Fetching https://github.com/swift-atoms/swift-translation.git
[1/47] Fetching swift-translation
Fetched https://github.com/swift-atoms/swift-translation.git (0.39s)
Fetching https://github.com/swift-atoms/swift-division.git
[1/84] Fetching swift-division
Fetched https://github.com/swift-atoms/swift-division.git (0.36s)
Fetching https://github.com/swift-atoms/swift-rational.git
[1/115] Fetching swift-rational
Fetched https://github.com/swift-atoms/swift-rational.git (0.40s)
Fetching https://github.com/swift-atoms/swift-ratio.git
[1/163] Fetching swift-ratio
Fetched https://github.com/swift-atoms/swift-ratio.git (0.39s)
Fetching https://github.com/swift-atoms/swift-subtraction.git
[1/59] Fetching swift-subtraction
Fetched https://github.com/swift-atoms/swift-subtraction.git (0.36s)
Fetching https://github.com/swift-atoms/swift-logic.git
[1/1008] Fetching swift-logic
Fetched https://github.com/swift-atoms/swift-logic.git (0.36s)
Fetching https://github.com/swift-atoms/swift-contramap.git
[1/33] Fetching swift-contramap
Fetched https://github.com/swift-atoms/swift-contramap.git (0.32s)
Fetching https://github.com/swift-atoms/swift-bifunctor.git
[1/213] Fetching swift-bifunctor
Fetched https://github.com/swift-atoms/swift-bifunctor.git (0.45s)
Fetching https://github.com/swift-atoms/swift-coproduct.git
[1/429] Fetching swift-coproduct
Fetched https://github.com/swift-atoms/swift-coproduct.git (0.42s)
Fetching https://github.com/swift-atoms/swift-sequence.git
[1/2186] Fetching swift-sequence
Fetched https://github.com/swift-atoms/swift-sequence.git (0.49s)
Fetching https://github.com/swift-atoms/swift-order.git
[1/864] Fetching swift-order
Fetched https://github.com/swift-atoms/swift-order.git (0.83s)
Fetching https://github.com/swift-atoms/swift-ownership.git
[1/3106] Fetching swift-ownership
Fetched https://github.com/swift-atoms/swift-ownership.git (1.06s)
Fetching https://github.com/swift-atoms/swift-vector.git
[1/118] Fetching swift-vector
Fetched https://github.com/swift-atoms/swift-vector.git (0.46s)
Fetching https://github.com/swift-atoms/swift-rounding.git
[1/61] Fetching swift-rounding
Fetched https://github.com/swift-atoms/swift-rounding.git (0.38s)
Fetching https://github.com/swift-atoms/swift-integer.git
[1/105] Fetching swift-integer
Fetched https://github.com/swift-atoms/swift-integer.git (0.39s)
Fetching https://github.com/swift-atoms/swift-multiplication.git
[1/79] Fetching swift-multiplication
Fetched https://github.com/swift-atoms/swift-multiplication.git (0.98s)
Fetching https://github.com/swift-atoms/swift-memory.git
[1/1981] Fetching swift-memory
Fetched https://github.com/swift-atoms/swift-memory.git (0.48s)
Fetching https://github.com/swift-atoms/swift-span.git
[1/433] Fetching swift-span
Fetched https://github.com/swift-atoms/swift-span.git (0.46s)
Fetching https://github.com/swift-atoms/swift-error.git
[1/350] Fetching swift-error
Fetched https://github.com/swift-atoms/swift-error.git (0.41s)
Fetching https://github.com/swiftlang/swift-syntax.git
[1/80201] Fetching swift-syntax
Fetched https://github.com/swiftlang/swift-syntax.git (3.51s)
Computing version for https://github.com/swiftlang/swift-syntax.git
Computed https://github.com/swiftlang/swift-syntax.git at 603.0.2 (4.72s)
Creating working copy for https://github.com/swift-atoms/swift-vector.git
Working copy of https://github.com/swift-atoms/swift-vector.git resolved at main (915cd7c)
Creating working copy for https://github.com/swift-atoms/swift-single.git
Working copy of https://github.com/swift-atoms/swift-single.git resolved at main (e468dca)
Creating working copy for https://github.com/swift-atoms/swift-coder.git
Working copy of https://github.com/swift-atoms/swift-coder.git resolved at main (627a31c)
Creating working copy for https://github.com/swift-atoms/swift-time.git
Working copy of https://github.com/swift-atoms/swift-time.git resolved at main (c6cb993)
Creating working copy for https://github.com/swift-atoms/swift-rounding.git
Working copy of https://github.com/swift-atoms/swift-rounding.git resolved at main (5481997)
Creating working copy for https://github.com/swift-atoms/swift-algebra.git
Working copy of https://github.com/swift-atoms/swift-algebra.git resolved at main (6f0468a)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1123.git
Working copy of https://github.com/swift-ietf/swift-rfc-1123.git resolved at main (0563819)
Creating working copy for https://github.com/swift-atoms/swift-division.git
Working copy of https://github.com/swift-atoms/swift-division.git resolved at main (fe65e48)
Creating working copy for https://github.com/swift-atoms/swift-ratio.git
Working copy of https://github.com/swift-atoms/swift-ratio.git resolved at main (089c5d6)
Creating working copy for https://github.com/swift-atoms/swift-tagged.git
Working copy of https://github.com/swift-atoms/swift-tagged.git resolved at main (6e00f02)
Creating working copy for https://github.com/swift-atoms/swift-flatmap.git
Working copy of https://github.com/swift-atoms/swift-flatmap.git resolved at main (03442d2)
Creating working copy for https://github.com/swift-atoms/swift-subtraction.git
Working copy of https://github.com/swift-atoms/swift-subtraction.git resolved at main (4614d98)
Creating working copy for https://github.com/swift-atoms/swift-collection.git
Working copy of https://github.com/swift-atoms/swift-collection.git resolved at main (7013fe3)
Creating working copy for https://github.com/swift-atoms/swift-successor.git
Working copy of https://github.com/swift-atoms/swift-successor.git resolved at main (ab8561a)
Creating working copy for https://github.com/swiftlang/swift-syntax.git
Working copy of https://github.com/swiftlang/swift-syntax.git resolved at 603.0.2
Creating working copy for https://github.com/swift-atoms/swift-iterator.git
Working copy of https://github.com/swift-atoms/swift-iterator.git resolved at main (e276f0c)
Creating working copy for https://github.com/swift-atoms/swift-empty.git
Working copy of https://github.com/swift-atoms/swift-empty.git resolved at main (134c48b)
Creating working copy for https://github.com/swift-atoms/swift-repetition.git
Working copy of https://github.com/swift-atoms/swift-repetition.git resolved at main (b2fafee)
Creating working copy for https://github.com/swift-atoms/swift-bifunctor.git
Working copy of https://github.com/swift-atoms/swift-bifunctor.git resolved at main (18fe386)
Creating working copy for https://github.com/swift-atoms/swift-logic.git
Working copy of https://github.com/swift-atoms/swift-logic.git resolved at main (91fbf3b)
Creating working copy for https://github.com/swift-atoms/swift-operation.git
Working copy of https://github.com/swift-atoms/swift-operation.git resolved at main (6b09f83)
Creating working copy for https://github.com/swift-atoms/swift-standard-library-extensions.git
Working copy of https://github.com/swift-atoms/swift-standard-library-extensions.git resolved at main (a727a9e)
Creating working copy for https://github.com/swift-atoms/swift-sequence.git
Working copy of https://github.com/swift-atoms/swift-sequence.git resolved at main (7c462e3)
Creating working copy for https://github.com/swift-atoms/swift-predecessor.git
Working copy of https://github.com/swift-atoms/swift-predecessor.git resolved at main (42a711d)
Creating working copy for https://github.com/swift-atoms/swift-calendar.git
Working copy of https://github.com/swift-atoms/swift-calendar.git resolved at main (92ed545)
Creating working copy for https://github.com/swift-atoms/swift-skip.git
Working copy of https://github.com/swift-atoms/swift-skip.git resolved at main (728b918)
Creating working copy for https://github.com/swift-atoms/swift-carrier.git
Working copy of https://github.com/swift-atoms/swift-carrier.git resolved at main (ee19248)
Creating working copy for https://github.com/swift-atoms/swift-coordinate.git
Working copy of https://github.com/swift-atoms/swift-coordinate.git resolved at main (6c56b05)
Creating working copy for https://github.com/swift-atoms/swift-ordinal.git
Working copy of https://github.com/swift-atoms/swift-ordinal.git resolved at main (bdb3f64)
Creating working copy for https://github.com/swift-atoms/swift-span.git
Working copy of https://github.com/swift-atoms/swift-span.git resolved at main (81b5071)
Creating working copy for https://github.com/swift-atoms/swift-memory.git
Working copy of https://github.com/swift-atoms/swift-memory.git resolved at main (dc058d2)
Creating working copy for https://github.com/swift-atoms/swift-parser.git
Working copy of https://github.com/swift-atoms/swift-parser.git resolved at main (0913ad9)
Creating working copy for https://github.com/swift-atoms/swift-order.git
Working copy of https://github.com/swift-atoms/swift-order.git resolved at main (a1866fe)
Creating working copy for https://github.com/swift-atoms/swift-map.git
Working copy of https://github.com/swift-atoms/swift-map.git resolved at main (317c5f8)
Creating working copy for https://github.com/swift-atoms/swift-cursor.git
Working copy of https://github.com/swift-atoms/swift-cursor.git resolved at main (0c4eb8c)
Creating working copy for https://github.com/swift-atoms/swift-either.git
Working copy of https://github.com/swift-atoms/swift-either.git resolved at main (46c666a)
Creating working copy for https://github.com/swift-atoms/swift-checkpoint.git
Working copy of https://github.com/swift-atoms/swift-checkpoint.git resolved at main (aa7b4ec)
Creating working copy for https://github.com/swift-atoms/swift-pair.git
Working copy of https://github.com/swift-atoms/swift-pair.git resolved at main (d71085f)
Creating working copy for https://github.com/swift-atoms/swift-always.git
Working copy of https://github.com/swift-atoms/swift-always.git resolved at main (1229653)
Creating working copy for https://github.com/swift-atoms/swift-distance.git
Working copy of https://github.com/swift-atoms/swift-distance.git resolved at main (1856165)
Creating working copy for https://github.com/swift-atoms/swift-product.git
Working copy of https://github.com/swift-atoms/swift-product.git resolved at main (d4702f8)
Creating working copy for https://github.com/swift-atoms/swift-byte.git
Working copy of https://github.com/swift-atoms/swift-byte.git resolved at main (50bd3e3)
Creating working copy for https://github.com/swift-atoms/swift-advancement.git
Working copy of https://github.com/swift-atoms/swift-advancement.git resolved at main (b947ae1)
Creating working copy for https://github.com/swift-atoms/swift-property.git
Working copy of https://github.com/swift-atoms/swift-property.git resolved at main (5b9a7f3)
Creating working copy for https://github.com/swift-molecules/swift-calendar-gregorian.git
Working copy of https://github.com/swift-molecules/swift-calendar-gregorian.git resolved at main (301a29c)
Creating working copy for https://github.com/swift-atoms/swift-index.git
Working copy of https://github.com/swift-atoms/swift-index.git resolved at main (425b76c)
Creating working copy for https://github.com/swift-ietf/swift-rfc-1035.git
Working copy of https://github.com/swift-ietf/swift-rfc-1035.git resolved at main (215fda4)
Creating working copy for https://github.com/swift-atoms/swift-optic.git
Working copy of https://github.com/swift-atoms/swift-optic.git resolved at main (72cf3fd)
Creating working copy for https://github.com/swift-atoms/swift-addition.git
Working copy of https://github.com/swift-atoms/swift-addition.git resolved at main (7662e87)
Creating working copy for https://github.com/swift-atoms/swift-append.git
Working copy of https://github.com/swift-atoms/swift-append.git resolved at main (5a2c22d)
Creating working copy for https://github.com/swift-atoms/swift-magnitude.git
Working copy of https://github.com/swift-atoms/swift-magnitude.git resolved at main (6c31511)
Creating working copy for https://github.com/swift-atoms/swift-error.git
Working copy of https://github.com/swift-atoms/swift-error.git resolved at main (f6ad8ee)
Creating working copy for https://github.com/swift-atoms/swift-predicate.git
Working copy of https://github.com/swift-atoms/swift-predicate.git resolved at main (57d2250)
Creating working copy for https://github.com/swift-incits/swift-incits-4-1986.git
Working copy of https://github.com/swift-incits/swift-incits-4-1986.git resolved at main (b208aff)
Creating working copy for https://github.com/swift-atoms/swift-cardinal.git
Working copy of https://github.com/swift-atoms/swift-cardinal.git resolved at main (a4beb26)
Creating working copy for https://github.com/swift-atoms/swift-finite.git
Working copy of https://github.com/swift-atoms/swift-finite.git resolved at main (f3eac5b)
Creating working copy for https://github.com/swift-atoms/swift-search.git
Working copy of https://github.com/swift-atoms/swift-search.git resolved at main (ab399f1)
Creating working copy for https://github.com/swift-atoms/swift-translation.git
Working copy of https://github.com/swift-atoms/swift-translation.git resolved at main (32e900c)
Creating working copy for https://github.com/swift-atoms/swift-rational.git
Working copy of https://github.com/swift-atoms/swift-rational.git resolved at main (f973aa9)
Creating working copy for https://github.com/swift-atoms/swift-contramap.git
Working copy of https://github.com/swift-atoms/swift-contramap.git resolved at main (c719674)
Creating working copy for https://github.com/swift-atoms/swift-multiplication.git
Working copy of https://github.com/swift-atoms/swift-multiplication.git resolved at main (f07296d)
Creating working copy for https://github.com/swift-atoms/swift-serializer.git
Working copy of https://github.com/swift-atoms/swift-serializer.git resolved at main (3971b0a)
Creating working copy for https://github.com/swift-atoms/swift-lazy.git
Working copy of https://github.com/swift-atoms/swift-lazy.git resolved at main (f12c258)
Creating working copy for https://github.com/swift-atoms/swift-polarity.git
Working copy of https://github.com/swift-atoms/swift-polarity.git resolved at main (4880d7d)
Creating working copy for https://github.com/swift-atoms/swift-integer.git
Working copy of https://github.com/swift-atoms/swift-integer.git resolved at main (05212bf)
Creating working copy for https://github.com/swift-atoms/swift-bit.git
Working copy of https://github.com/swift-atoms/swift-bit.git resolved at main (30f6189)
Creating working copy for https://github.com/swift-atoms/swift-difference.git
Working copy of https://github.com/swift-atoms/swift-difference.git resolved at main (fb95a3f)
Creating working copy for https://github.com/swift-ietf/swift-rfc-5322.git
Working copy of https://github.com/swift-ietf/swift-rfc-5322.git resolved at main (e9864e0)
Creating working copy for https://github.com/swift-atoms/swift-ownership.git
Working copy of https://github.com/swift-atoms/swift-ownership.git resolved at main (f8702ec)
Creating working copy for https://github.com/swift-atoms/swift-ascii.git
Working copy of https://github.com/swift-atoms/swift-ascii.git resolved at main (a365691)
Creating working copy for https://github.com/swift-atoms/swift-retreat.git
Working copy of https://github.com/swift-atoms/swift-retreat.git resolved at main (c78a367)
Creating working copy for https://github.com/swift-atoms/swift-coproduct.git
Working copy of https://github.com/swift-atoms/swift-coproduct.git resolved at main (224eb87)
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-5322': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-5322': ignoring duplicate product 'Calendar Gregorian' from package 'swift-calendar-gregorian'
warning: 'swift-rfc-1123': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-rfc-1035': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'swift-collection': ignoring duplicate product 'Order' from package 'swift-order'
Building for debugging...
[Computing dependencies]
[Provisioning 2 / 143]
[Constructing description]
[Pre-planning 1 / 2194]
[Planning 199 / 2194]
[Planning 1349 / 2194]
[Planning 1803 / 2194]
[Planning deferred tasks]
[Constructing 399 / 5137]
[Starting]
[200 / 867] Memory
[379 / 884] Translation
[395 / 940] Single
[428 / 949] Vector
[436 / 949] Vector
[437 / 949] Product
[439 / 949] Product
[454 / 949] Translation
[456 / 949] Translation
[462 / 950] Translation
[464 / 950] Translation
[468 / 950] Standard Library Extensions
[470 / 951] Standard Library Extensions
[477 / 952] Search-product
[485 / 953] Single
[489 / 953] Single
[495 / 954] Search
[503 / 954] Pair-product
[514 / 955] Operation
[527 / 957] Logic
[539 / 963] Vector-product
[552 / 982] Lazy
[573 / 995] Error
[589 / 996] Error-product
[597 / 996] Empty-product
[605 / 997] Either
[624 / 1030] Polarity
[637 / 1050] Polarity
[668 / 1050] Either
[671 / 1050] Checkpoint
[676 / 1052] Polarity
[687 / 1052] Carrier-product
[692 / 1052] Carrier
[704 / 1053] Always
[714 / 1055] Algebra
[722 / 1056] Logic
[725 / 1062] Standard Library Extensions-product
[734 / 1063]
[744 / 1079] Multiplication
[746 / 1088] Algebra
[750 / 1089] Tagged
[764 / 1089] Tagged
[773 / 1090] Ownership
[777 / 1090] Magnitude
[783 / 1091] Optic
[790 / 1101] Predicate
[800 / 1103] Magnitude
[810 / 1109] Ownership
[816 / 1128] Addition
[825 / 1129] Ownership
[835 / 1129] Ownership
[843 / 1129] Property
[847 / 1129] Successor
[857 / 1137] Subtraction
[880 / 1154] Retreat
[884 / 1158] Retreat
[905 / 1159] Property
[913 / 1164] Advancement
[926 / 1169] Predicate
[942 / 1173] Order
[947 / 1190] Cardinal
[950 / 1190] Order
[957 / 1190] Distance-product
[960 / 1190] Cardinal
[965 / 1191] Cardinal
[975 / 1197] Rounding
[978 / 1201] Rounding
[985 / 1201] Repetition
[997 / 1204]
[1006 / 1218] Division
[1009 / 1240] Iterator
[1013 / 1240] Rounding
[1025 / 1241] Iterator
[1028 / 1241] Difference
[1045 / 1241] Iterator-product
[1048 / 1241] Integer-product
[1052 / 1242] Iterator
[1054 / 1242] Rational
[1059 / 1242] Integer
[1066 / 1255] Ordinal
[1070 / 1271] Rational
[1073 / 1273] Cursor
[1086 / 1273] Rational
[1089 / 1273] Ordinal
[1093 / 1274] Rational
[1096 / 1274] Rational
[1102 / 1274] Cursor
[1107 / 1274] Cursor
[1114 / 1276] Repetition
[1132 / 1281] Ordinal
[1142 / 1291] Index
[1146 / 1291] Index
[1150 / 1292]
[1155 / 1301] Finite
[1157 / 1301] Finite
[1159 / 1301] Finite
[1165 / 1302]
[1168 / 1311] Collection
[1169 / 1311] Collection
[1176 / 1311] Finite
[1180 / 1312] Byte
[1187 / 1322] Byte
[1190 / 1323] Sequence
[1200 / 1323] Collection-product
[1204 / 1325] Byte
[1217 / 1334] Parser
[1224 / 1346] Span
[1230 / 1355] Span
[1245 / 1355] Span-product
[1257 / 1356]
[1263 / 1360] Serializer
[1276 / 1378] Memory
[1281 / 1378] Memory
[1289 / 1378] Coder-product
[1291 / 1380] Coder
[1294 / 1381] ASCII
[1300 / 1389] ASCII
[1300 / 1389] Memory
[1304 / 1389] Memory
[1313 / 1400] Ratio
[1315 / 1400] Ratio
[1319 / 1400] Ratio
[1325 / 1400] Memory
[1327 / 1401] Ratio
[1341 / 1411] Time
[1342 / 1412] Time
[1346 / 1412] Time
[1355 / 1415] Calendar
[1360 / 1442] RFC 1035
[1361 / 1442] INCITS 4 1986
[1364 / 1442] Calendar
[1370 / 1442] RFC 1035
[1372 / 1442] RFC 1035
[1373 / 1442] RFC 1035
[1381 / 1443] Time
[1391 / 1443] Time
[1395 / 1443] INCITS 4 1986
[1400 / 1444] RFC 1035
[1404 / 1445]
[1411 / 1463] RFC 1123
[1413 / 1463] RFC 1123
[1419 / 1463] RFC 1123
[1422 / 1463] RFC 1123
[1428 / 1465] Calendar Gregorian
[1435 / 1465] Calendar Gregorian-product
[1437 / 1465] Calendar
[1440 / 1467] RFC 5322
[1443 / 1476] Calendar Gregorian
[1445 / 1476] RFC 5322
[1446 / 1476] RFC 5322
[1449 / 1476] RFC 5322
[1450 / 1476] RFC 1123
[1459 / 1486] RFC 2045
[1462 / 1487] RFC 2045
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Charset.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentTransferEncoding.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentType.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Parameter.Name.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045.Parameter {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1464 / 1487] RFC 2045
[1466 / 1487] RFC 2045
[1467 / 1487] RFC 2045
[1475 / 1488] RFC 2045 Foundation Integration
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Parameter.Name.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045.Parameter {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.Charset.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentTransferEncoding.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1481 / 1494] RFC 5322
[1483 / 1494] RFC 2045 Foundation Integration
[1490 / 1495] RFC 2045
/host/spi-builder-workspace/Sources/RFC 2045/RFC_2045.ContentType.swift:3:8: warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  1 | import ASCII
  2 | public import Byte
    |               `- note: imported 'public' here
  3 | import Byte
    |        `- warning: module 'Byte' is imported as 'public' from the same file; this 'internal' access level will be ignored [#]8;;https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access\InconsistentImportAccess]8;;\]
  4 |
  5 | extension RFC_2045 {
[#InconsistentImportAccess]: <https://docs.swift.org/compiler/documentation/diagnostics/inconsistent-import-access>
[1496 / 1496] RFC 2045 Foundation Integration-product
Build complete! (30.07 secs)
Build complete.
{
  "dependencies" : [
    {
      "identity" : "swift-ascii",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-atoms/swift-ascii.git"
    },
    {
      "identity" : "swift-byte",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-atoms/swift-byte.git"
    },
    {
      "identity" : "swift-rfc-5322",
      "requirement" : {
        "branch" : [
          "main"
        ]
      },
      "type" : "sourceControl",
      "url" : "https://github.com/swift-ietf/swift-rfc-5322.git"
    }
  ],
  "manifest_display_name" : "swift-rfc-2045",
  "name" : "swift-rfc-2045",
  "path" : "/host/spi-builder-workspace",
  "platforms" : [
    {
      "name" : "macos",
      "version" : "27.0"
    },
    {
      "name" : "ios",
      "version" : "27.0"
    },
    {
      "name" : "tvos",
      "version" : "27.0"
    },
    {
      "name" : "watchos",
      "version" : "27.0"
    },
    {
      "name" : "visionos",
      "version" : "27.0"
    }
  ],
  "products" : [
    {
      "name" : "RFC 2045",
      "targets" : [
        "RFC 2045"
      ],
      "type" : {
        "library" : [
          "automatic"
        ]
      }
    },
    {
      "name" : "RFC 2045 Foundation Integration",
      "targets" : [
        "RFC 2045 Foundation Integration"
      ],
      "type" : {
        "library" : [
          "automatic"
        ]
      }
    }
  ],
  "swift_languages_versions" : [
    "6"
  ],
  "targets" : [
    {
      "c99name" : "RFC_2045_Tests",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Tests",
      "path" : "Tests/RFC 2045 Tests",
      "product_dependencies" : [
        "ASCII",
        "Byte",
        "Byte",
        "RFC 5322"
      ],
      "sources" : [
        "RFC_2045.Charset Tests.swift",
        "RFC_2045.ContentTransferEncoding Tests.swift",
        "RFC_2045.ContentType Tests.swift",
        "RFC_2045.Parameter.Name Tests.swift",
        "RFC_5322.Header.Name Tests.swift"
      ],
      "target_dependencies" : [
        "RFC 2045"
      ],
      "type" : "test"
    },
    {
      "c99name" : "RFC_2045_Foundation_Integration_Tests",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Foundation Integration Tests",
      "path" : "Tests/RFC 2045 Foundation Integration Tests",
      "sources" : [
        "RFC_2045+Codable Tests.swift"
      ],
      "target_dependencies" : [
        "RFC 2045",
        "RFC 2045 Foundation Integration"
      ],
      "type" : "test"
    },
    {
      "c99name" : "RFC_2045_Foundation_Integration",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045 Foundation Integration",
      "path" : "Sources/RFC 2045 Foundation Integration",
      "product_memberships" : [
        "RFC 2045 Foundation Integration"
      ],
      "sources" : [
        "RFC_2045.Charset+Codable.swift",
        "RFC_2045.ContentTransferEncoding+Codable.swift",
        "RFC_2045.ContentType+Codable.swift",
        "RFC_2045.Parameter.Name+Codable.swift"
      ],
      "target_dependencies" : [
        "RFC 2045"
      ],
      "type" : "library"
    },
    {
      "c99name" : "RFC_2045",
      "module_type" : "SwiftTarget",
      "name" : "RFC 2045",
      "path" : "Sources/RFC 2045",
      "product_dependencies" : [
        "ASCII",
        "Byte",
        "Byte",
        "RFC 5322"
      ],
      "product_memberships" : [
        "RFC 2045",
        "RFC 2045 Foundation Integration"
      ],
      "sources" : [
        "RFC_2045.Charset.Error.swift",
        "RFC_2045.Charset.swift",
        "RFC_2045.ContentTransferEncoding.Error.swift",
        "RFC_2045.ContentTransferEncoding.swift",
        "RFC_2045.ContentType.Error.swift",
        "RFC_2045.ContentType.swift",
        "RFC_2045.Grammar.swift",
        "RFC_2045.Parameter.Name.Error.swift",
        "RFC_2045.Parameter.Name.swift",
        "RFC_2045.Parameter.swift",
        "RFC_2045.swift",
        "RFC_5322.Header.Name.swift"
      ],
      "type" : "library"
    }
  ],
  "tools_version" : "6.4"
}
wasm-6.4-latest: Pulling from saguaro1/spi-images
Digest: sha256:4328fdb43c680d205c1d6761b1e3267aa38277eefdda9ddfb17b6a0f1a77857a
Status: Image is up to date for registry.gitlab.com/saguaro1/spi-images:wasm-6.4-latest
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
warning: 'spi-builder-workspace': ignoring duplicate product 'Byte' from package 'swift-byte'
Done.