The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build LiveFader with Swift 5.10 for macOS (SPM).

Build Command

env DEVELOPER_DIR=/Applications/Xcode-15.3.0.app xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.39.0
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/cemolcay/livefader.git
Reference: 1.1.0
Initialized empty Git repository in /Users/builder/builds/UKfvDsi8u/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/cemolcay/livefader
 * tag               1.1.0      -> FETCH_HEAD
HEAD is now at 25eab09 Update README.md
Cloned https://github.com/cemolcay/livefader.git
Revision (git rev-parse @):
25eab09eed323d6e39c5360e3a70f0cdd399f54d
SUCCESS checkout https://github.com/cemolcay/livefader.git at 1.1.0
========================================
ResolveProductDependencies
========================================
Resolving dependencies ...
{
  "identity": ".resolve-product-dependencies",
  "name": "resolve-dependencies",
  "url": "/Users/builder/builds/UKfvDsi8u/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies",
  "version": "unspecified",
  "path": "/Users/builder/builds/UKfvDsi8u/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies",
  "dependencies": [
    {
      "identity": "livefader",
      "name": "LiveFader",
      "url": "https://github.com/cemolcay/livefader.git",
      "version": "unspecified",
      "path": "/Users/builder/builds/UKfvDsi8u/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/.resolve-product-dependencies/.build/checkouts/livefader",
      "dependencies": [
      ]
    }
  ]
}
Fetching https://github.com/cemolcay/livefader.git
[2/126] Fetching livefader
Fetched https://github.com/cemolcay/livefader.git from cache (0.27s)
Creating working copy for https://github.com/cemolcay/livefader.git
Working copy of https://github.com/cemolcay/livefader.git resolved at 1.1.0 (25eab09)
warning: '.resolve-product-dependencies': dependency 'livefader' is not used by any target
Found 0 product dependencies
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.10
Building package at path:  $workDir
https://github.com/cemolcay/livefader.git
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.3.0.app xcrun swift build --arch arm64
Building for debugging...
[0/2] Write sources
[1/2] Write swift-version-6044DDE57671499D.txt
error: emit-module command failed with exit code 1 (use -v to see invocation)
[3/5] Emitting module LiveFader
/Users/builder/builds/UKfvDsi8u/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/LiveFader/LiveFader.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[4/5] Compiling LiveFader LiveFader.swift
/Users/builder/builds/UKfvDsi8u/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/LiveFader/LiveFader.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
[5/5] Compiling LiveFader LiveFaderScrollView.swift
/Users/builder/builds/UKfvDsi8u/0/finestructure/swiftpackageindex-builder/spi-builder-workspace/Sources/LiveFader/LiveFader.swift:9:8: error: no such module 'UIKit'
import UIKit
       ^
error: fatalError
BUILD FAILURE 5.10 macosSpm

Build Machine: Mac 7