The Swift Package Index logo.Swift Package Index

Track the adoption of Swift 6 strict concurrency checks for data race safety. How many packages are Ready for Swift 6?

Build Information

Failed to build nostr-kit with Swift 5.8 for macOS (SPM).

Build Command

env DEVELOPER_DIR="/Applications/Xcode-14.3.0.app" xcrun swift build --arch arm64

Build Log

========================================
RunAll
========================================
Builder version: 4.21.4
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/tannerdsilva/nostr-kit.git
Reference: master
Initialized empty Git repository in /Users/builder/builds/o86TiJKT/3/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/tannerdsilva/nostr-kit
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at e91c853 release v0.6.0
Cloned https://github.com/tannerdsilva/nostr-kit.git into spi-builder-workspace
e91c85387712b702c47a610def5c90cb91b25e2a
SUCCESS checkout https://github.com/tannerdsilva/nostr-kit.git at master
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.8
Building package at path:  spi-builder-workspace
Running build ...
env DEVELOPER_DIR="/Applications/Xcode-14.3.0.app" xcrun swift build --arch arm64
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.0
ShellOut encountered an error
Status code: 1
Message: "error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.0"
Output: ""
Retrying in 0.0 seconds ...
Building ... (attempt 2)
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.0
ShellOut encountered an error
Status code: 1
Message: "error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.9.0 but the installed version is 5.8.0"
Output: ""
BUILD FAILURE 5.8 macosSpm

Build Machine: Mac 5