The Swift Package Index logo.Swift Package Index

Build Information

Failed to build SwordRPC with Swift 5.9 for macOS (SPM).

Build Command

Build command unavailable

Build Log

========================================
RunAll
========================================
Builder version: 4.27.1
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/Azoy/SwordRPC.git
Reference: master
Initialized empty Git repository in /Users/admin/builds/J1XnyXFH/1/finestructure/swiftpackageindex-builder/spi-builder-workspace/.git/
From https://github.com/Azoy/SwordRPC
 * branch            master     -> FETCH_HEAD
 * [new branch]      master     -> origin/master
HEAD is now at 97535a2 TMPDIR Function bby
Cloned https://github.com/Azoy/SwordRPC.git
Revision (git rev-parse @):
97535a22bdca462f8b91e8a7349391fb2344d757
SUCCESS checkout https://github.com/Azoy/SwordRPC.git at master
Fetching https://github.com/IBM-Swift/BlueSocket.git from cache
Fetched https://github.com/IBM-Swift/BlueSocket.git (0.25s)
Computing version for https://github.com/IBM-Swift/BlueSocket.git
error: the Swift tools version specification is missing a label; consider inserting 'swift-tools-version:' between the comment marker and the version specifier
========================================
Build
========================================
Selected platform:         macosSpm
Swift version:             5.9
Building package at path:  $PWD/checkout
Running build ...
env DEVELOPER_DIR=/Applications/Xcode-15.0.0.app xcrun swift build --arch arm64
Updating https://github.com/IBM-Swift/BlueSocket.git
Updated https://github.com/IBM-Swift/BlueSocket.git (0.19s)
Computing version for https://github.com/IBM-Swift/BlueSocket.git
error: the Swift tools version specification is missing a label; consider inserting 'swift-tools-version:' between the comment marker and the version specifier
Updating https://github.com/IBM-Swift/BlueSocket.git
Updated https://github.com/IBM-Swift/BlueSocket.git (0.23s)
Computing version for https://github.com/IBM-Swift/BlueSocket.git
error: the Swift tools version specification is missing a label; consider inserting 'swift-tools-version:' between the comment marker and the version specifier
BUILD FAILURE 5.9 macosSpm