The Swift Package Index logo.Swift Package Index

Build Information

Failed to build Source with Swift 5.9 for Linux.

Build Command

bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build --triple x86_64-unknown-linux-gnu 2>&1

Build Log

========================================
RunAll
========================================
Builder version: 4.33.2
Interrupt handler set up.
========================================
Checkout
========================================
Clone URL: https://github.com/blackjacx/Source.git
Reference: develop
Initialized empty Git repository in /host/spi-builder-workspace/.git/
hint: Using 'master' as the name for the initial branch. This default branch name
hint: is subject to change. To configure the initial branch name to use in all
hint: of your new repositories, which will suppress this warning, call:
hint:
hint: 	git config --global init.defaultBranch <name>
hint:
hint: Names commonly chosen instead of 'master' are 'main', 'trunk' and
hint: 'development'. The just-created branch can be renamed via this command:
hint:
hint: 	git branch -m <name>
From https://github.com/blackjacx/Source
 * branch            develop    -> FETCH_HEAD
 * [new branch]      develop    -> origin/develop
HEAD is now at 0cca773 Update X url
Cloned https://github.com/blackjacx/Source.git
Revision (git rev-parse @):
0cca7730391f02fd015a298aa146ce0759047bde
SUCCESS checkout https://github.com/blackjacx/Source.git at develop
========================================
Build
========================================
Selected platform:         linux
Swift version:             5.9
Building package at path:  $workDir
https://github.com/blackjacx/Source.git
Running build ...
bash -c docker run --rm -v "checkouts-4609320-0":/host -w "$workDir" registry.gitlab.com/finestructure/spi-images:basic-5.9-latest swift build --triple x86_64-unknown-linux-gnu 2>&1
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.10.0 but the installed version is 5.9.2
error: 'spi-builder-workspace': package 'spi-builder-workspace' is using Swift tools version 5.10.0 but the installed version is 5.9.2
BUILD FAILURE 5.9 linux

Build Machine: Linux 2