Packages for keyword “internationalization”
These packages are available as a package collection, usable in Xcode or SwiftPM.
TranslateKit
SF Symbols for Texts: 2000+ built-in translations in 40 languages + semantic localization key macro for Swift devs
swift-iso-3166
Swift implementation of ISO 3166: Country codes.
swift-iso-639
Swift implementation of ISO 639: Language codes.
swift-rfc-3987
Swift implementation of RFC 3987: Internationalized Resource Identifiers (IRIs).
ReRune
Over-the-air localization SDK for iOS. Update translations and add dashboard-managed app languages after release via Swift Package Manager.
swift-rfc-3492
Swift implementation of RFC 3492: Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA).
swift-rfc-5890
Swift implementation of RFC 5890: Internationalized Domain Names for Applications (IDNA): Definitions and Document Framework.
LocaleSupport
Swift references and extensions for app localization & internationalization.
Aksara
Aksara means a letter, multi-platform live localization runtime for iOS (Swift) & Android (Kotlin): shared JSON, OTA updates, live UI.
StringCatalogKit
Swift toolkit for reading, writing, and translating Xcode .xcstrings string catalogs with provider-agnostic and LLM-powered workflows.
SVGFlags
Xcode-compatible SVG country (and more!) flags with real colors - circle, rect, and full-size variants
11 packages.