Packages for keyword “json-parser”
These packages are available as a package collection, usable in Xcode or SwiftPM.
FlatBuffers
FlatBuffers: Memory Efficient Serialization Library
SwiftyJSON
The better way to deal with JSON data in Swift.
MetaCodable
Supercharge Swift's Codable implementations with macros meta-programming.
DynamicJSON
Framework for representing, validating, querying, and manipulating generic JSON values in Swift 6. Supported are standards such as JSON Text Sequences (RFC 7464), JSON Pointer (RFC 6901), JSON Path (RFC 9535), JSON Patch (RFC 6902), JSON Merge Patch (RFC 7396), and JSON Schema.
Swift-JSON
Exact JSON for modern Swift: lossless decimals and Unicode scalar keys, offline Draft 2020-12 schemas, transactional JSON Patch, and pull-driven streams with finite budgets. Swift 6.4+, macOS 27+. Apache-2.0.
swift-stream-parsing
Type-safe incremental parsing in Swift.
MacroCodableKit
Boilerplate-free Codable for Swift. Supports AllOf / OneOf (OpenAPI), adjacently tagged enums, custom coding keys, default values, and value strategies — all via macros with zero runtime overhead
Iatheto
A simple JSON framework
JSONParser
Elegant, type-safe JSON parsing in Swift
JSONUtilities
Easily load JSON objects and decode them into structs or classes
DynamicCodableKit
Implement dynamic JSON decoding within the constraints of Swift's sound type system by working on top of Swift's Codable implementations.
11 packages.