Packages for keyword “standards”
These packages are available as a package collection, usable in Xcode or SwiftPM.
swift-html-standard
Unified wrapper over the WHATWG HTML Living Standard, with complete, attributes-only, and elements-only products, for Swift.
swift-iso-639
Swift implementation of ISO 639: Language codes.
swift-iso-9899
Swift implementation of ISO/IEC 9899: Programming languages - C.
swift-rfc-791
Swift implementation of RFC 791: Internet Protocol.
swift-whatwg-html
Swift implementation of WHATWG HTML Living Standard.
swift-color-standard
Unified Color type converting between sRGB, CIE LAB, CIE LCH, Oklab, Oklch, and CIE XYZ color spaces for Swift.
swift-rfc-4648
Swift implementation of RFC 4648: The Base16, Base32, and Base64 Data Encodings.
swift-w3c-css
Modular implementations of 40+ W3C CSS module specifications — Cascade, Selectors, Color, Flexbox, Grid, Animations, Transforms, and more — for Swift.
swift-w3c-svg
Swift implementation of W3C Scalable Vector Graphics 2.
swift-css-standard
Unified facade over the W3C CSS specifications with CSSOM-based serialization for Swift.
swift-domain-standard
RFC 1035, 1123, and 5321 domain name validation for Swift.
swift-ieee-754
Swift implementation of IEEE 754: IEEE Standard for Floating-Point Arithmetic.
swift-incits-4-1986
Swift implementation of INCITS 4-1986: US-ASCII.
swift-iso-3166
Swift implementation of ISO 3166: Country codes.
swift-iso-8601
Swift implementation of ISO 8601: Date and time format.
swift-rfc-1035
Swift implementation of RFC 1035: Domain Names - Implementation and Specification.
swift-rfc-1123
Swift implementation of RFC 1123: Requirements for Internet Hosts - Application and Support.
swift-rfc-2045
Swift implementation of RFC 2045: Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies.
swift-rfc-3987
Swift implementation of RFC 3987: Internationalized Resource Identifiers (IRIs).
swift-rfc-4291
Swift implementation of RFC 4291: IP Version 6 Addressing Architecture.