Swift Package Index


Vapor 3 Package for pre-populating any database with Spice related data.


  • The latest stable release is 0.1.0. Released 2 years ago.
  • The last commit to master was 2 years ago.

Swift Version Compatibility

  • 0.1.0 and master
    5.3
    5.2
    5.1
    5.0
    4.2
Full build results

Platform Compatibility

  • 0.1.0 and master
    iOS
    macOS(Intel)
    macOS(ARM)
    Linux
    tvOS
    watchOS
Full build results

VaporSpices

Vapor 3 Package for pre-populating any database with Spice related data.

Import it into your project:

let package = Package(name: "TestVaporSpices",
dependencies: [      
//VaporSpices
  .package(url: "https://github.com/mihaelamj/VaporSpices", from: "0.1.0")
],
targets: [
  .target(name: "App", dependencies: ["FluentSQLite", "FluentMySQL", "FluentPostgreSQL", "VaporSpices"]),
]
)

Usage (for MySQL) :

import VaporSpices

migrations.addVaporSpices(for: .mysql)

Usage (for PostgreSQL) :

import VaporSpices

migrations.addVaporSpices(for: .psql)

Usage (for SQLite) :

import VaporSpices

migrations.addVaporSpices(for: .sqlite)